1.配置基本的集成IS-IS路由协议
2.多区域的集成IS-IS配置
3.IS-IS认证
4.IS-IS路由泄露
5.IS-IS汇总
6.在IS-IS中手动产生一条默认路由
7.IS-IS协议重分布
8.用IS-IS支持IPv6
9.用IS-IS多拓扑支持IPv6
10.在帧中继环境中运行IS-IS

enable
conf t
no ip do lo
enable pass cisco
line con 0
logg sync
exec-t 0 0
line vty 0 4
pass cisco
logg sync
exit
host

1.配置基本的集成IS-IS路由协议

R1:
int l0
ip add 11.1.1.1 255.255.255.0
no shut
exit
int f0/0
ip add 12.1.1.1 255.255.255.0
no shut
exit

router isis
net 49.0001.0000.0000.0001.00
log-adjacency-changes
exit
int f0/0
ip router isis
exit
int l0
ip router isis
exit

R2:
int f0/0
ip add 12.1.1.2 255.255.255.0
no shut
exit
int l0
ip add 22.1.1.1 255.255.255.0
no shut
exit
int f0/1
ip add 23.1.1.2 255.255.255.0
no shut
exit

router isis
net 49.0001.0000.0000.0002.00
log-adjacency-changes
exit
int f0/0
ip router isis
exit
int l0
ip router isis
exit
int f0/1
ip router isis
exit

R3:
int f0/1
ip add 23.1.1.3 255.255.255.0
no shut
exit
int l0
ip add 33.1.1.1 255.255.255.0
no shut
exit

router isis
net 49.0001.0000.0000.0003.00
log-adjacency-changes
exit
int f0/1
ip router isis
exit
int l0
ip router isis
exit

R2:
show clns neighbors
show clns protocol
show clns int f0/0
show isis hostname
show isis topology
show isis database
conf t
int f0/1
isis priority 100
exit
show isis database
show ip route isis

R3:
show run int l0
router isis
passive-interface l0
exit
show run int l0

R1:
show ip route isis
show clns neighbors
router isis
passive-interface f0/0
exit
show clns neighbors
conf t
int f0/0
ip router isis
exit
show clns neighbors

2.多区域的集成IS-IS配置
-------------------------------------------------------------------------

R1:
int l0
ip add 11.1.1.1 255.255.255.0
no shut
exit
int f0/0
ip add 12.1.1.1 255.255.255.0
no shut
exit

router isis
net 49.0001.0000.0000.0001.00
exit
int l0
ip router isis
exit
int f0/0
ip router isis
exit

R2:
int f0/0
ip add 12.1.1.2 255.255.255.0
no shut
exit
int l0
ip add 22.1.1.1 255.255.255.0
no shut
exit
int f0/1
ip add 23.1.1.2 255.255.255.0
no shut
exit

router isis
net 49.0001.0000.0000.0002.00
exit
int f0/0
ip router isis
exit
int l0
ip router isis
exit
int f0/1
ip router isis
exit

R3:
int f0/1
ip add 23.1.1.3 255.255.255.0
no shut
exit
int l0
ip add 33.1.1.1 255.255.255.0
no shut
exit
int f0/0
ip add 34.1.1.3 255.255.255.0
no shut
exit

router isis
net 49.0002.0000.0000.0003.00
exit
int f0/1
ip router isis
exit
int l0
ip router isis
exit
int f0/0
ip router isis
exit

R4:
int f0/0
ip add 34.1.1.4 255.255.255.0
no shut
exit
int l0
ip add 44.1.1.1 255.255.255.0
no shut
exit
int f0/1
ip add 45.1.1.4 255.255.255.0
no shut
exit

router isis
net 49.0002.0000.0000.0004.00
exit
int f0/0
ip router isis
exit
int l0
ip router isis
exit
int f0/1
ip router isis
exit

R5:
int f0/1
ip add 45.1.1.5 255.255.255.0
no shut
exit
int l0
ip add 55.1.1.1 255.255.255.0
no shut
exit
int f0/0
ip add 56.1.1.5 255.255.255.0
no shut
exit

router isis
net 49.0003.0000.0000.0005.00
exit
int f0/1
ip router isis
exit
int l0
ip router isis
exit
int f0/0
ip router isis
exit

R6:
int f0/0
ip add 56.1.1.6 255.255.255.0
no shut
exit
int l0
ip add 66.1.1.1 255.255.255.0
no shut
exit

router isis
net 49.0003.0000.0000.0006.00
exit
int f0/0
ip router isis
exit
int l0
ip router isis
exit

定义骨干区域和非骨干区域
------------------------------------------------
R1:
router isis
is-type level-1
exit

R2:
router isis
is-type level-1-2
exit

R3:
router isis
is-type level-2
exit

R4:
router isis
is-type level-2
exit

R5:
router isis
is-type level-1-2
exit

R6:
router isis
is-type level-1
exit

修改接口电路类型
------------------------------------------------
R2:
int f0/0
isis circuit-type level-1
exit
int f0/1
isis circuit-type level-2
exit

R5:
int f0/0
isis circuit-type level-1
exit
int f0/1
isis circuit-type level-2
exit

3.ISIS认证
--------------------------------------------------
邻居认证:在接口上配置
(R1,R2)
R1:
int f0/0
isis password yeslab level-1
exit

R2:
int f0/0
isis password yeslab level-1
exit

(R2,R3)
R2:
int f0/1
isis password yeslab level-2
exit

R3:
int f0/1
isis password yeslab level-2
exit

(R3,R4)
R3:
key chain yeslab
key 1
key-string cisco
exit
exit
int f0/0
isis authentication mode md5 level-2
isis authentication key-chain yeslab level-2
exit

R4:
key chain yeslab
key 1
key-string cisco
exit
exit
int f0/0
isis authentication mode md5 level-2
isis authentication key-chain yeslab level-2
exit

区域认证
(49.0001区域)
R1:
router isis
area-password yeslab
exit
show ip route isis

R2:
router isis
area-password yeslab
exit

(49.0003区域)
R5:
key chain yeslab
key 1
key-string cisco
exit
exit
router isis
authentication mode md5 level-1
authentication key-chain yeslab level-1
exit

R6:
key chain yeslab
key 1
key-string cisco
exit
exit
router isis
authentication mode md5 level-1
authentication key-chain yeslab level-1
exit

域认证
(R2,R3,R4,R5)
R2:
router isis
domain-password yeslab
exit

R3:
router isis
domain-password yeslab
exit

R4:
router isis
domain-password yeslab
exit

R5:
router isis
domain-password yeslab
exit
------------------------------------------
R2:
key chain yeslab2
key 1
key-string cisco
exit
exit
router isis
no domain-password
authentication mode md5 level-2
authentication key-chain yeslab level-2
exit

R3:
key chain yeslab2
key 1
key-string cisco
exit
exit
router isis
no domain-password
authentication mode md5 level-2
authentication key-chain yeslab level-2
exit

R4:
key chain yeslab2
key 1
key-string cisco
exit
exit
router isis
no domain-password
authentication mode md5 level-2
authentication key-chain yeslab level-2
exit

R5:
key chain yeslab2
key 1
key-string cisco
exit
exit
router isis
no domain-password
authentication mode md5 level-2
authentication key-chain yeslab level-2
exit

4.IS-IS路由泄露
R2:
access-list 100 permit ip host 66.1.1.0 any
router isis
redistribute isis ip level-2 into level-1 distribute-list 100
exit

router isis
no redistribute isis ip level-2 into level-1 distribute-list 100
exit

access-list 10 permit 55.1.1.0
route-map yeslab permit 10
match ip add 10
exit

router isis
redistribute isis ip level-2 into level-1 route-map yeslab
exit

5.IS-IS路由汇总
R3:
show ip route isis

R2:
router isis
summary-add 11.1.0.0 255.255.0.0 metric 100
exit

R3:
show ip route isis
--------------------------------------------------------
R1:
show ip route isis

R2:
access-list 10 permit 66.1.1.0
route-map yeslab permit 10
match ip address 10
exit
router isis
redistribute isis ip level-2 into level-1 route-map yeslab
exit

R1:
show ip route isis

R2:
router isis
summary-add 66.1.0.0 255.255.0.0 level-1
exit

R1:
show ip route isis

R2:
show ip route isis

6.在IS-IS中手动产生一条默认路由
7.IS-IS协议重分布
8.用IS-IS支持IPv6
9.用IS-IS多拓扑支持IPv6
10.在帧中继环境中运行IS-IS

CCIE路由实验(10) -- IS-IS的更多相关文章

  1. CCIE路由实验(9) -- IPv6

    1.IPv6地址的各种情况2.配置通过DHCP-PD方式分配前缀信息3.IPv6路由基本配置4.IPv6路由--RIPng5.IPv6路由--EIGRPv66.IPv6路由--OSPFv37.IPv6 ...

  2. CCIE路由实验(7) -- MPLS VPN

    1.LDP协议的各种情况2.LDP和BGP交互3.LDP高级部分4.MPLS VPN (RIP和静态)5.MPLS VPN (EIGRP)6.MPLS VPN (OSPF)7.MPLS VPN (EB ...

  3. CCIE路由实验(6) -- 组播Multicasting

    1.组播IGMP的各种情况2.PIM Dense-Mode3.PIM Sparse-Mode4.PIM双向树和SSM5.动态RP之auto-rp6.动态RP之BSR7.Anycast RP8.域间组播 ...

  4. CCIE路由实验(3) -- BGP高级部分

    当一个AS包含多个IBGP对等体时,路由反射器非常有用.因为IBGP客户只需要和路由反射器建立邻居关系,从而降低了IBGP的连接数量.路由反射器和它的客户合称为一个簇.路由反射是克服IBGP水平分割的 ...

  5. CCIE路由实验(2) -- BGP选路原则

    BGP路径属性分为4类: 公认必遵(Well-Known Mandatory):BGP更新报文中必须包含的,且必须被所有BGP厂商实现所能识别的,包括ORIGIN,AS-PATH和Next_Hop 1 ...

  6. CCIE路由实验(8) -- QoS

    1.查看端口缺省的队列机制2.配置CB-WFQ3.配置CB-LLQ4.配置CB-Shapping在以太接口下5.配置CB-Shapping在FR接口下6.配置帧中继流量整形FRTS7.配置CB-Pol ...

  7. CCIE路由实验(4) -- BGP路由控制

    1.过滤BGP路由的方法2.用AS-path filter控制路由3.用Community Filter控制路由 enableconf tno ip do loenable pass ciscolin ...

  8. CCIE路由实验(5) -- BGP负载均衡

    enableconf tno ip do loenable pass ciscoline con 0logg syncexec-t 0 0exitline vty 0 4pass ciscologg ...

  9. CCNA CCNP CCIE所有实验名称完整版

    实验1:通过Console端口访问Cisco路由器  实验2:通过Telnet访问Cisco路由器  实验3:配置终端服务器  实验4:通过浏览器访问路由器  实验5:模式切换.上下文帮助及查看有关信 ...

随机推荐

  1. Django : Table 'MyDjango.django_admin_log' doesn't exist

    原因: 添加admin之后,没有运行 manage.py syncdb 解决方法: 在命令行中运行manage.py syncdb 即可 运行截图:

  2. Web APIs 基于令牌TOKEN验证的实现

    Web APIs 基于令牌TOKEN验证的实现 概述: ASP.NET Web API 的好用使用过的都知道,没有复杂的配置文件,一个简单的ApiController加上需要的Action就能工作.但 ...

  3. Windows Phone 8本地化多语言支持

    原文 Windows Phone 8本地化多语言支持 在WP8平台处理本地化多语言的支持还是比较容易的,大部分工作都有VS IDE处理,开发者只需简单操作,并翻译本地资源即可实现. 无论您目前的应用是 ...

  4. STL front() ,back()和begin(),end()区别

    首先看看vector里面的: reference front(); const_reference front() const; queue里面的: value_type& front(); ...

  5. Exploring the MapBox stack: MBTiles, TileJSON, UTFGrids and Wax

    转自:http://blog.thematicmapping.org/2012/11/exploring-mapbox-stack-mbtiles-tilejson.html In my last b ...

  6. 文件队列 QueueFile

    /** * Copyright (C) 2010 Square, Inc. * * Licensed under the Apache License, Version 2.0 (the " ...

  7. iOS学习之NSAttributedString(富文本)

    NSAttributedString 叫做富文本,是一种带有属性的字符串,通过它可以轻松的在一个字符串中表现出多种字体.字号.字体大小等各不相同的风格,还可以对段落进行格式化,一般都是对可变富文本(N ...

  8. POJ--1300--Door Man【推断无向图欧拉通路】

    链接:http://poj.org/problem?id=1300 题意:有n个房间.每一个房间有若干个门和别的房间相连.管家从m房间開始走.要回到自己的住处(0),问是否有一条路能够走遍全部的门而且 ...

  9. stm32之Systick(系统时钟)

    Systick的两大作用: 1.可以产生精确延时: 2.可以提供给操作系统一个单独的心跳(时钟)节拍: 通常实现Delay(N)函数的方法为: for(i=0;i<x;i++) ; 对于STM3 ...

  10. ListView.MultiChoiceModeListener

    参考:http://www.cnblogs.com/a284628487/p/3460400.html和http://blog.csdn.net/mayingcai1987/article/detai ...