HSRP:
1.启用HSRP功能,并设置虚拟地址IP, 1为standby的组号。
2.相同组号的路由器属于同一个HSRP组,所有属于同一个HSRP组的路由器的虚拟地址必须一致。
3.HSRP的优先级默认为100,该值越大抢占为活动路由器的优先权越高
4.可以设置路由器是否抢占为活动路由器
5.由于局域网内大多使用三层交换机,此时HSRP是在交换机的SVI接口上配置的。

1.网关冗余热备份协议HSRP(CISCO私有)
2.VRRP
3.GLBP

enable
conf t
no ip do lo
enable pass cisco
line con 0
logg sync
exec-t 0 0
line vty 0 4
pass cisco
logg sync
exit
host

1.网关冗余热备份协议HSRP(CISCO私有)
-------------------------------------------------------------------------

R1:
int e0/0
ip add 10.1.1.1 255.255.255.0
no shut
exit
int e0/1
ip add 13.1.1.1 255.255.255.0
no shut
exit

router rip
version 2
no auto-summary
network 10.0.0.0
network 13.0.0.0
passive-int e0/0
exit

R2:
int e0/0
ip add 10.1.1.2 255.255.255.0
no shut
exit
int e0/1
ip add 23.1.1.2 255.255.255.0
no shut
exit

router rip
version 2
no auto-summary
network 10.0.0.0
network 23.0.0.0
passive-interface e0/0
exit

R3:
int l0
ip add 33.1.1.1 255.255.255.0
exit
int e0/1
ip add 13.1.1.3 255.255.255.0
no shut
exit
int e0/2
ip add 23.1.1.3 255.255.255.0
no shut
exit

router rip
version 2
no auto-summary
network 33.0.0.0
network 13.0.0.0
network 23.0.0.0
exit

R1:
int e0/0
standby 1 ip 10.1.1.254
standby 1 priority 120
standby 1 preempt
standby 1 authentication mode md5 key-string cisco

standby 2 ip 10.1.1.253
standby 2 preempt
standby 2 authentication mode md5 key-string cisco
exit

R2:
int e0/0
standby 1 ip 10.1.1.254
standby 1 preempt
standby 1 authentication mode md5 key-string cisco

standby 2 ip 10.1.1.253
standby 2 priority 120
standby 2 preempt
standby 2 authentication mode md5 key-string cisco
exit

R1/R2:
show standby brief

PC1:
no ip routing
int e0/0
ip add 10.1.1.100 255.255.255.0
no shut
exit
ip default-gateway 10.1.1.254

ping 33.1.1.1 repeat 10000

R3:
show standby brief

R1:
int e0/0
shutdown
exit

R3:
show standby brief

R1:
int e0/0
standby 1 track e0/1 30
exit

int e0/1
shutdown
exit

show standby brief
show standby

2.VRRP
--------------------------------------------------------------------------
R1:
default int e0/0

int e0/0
ip add 10.1.1.1 255.255.255.0
no shut
exit

router rip
network 10.0.0.0
passive-int e0/0
exit

R2:
default int e0/0

int e0/0
ip add 10.1.1.2 255.255.255.0
no shut
exit

router rip
network 10.0.0.0
passive-interface e0/0
exit

R1:
track 1 int e0/1 line-protocol
exit

int e0/0
vrrp 1 ip 10.1.1.254
vrrp 1 priority 120
vrrp 1 preempt
vrrp 1 authentication mode md5 key-string cisco
vrrp 2 ip 10.1.1.253
vrrp 2 preempt
vrrp 2 authentication mode md5 key-string cisco
vrrp 2 track 1 decrement 30
exit

R2:
track 1 int e0/1 line-protocol
exit

int e0/0
vrrp 1 ip 10.1.1.254
vrrp 1 priority 120
vrrp 1 preempt
vrrp 1 authentication mode md5 key-string cisco
vrrp 2 ip 10.1.1.253
vrrp 2 priority 120
vrrp 2 preempt
vrrp 2 authentication mode md5 key-string cisco
vrrp 2 track 1 decrement 30
exit

R1/R2:
show vrrp brief

3. GLBP
--------------------------------------------------------------------

R1:
int e0/0
ip add 10.1.1.1 255.255.255.0
no shut
exit
int e0/1
ip add 20.1.1.1 255.255.255.0
no shut
exit

router rip
version 2
no auto-summary
network 10.0.0.0
network 20.0.0.0
passive-interface e0/0
exit

R2:
int e0/0
ip add 10.1.1.2 255.255.255.0
no shut
exit
int e0/1
ip add 20.1.1.2 255.255.255.0
no shut
exit

router rip
version 2
no auto-summary
network 10.0.0.0
network 20.0.0.0
passive-interface e0/0
exit

R3:
int e0/0
ip add 10.1.1.3 255.255.255.0
no shut
exit
int e0/1
ip add 20.1.1.3 255.255.255.0
no shut
exit

router rip
version 2
no auto-summary
network 10.0.0.0
network 20.0.0.0
passive-interface e0/0
exit

R4:
int l0
ip add 44.1.1.1 255.255.255.0
exit
int e0/0
ip add 20.1.1.4 255.255.255.0
no shut
exit

router rip
version 2
no auto-summary
network 20.0.0.0
network 44.0.0.0
exit

-----------------------------------------------------
R1:
int e0/0
glbp 1 ip 10.1.1.254
glbp 1 priority 200
glbp 1 preempt
glbp 1 authentication text cisco
exit

R2:
int e0/0
glbp 1 ip 10.1.1.254
glbp 1 priority 180
glbp 1 preempt
glbp 1 authentication text cisco
exit

R3:
int e0/0
glbp 1 ip 10.1.1.254
glbp 1 priority 160
glbp 1 preempt
glbp 1 authentication text cisco
exit

R1:
show glbp

R7-PC1:
no ip routing

int e0/0
ip add 10.1.1.100 255.255.255.0
no shut
exit
ip default-gateway 10.1.1.254

ping 44.1.1.1
show arp
clear arp cache
ping 44.1.1.1
show arp

跟踪上行链路
------------------------------------------------------
R1:
track 2 int e0/1 line-protocol

int e0/0
glbp 1 wighting 110 lower 85 upper 105
glb1 1 weighting track 2 decrement 50

CCNP交换实验(5) -- 网关热备冗余的更多相关文章

  1. CCNP交换实验(7) -- NAT

    1.静态NAT2.动态NAT3.复用内部全局地址的NAT(PAT) enableconf tno ip do loenable pass ciscoline con 0logg syncexec-t ...

  2. [na]vrrp两用(网关冗余+服务器热备)

    VRRP的两种用途 早上想了想vrrp的使用,1,网关冗余 2,服务器热备 思想稍微有点不一样.主要在于监控口 服务器的话有心跳线,用户同步一些配置和迁移一些服务.达到热备的目的.:牵涉到四个优先级: ...

  3. web双机热备添加心跳检测ip的时候填了网关导致外网ip不能上网

    web双机热备添加心跳检测ip的时候填了网关导致外网ip不能上网 1 连接 机器其他机器, 通过机房做的服务器的局域网,ssh到这台的局域网ip,删除网卡配置文件的网关哪一行,重启网卡. 2 如果没有 ...

  4. Nginx+keepalived双机热备(主从模式)

    负载均衡技术对于一个网站尤其是大型网站的web服务器集群来说是至关重要的!做好负载均衡架构,可以实现故障转移和高可用环境,避免单点故障,保证网站健康持续运行.关于负载均衡介绍,可以参考:linux负载 ...

  5. Nginx+keepalived 双机热备(主从模式)

    负载均衡技术对于一个网站尤其是大型网站的web服务器集群来说是至关重要的!做好负载均衡架构,可以实现故障转移和高可用环境,避免单点故障,保证网站健康持续运行.关于负载均衡介绍,可以参考:linux负载 ...

  6. 《nginx 四》双机主从热备

    lvs+keepalived+nginx实现高性能负载均衡集群 LVS作用 LVS是一个开源的软件,可以实现传输层四层负载均衡.LVS是Linux Virtual Server的缩写,意思是Linux ...

  7. Nginx+keepalived双机热备(默认路径安装)- 基础篇

    负载均衡技术对于一个网站尤其是大型网站的web服务器集群来说是至关重要的!做好负载均衡架构,可以实现故障转移和高可用环境,避免单点故障,保证网站健康持续运行.关于负载均衡介绍,可以参考:linux负载 ...

  8. CCNP路由实验之十五 NAT(网络地址转换)

     CCNP路由实验之十五 NAT(网络地址转换) 众所周知,要让自己的电脑连上Internet,必须要到运营商(ISP)申请一个上网账号,依据此账号申请自己的宽频业务(拨号上网.商业固定IP等等) ...

  9. 【Nginx】(主从热备)LVS+Keepalived+Nginx实现高性能负载均衡集群

    一.LVS 1.1 概述 1.2 Nginx与LVS区别什么 二.Keepalived 2.1 概述 2.2 keepalived和其工作原理 三.LVS+Keepalived+Nginx 搭建双机主 ...

随机推荐

  1. 《Java并发编程实战》第二章 线程安全性 读书笔记

    一.什么是线程安全性 编写线程安全的代码 核心在于要对状态訪问操作进行管理. 共享,可变的状态的訪问 - 前者表示多个线程訪问, 后者声明周期内发生改变. 线程安全性 核心概念是正确性.某个类的行为与 ...

  2. 用AS3清空容器下所有子显示对象

    容器中的子显示对象分为两类: 处于显示列表中的子显示对象.被numChildren所记录的. 由容器graphics对象绘制出来的矢量图.这个矢量图不属于Shape类型,不在容器的显示列表中,不被nu ...

  3. ios中利用NSDateComponents、NSDate、NSCalendar判断当前时间是否在一天的某个时间段内。

    应用中设置一般会存在这样的设置,如夜间勿扰模式,从8:00-23:00,此时如何判断当前时间是否在该时间段内.难点主要在于如何用NSDate生成一个8:00的时间和23:00的时间,然后用当前的时间跟 ...

  4. jz2440开发板设置备份

    ___________________uboot______________________________________ OpenJTAG> pribootdelay=2baudrate=1 ...

  5. <%@ include file=” ”%> ——最简洁易懂的解释

    <%@ include file=” ”%> 假如 在B.jsp 中,使用 <%@ include file=”A.jsp”%>  ,那么就是把 A.jsp 的内容 原封不动 ...

  6. javascript 学习随笔3

    <html> <head> <script type="text/javascript"> function startTime() { var ...

  7. Spring MVC 3.x 版本使用 @ResponseBody 返回乱码

    由于万恶的Spring MVC 默认返回编码 是 ISO-8859-1, 使用如下配置, 可以将编码专为UTF-8, <bean class="org.springframework. ...

  8. postgresql 忘记 postgres 密码

    参考博文: 如何重置postgresql用户密码 解决方法: 1.关闭数据库服务 2.进入数据库的工作空间目录 (如果是建库是没有另外指定,应该就是postgresql安装目录下的 data 目录) ...

  9. Python基础2:反射、装饰器、JSON,接口

    一.反射 最近接触到python的反射机制,遂记录下来已巩固.但是,笔者也是粗略的使用了__import__, getattr()函数而已.目前,笔者的理解是,反射可以使用户通过自定义输入来导入响应的 ...

  10. java代码中获取进程process id(转)

    另一方面,线程ID=进程ID+内部线程对象ID并不成立,    参考: blog.csdn.net/heyetina/article/details/6633901     如何在java代码中获取进 ...