demo控制脚本tel,150 5519 8367

Running Puppet on AIX

Puppet on AIX is… not officially supported, yet still useful (at least one site has it deployed in a production environment). It doesn’t work with the ruby packages that are available from bull at http://www.bullfreeware.com/, as they lack socket functionality, however it does when ruby is built from source with openssl support (at least on 5.2 and 5.3! On early versions, mileage may very etc). Currently, as at 0.22.4 there is still some big holes in functionality, specifically:

  • Mount doesn’t work. Thank you, IBM!
  • Cron jobs mysteriously fail with ‘crontab: cannot access’. Bug 2798
  • Service management via init works, however AIX by default uses something else for internal packages Feature 2864
  • Package support for installing/removing packages via NIM and local directory Bug 2805

Service Management

Most things on AIX are handled using the system resource controller (SRC).

lssrc -a list all services available and their state

startsrc -s sshd start a subsystem

stopsrc -s sshd stop a subsystem

refresh -s sshd refresh a subsystem (does not work on all subsystems, ssh for instance).

You can also pass -g instead of -s to start/stop a group of systems (such as NFS).

Services to be managed via the SRC can be defined with the mkssys command. The example adds the sshd subsystem and the ssh group to the SRC. In the example the binaries reside in /usr. The -a flag allows passing of arguments.

/usr/bin/mkssys -s sshd -p /usr/sbin/sshd -a ‘-D’ -u 0 -S -f 9 -n 15 -R -G ssh

The so generated subsystem sshd can be started with the above mentioned commands.

Package Maintenance

Packages are installed one or two ways. Locally using a local collection of .bff files (native BFF filesets) or remotely using Network Install Manager (NIM), which is similar to kickstart or jump start, plus there’s client management after the fact. NIM has the ability to remotely run simple scripts, reinstalling the OS, or making a system backup (mksysb).

NIM installation

The way that seems to be most common is to deploy packages with NIM. The client is configured to communicate with the NIM server using the niminit command. This can be run on the client or server. In most cases the entry on the server should be created first.

niminit -a name=HOSTNAME -a master=NIM_SERVER_FQDN -a connect=nimsh

Packages can then be installed using the nimclient command with the CUSTomize operation.

nimclient -o cust -a lpp_source=LPP_NAME -a filesets=“package1 package2 package3”

LPP_NAME is the name of the package repository on the server, you can discover the available sources with nimclient -l -t lpp_source.

Local Installation

If the packages are local (or on NFS) they can be installed with the installp command.

installp -acgXY -d /usr/sys/inst.images package1 package2 package3

-a means to apply packages (install)

-c (optional) commit packages to the system, cannot be rejected after this

-g (optional) process dependencies. If depends are not met, install fails.

-X automatically extend filesystems if needed.

-Y automatically accept License agreements.

-d dir use install source location

Before packages can be installed from a local repository, an index of metadata must be created. This is done with the inutoc command. This generates a .toc file in the directory that installp uses to know what packages are where. The filenames of the packages are irrelevant.

Handling mounts

Mounts are dynamically created/removed by commands, instead of modifying /etc/filesystems directly.

lsfs, list filesystems with their attributes

mkfs, creates a filesystem and adds it to /etc/filesystems

rmfs, removes a filesystem (and underlying block device unless the filesystem is not JFS or JFS2)

mknfsmnt, create an NFS mount in /etc/filesystems

rmnfsmnt, remove an NFS mount from /etc/filesystems

chfs, change the mountpoint, attributes, mounting groups, etc. of a filesystem (example: chfs -An /usr causes /usr to not mount on boot)

Mounts are handled exclusively via command line or smitty, using the above commands or importvg/exportvg.

Inittab

/etc/inittab is managed by {ch,ls,mk,rm}itab commands. Do not write changes to this as a text file.

pup-zlib-1.2.5-1.32.puppet.local.aix5.3.ppc.rpm (73.146 KB) Vincent Lin, 07/10/2012 10:41

pup-facter-1.6.3-1.puppet.local.aix5.3.noarch.rpm (63.178 KB) Vincent Lin, 07/10/2012 10:41

pup-openssl-1.0.0e-2.32.puppet.local.aix5.3.ppc.rpm (3.118 MB) Vincent Lin, 07/10/2012 10:41

pup-puppet-2.7.6-1.local.aix5.3.ppc.rpm (970.885 KB) Vincent Lin, 07/10/2012 10:41

pup-puppet-conf-0.1-1.local.aix5.3.noarch.rpm (1.618 KB) Vincent Lin, 07/10/2012 10:41

pup-ruby-1.8.7-p352.1.32.puppet.local.aix5.3.ppc.rpm (3.527 MB) Vincent Lin, 07/10/2012 10:41

aix puppet agent的更多相关文章

  1. aix光盘安装包 aix puppet agent 自动化安装

    脚本待处理事务1,替换指定行数据2,获取$1 :字段分割 [Tips Notes,byRui]从光盘等安装媒介中isntallp -l -d /opt/ruiyhe or /dev/cd0 搜索所有的 ...

  2. Puppet Agent/Master HTTPS Communications

    The agent/master HTTP interface is REST-like, but varies from strictly RESTful design in several way ...

  3. aix 小机运维

    zzbank 一个月折腾总结小总结:#+++++++++++++++++++++++++++++++++++++++++++++++++++++++++#+    Ruiy-ge;#+#+    Te ...

  4. aix Mysql-Rpm puppet puppetAgent

    http://www.bullfreeware.com/toolbox.php   (Large Open Source Software Archieve for AIX 提供MySQL5.1 fo ...

  5. Puppet master/agent installation on RHEL7

    ==================================================================================================== ...

  6. zzbank oneOpencloud Env linuxaix6.1 interactiveMaintain(nfs,aix genintall基于系统iso光盘,aix6.1 puppet-Agent,Cent6.4 puppetServer,agent time no syn case Er)

    1,puppet--server,Client,Agent time no syn case eror puppet agent --server frontend -terr: Could not ...

  7. puppet(5)-master/agent模式

    master/agent模式的工作流程 agent每隔固定时长会向master端发送nodename(自己的节点名,节点名至关重要)和 facts ,并且向服务器端请求自己的catalog. mast ...

  8. 部署puppet master/agent模型

    自己画的一个简单的架构图 agent端每隔30分钟到master端请求与自己相关的catalog. 各节点时间要同步. 依赖DNS,各节点能通过主机名能解析. 1.同步时间 # yum install ...

  9. Puppet基于Master/Agent模式实现LNMP平台部署

    前言 随着IT行业的迅猛发展,传统的运维方式靠大量人力比较吃力,运维人员面对日益增长的服务器和运维工作,不得不把很多重复的.繁琐的工作利用自动化处理.前期我们介绍了运维自动化工具ansible的简单应 ...

随机推荐

  1. bash 变量使用技巧

  2. ASP.net(C#)批量上传图片(完整版)

    摘自:http://www.biye5u.com/article/netsite/ASPNET/2010/1996.html   这篇关于ASP.Net批量上传图片的文章写得非常好,偶尔在网上看到想转 ...

  3. android 遇到的细节 FAQ

    1.ListView 设置addHead 在3.0与之前版本若在:setAdapter之后添加,运行报错.4.0以后不报错 2.ListView  Adapter    getView函数忘记返回vi ...

  4. Firebug Command Line

    http://michaelsync.net/2007/09/15/firebug-tutorial-commandline-api

  5. MarkDown基础使用教程-by sixleaves

    以下是个人浏览文档,结合自己平时使用所总结, 和引用国外关于如何使用markdown的教程.如有不足,还请海涵,期待于您的交流.我觉得使用markdown书写挺好的! 工具下载,可以去下载gitboo ...

  6. 原生Javascript 省市区下拉列表插件

    每个电商网站中,都会有收件地址管理模块,用户进行地址操作时,最好不要用户手工进行填写地址. 常见的地址管理界面: 实现插件:PCASClass.js 插件下载地址:http://pan.baidu.c ...

  7. PHP 多input file文件上传

    前台html jquery代码 后台PHP处理 前台html <form id="form" method="post" enctype="mu ...

  8. CF 444A(DZY Loves Physics-低密度脂蛋白诱导子图)

    A. DZY Loves Physics time limit per test 1 second memory limit per test 256 megabytes input standard ...

  9. Error in invoking target 'agent nmhs' of makefile

    安装Oracle11g报错:Error in invoking target 'agent nmhs' of makefile  解决方法:cd $ORACLE_HOME/sysman/libvi i ...

  10. Erp第二章:业务流程化、集成、规划

    1从全流程着眼,支持业务流程化优化,通过流程化优化提高工作效率和企业效益 2每个系统业务都相互依存.相互作用. 3.应用 程序(不用厂家)越多,信息集成难度越大 4信息集成.实时共享.实时企业 5信息 ...