一、实验拓扑

二、实验步骤

1、给主机设置IP,网关;给交换机划分VLAN,给VLAN划分端口,给VLAN设置IP

2、启用OSPF、宣告网段(network 网络地址 反掩码 区域名     其中0区域为主干区域)

▲SwitchA 的相关配置

Switch>enable
Switch#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname SwitchA
SwitchA(config)#vlan 10
SwitchA(config-vlan)#exit
SwitchA(config)#vlan 20
SwitchA(config-vlan)#exit
SwitchA(config)#vlan 100
SwitchA(config-vlan)#exit
SwitchA(config)#interface range fastEthernet 0/1-10
SwitchA(config-if-range)#switchport access vlan 10
SwitchA(config-if-range)#interface range fastEthernet 0/11-20
SwitchA(config-if-range)#switchport access vlan 20
SwitchA(config-if-range)#interface fastEthernet 0/23
SwitchA(config-if)#switchport access vlan 100
SwitchA(config-if)#
SwitchA(config-if)#interface vlan 100
SwitchA(config-if)#ip address 192.168.100.1 255.255.255.0
SwitchA(config-if)#no shutdown
SwitchA(config-if)#interface vlan 10
SwitchA(config-if)#ip address 192.168.10.1 255.255.255.0
SwitchA(config-if)#no shutdown
SwitchA(config-if)#interface vlan 20
SwitchA(config-if)#ip address 192.168.20.1 255.255.255.0
SwitchA(config-if)#no shutdown
SwitchA(config-if)#exit
SwitchA(config)#router ?
  eigrp  Enhanced Interior Gateway Routing Protocol (EIGRP)
ospf Open Shortest Path First (OSPF)
rip Routing Information Protocol (RIP)
SwitchA(config)#router ospf ?
<1-65535> Process ID
SwitchA(config)#router ospf 1
SwitchA(config-router)#network 192.168.10.0 0.0.0.255 area 0
SwitchA(config-router)#network 192.168.20.0 0.0.0.255 area 0
SwitchA(config-router)#network 192.168.100.0 0.0.0.255 area 0
SwitchA(config-router)#

▲SwitchB 的相关配置

Switch>
Switch>enable
Switch#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 30
Switch(config-vlan)#exit
Switch(config)#vlan 40
Switch(config-vlan)#exit
Switch(config)#vlan 101
Switch(config-vlan)#exit
Switch(config)#vlan 200
Switch(config-vlan)#exit
Switch(config)#hostname SwitchB
SwitchB(config)#interface range fastEthernet 0/1-10
SwitchB(config-if-range)#switchport access vlan 30
SwitchB(config-if-range)#interface range fastEthernet 0/11-20
SwitchB(config-if-range)#switchport access vlan 40
SwitchB(config-if-range)#interface fastEthernet 0/23
SwitchB(config-if)#switchport access vlan 101
SwitchB(config-if)#interface fastEthernet 0/24
SwitchB(config-if)#switchport access vlan 200
SwitchB(config-if)#
SwitchB(config-if)#exit
SwitchB(config)#interface vlan 101
SwitchB(config-if)#ip address 192.168.100.2 255.255.255.0
SwitchB(config-if)#no shutdown
SwitchB(config-if)#interface vlan 200
SwitchB(config-if)#ip address 192.168.200.1 255.255.255.0
SwitchB(config-if)#no shutdown
SwitchB(config-if)#interface vlan 30
SwitchB(config-if)#ip address 192.168.30.1 255.255.255.0
SwitchB(config-if)#no shutdown
SwitchB(config-if)#interface vlan 40
SwitchB(config-if)#ip address 192.168.40.1 255.255.255.0
SwitchB(config-if)#no shutdown
SwitchB(config-if)#exit
SwitchB(config)#route ospf 1
SwitchB(config-router)#network 192.168.100.0 0.0.0.255 area 0
SwitchB(config-router)#network 192.168.30.0 0.0.0.255 area 0
SwitchB(config-router)#network 192.168.200.0 0.0.0.255 area 1
SwitchB(config-router)#network 192.168.40.0 0.0.0.255 area 1
SwitchB(config-router)#

  

▲SwitchC 的相关配置

Switch>
Switch>enable
Switch#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname SwitchC
SwitchC(config)#vlan 50
SwitchC(config-vlan)#exit
SwitchC(config)#vlan 60
SwitchC(config-vlan)#exit
SwitchC(config)#vlan 201
SwitchC(config-vlan)#exit SwitchC(config)#interface range fastEthernet 0/1-10
SwitchC(config-if-range)#switchport access vlan 50
SwitchC(config-if-range)#interface range fastEthernet 0/11-20
SwitchC(config-if-range)#switchport access vlan 60
SwitchC(config-if-range)#interface fastEthernet 0/24
SwitchC(config-if)#switchport access vlan 201
SwitchC(config-if)#exit
SwitchC(config)#interface vlan 201
SwitchC(config-if)#ip address 192.168.200.2 255.255.255.0
SwitchC(config-if)#no shutdown
SwitchC(config-if)#interface vlan 50
SwitchC(config-if)#ip address 192.168.50.100 255.255.255.0
SwitchC(config-if)#no shutdown
SwitchC(config-if)#interface vlan 60
SwitchC(config-if)#ip address 192.168.60.100 255.255.255.0
SwitchC(config-if)#no shutdown
SwitchC(config-if)#exit
Switch(config)#router ?
eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)
ospf Open Shortest Path First (OSPF)
rip Routing Information Protocol (RIP)
Switch(config)#router ospf ?
<1-65535> Process ID
Switch(config)#router ospf 1
Switch(config-router)#network 192.168.50.0 0.0.0.255 area 1
Switch(config-router)#network 192.168.60.0 0.0.0.255 area 1
Switch(config-router)#network 192.168.200.0 0.0.0.255 area 1
Switch(config-router)#  

当三台交换机都设置好ospf动态路由后,用以下命令查看(在特权模式下)

SwitchC#show ip route

结果如图

三、实验结果

所有的PC间全通。

三台三层交换机OSPF多区域划分动态路由实验的更多相关文章

  1. 两台三层交换机单区域OSPF动态路由实验

    一.   实验目的 1.  掌握三层交换机之间通过OSPF协议实现网段互通的配置方法. 2.  理解RIP协议和OSPF协议内部实现的不同点 二.   应用环境 当两台三层交换机级联时,为了保证每台交 ...

  2. RIP、OSPF、BGP、动态路由选路协议、自治域AS

    相关学习资料 tcp-ip详解卷1:协议.pdf http://www.rfc-editor.org/rfc/rfc1058.txt http://www.rfc-editor.org/rfc/rfc ...

  3. 三层交换机RIP动态路由实验

    一.   实验目的 1.  掌握三层交换机之间通过RIP协议实现网段互通的配置方法. 2.  理解动态实现方式与静态方式的不同 二.   应用环境 当两台三层交换机级联时,为了保证每台交换机上所连接的 ...

  4. 八、路由详细介绍之动态路由OSPF(重点)

    一.OSPF介绍 OSPF优点:无环路.收敛快.扩展性好.支持认证 二.工作原理: 图中RTA.RTB.RTC每个路由器都会生成一个LSA, 通过LSA泛洪进行互相发送相互学习,形成LSDB (链路状 ...

  5. 动态路由 - OSPF 一文详解

    动态路由 在之前的文章中,介绍了基于距离矢量的路由协议.而在今天这这一部分中会主要讲解链路状态的路由协议,对于动态的路由协议来说,需要具备如下的能力: 发现远端网络 路由器可以直接获得直连路由,这是由 ...

  6. H3C路由器配置——动态路由OSPF协议

    一.介绍 1.OSPF协议介绍 (1).OSPF(Open Shortest Path First,开放最短路径优先)路由协议是用于网际协议(IP)网络的链路状态路由协议.是一个被各厂商设备广泛支持的 ...

  7. 浅谈-动态路由之OSPF的理解

    路由 在网络中,路由相当于就是一张地图,让路由器知道这个对应的IP数据包应该往哪端口.网段走:而这个"地图"我们称之为路由表,不同的目的IP路由表的下一个跳也不同,其生成方式有又有 ...

  8. 动态路由——OSPF

    目录: 一. OSPF路由协议概述     1,OSPF协议    2,内部网关协议和外部网关协议   3,OSPF的工作过程 二.OSPF基本概念   1,OSPF区域   2,区域ID   3,R ...

  9. Vlan间通讯,动态路由

    Vlan间通讯,动态路由 案例1:三层交换vlan间通信 案例2:多交换机vlan间通信 案例3:三层交换配置路由 案例4:RIP动态路由配置 案例5:三层交换配置RIP动态路由 1 案例1:三层交换 ...

随机推荐

  1. 05. Go 语言函数

    Go 语言函数 函数是组织好的.可重复使用的.用来实现单一或相关联功能的代码段,其可以提高应用的模块性和代码的重复利用率. Go 语言支持普通函数.匿名函数和闭包,从设计上对函数进行了优化和改进,让函 ...

  2. 如何让junit的测试跑多次

    对JUnit4可以使用下面的方法: @RunWith(Parameterized.class) public class RunTenTimes { @Parameterized.Parameters ...

  3. 剑指Offer-35.两个链表的第一个公共结点(C++/Java)

    题目: 输入两个链表,找出它们的第一个公共结点. 分析: 先统计两个链表的长度,计算他们的差值,然后将两个链表对齐,再去寻找公共节点即可. 程序: C++ class Solution { publi ...

  4. USACO Max Flow

    洛谷 P3128 [USACO15DEC]最大流Max Flow 洛谷传送门 JDOJ 3027: USACO 2015 Dec Platinum 1.Max Flow JDOJ传送门 Descrip ...

  5. 用vbs和ADSI管理Windows账户

    ADSI (Active Directory Services Interface)是Microsoft新推出的一项技术,它统一了许多底层服务的编程接口,程序员可以使用一致的对象技术来访问这些底层服务 ...

  6. 描述符(__get__和__set__和__delete__)

    目录 一.描述符 二.描述符的作用 2.1 何时,何地,会触发这三个方法的执行 三.两种描述符 3.1 数据描述符 3.2 非数据描述符 四.描述符注意事项 五.使用描述符 5.1 牛刀小试 5.2 ...

  7. ASP.NET Core 中使用负载均衡时获取客户端 IP

    在使用负载均衡的情况下,通过 context.Connection.RemoteIpAddress 获取到的是负载均衡的 IP 地址,需要通过 X-Forwarded-For 请求头才能获取到客户端的 ...

  8. centos安装nodejs并配置生产环境,基于pm2

    安装nodejs和yarn的命令: curl --silent --location https://dl.yarnpkg.com/rpm/yarn.repo | sudo tee /etc/yum. ...

  9. 创意编程,Python开发多功能壁纸自动切换工具!

    import ctypes import time import requests import os from threading import Thread from tkinter import ...

  10. pyEcharts安装及使用指南(最新)

    pyEcharts安装及使用指南(最新): 网上资料大多数是0.5X的版本, 这里我给出我的0.5版本连接https://www.cnblogs.com/dgwblog/p/11811562.html ...