All people seem to need data processing
( Application presentation session transport network data link physic )

host : end device ( PC Server )
switch : to connect many device
router : to connect two or more different networks
internet cable : straight cable and crossover cable
The straight through cable is used to connect:
 
  • switch to router
  • switch to pc/server
 
 
The crossover cable is used to connect:
 
  • switch to switch
  • router to router
  • router to pc/server
  • pc/server to pc/server
 
192.168.0.0 /16 ( 16个1 )
11111111.11111111.00000000.00000000
255.255.0.0
It means that the first address of this network ( the network address ) is : 192.128.00000000.00000000 => 192.168.0.0
The last address of this network ( the broadcast address ) is 192.16811111111.11111111 => 192.168.255.255
And the range of IP address for the host is from 192.168.00000000.00000001 => 192.168.0.1 to 192.168.11111111.11111110 => 192.168.255.254
Let’s devide this network into smaller subnetworks.
Always start by the biggest subnetwork which contains the biggest number of hosts..
Office subnetwork : 511 hosts
So we need 511 IP adderss for the hosts ( end device ) + 1 IP address for the network address +1IP address as a broadcast address = 511 + 1 + 1 = 513 IP addresses
2^9=512 <range for 513 IP addresses < 2^10=1024
1024 in binary is : 0000 0100 0000 0000
So for this subnetwork, we will use the following subnet mask : 11111111.11111111.11111100.00000000 => 255.255.252.0 or /22
So to create the Office subnetwork as a part os the big 192.168.0.0/16 network, we will start at the beginning os this big network.
So the network address of our Office subnetwork will be the first address of the big network : 192.168.0.0/22 ( the host part of the subnet mask is 00.00000000 )
The broadcast address will be : 192.168.3.255/22 ( The host part of the subnet mask is 11.11111111 )
So the range of IP addresses for the hosts will be : from 192.168.0.1/22 to 192.168.3.254/22
we will also book the last host IP address for the gateway ( =router ),so the gateway address of this  subnetwork is ; 192.168.3.254
Then, for the factory subnetwork : 
128(2^7) < 250 IPs =1=1 = 252 < 256(2^8)
So the subnet mask for this subnetwork is : 11111111.11111111.11111111.00000000 => 255.255.255.0 or /24
network address : 192.168.4.0/24 ( this is the next available address of the big network )
broadcast address : 192.168.4.255/24
IP range for hosts : 192.168.4.1/24 to 192.268.4.254/24
gateway is : 192.168.4.154/24
For the small subnetwork OfficeRTR < - > EdgeRTR :  
This is a PtP ( Point to Point ) connection,that means we connect only two devices together.So we need 2+1+1 = 4 IP addresses in this network
subnet mask : 11111111.11111111.11111111.11111100 => 255.255.252 or 30
network address : 192.168.5.4/30 ( this is the next available address of the big network )
 
.
.
.
.
enable
configure terminal
interface gigabitEthernet
ip adress …(last IP address)
no shutdown
exit 
in
自动填充命令语句
重现之前用过的语句
Configure R1
 
en
conf t
hostname R1
no ip domain-lookup
enable secret class
banner motd #Do not touch my router#
line con 0
password cisco
exit
line vty 0 4
password cisco
exit
interface fastEthernet 0/0
ip address 192.168.1.1 255.255.255.0
no shutdown
exit
interface serial 0/0/0
ip address 192.168.2.1 255.255.255.0
clock rate 64000
exit
end
copy runnig-config startup-config
 
 
 
Configure R2 :
 
en
conf t
hostname R2
no ip domain-lookup
enable secret class
banner motd #Do not touch my router#
line con 0
password cisco
exit
line vty 0 4
password cisco
exit
interface fastEthernet 0/0
ip address 192.168.3.1 255.255.255.0
no shutdown
exit
interface serial 0/0/0
ip address 192.168.2.2 255.255.255.0
clock rate 64000
exit
end
copy runnig-config startup-config

CCNA 4.14 TP Correction的更多相关文章

  1. iOS中UITextField 使用全面解析 分类: ios技术 2015-04-10 14:37 153人阅读 评论(0) 收藏

    //初始化textfield并设置位置及大小   UITextField *text = [[UITextField alloc]initWithFrame:CGRectMake(20, 20, 13 ...

  2. iOS TextField用法大全

    //初始化textfield并设置位置及大小 UITextField *text = [[UITextField alloc]initWithFrame:CGRectMake(20, 20, 130, ...

  3. IOS开发 - TextField 控件详细

    //初始化textfield并设置位置及大小 UITextField *text = [[UITextField alloc]initWithFrame:CGRectMake(20, 20, 130, ...

  4. UITextField使用详解

    转iOS中UITextField使用详解 (1) //初始化textfield并设置位置及大小   UITextField *text = [[UITextField alloc]initWithFr ...

  5. IOS—UITextFiled控件详解

    IOS—UITextFiled控件详解 //初始化textfield并设置位置及大小 UITextField *text = [[UITextField alloc]initWithFrame:CGR ...

  6. IOS-TextField控件详解

    //初始化textfield并设置位置及大小 UITextField *text = [[UITextField alloc]initWithFrame:CGRectMake(20, 20, 130, ...

  7. IOS开发UI基础UITextFidle相关属性

    UITextFidle相关属性 •    enablesReturnKeyAutomatically默认为No,如果设置为Yes,文本框中没有输入任何字符的话,右下角的返回按钮是disabled的. ...

  8. IOS-UITextField-全解

    IOS-UITextField-全解   //初始化textfield并设置位置及大小   UITextField *text = [[UITextField alloc]initWithFrame: ...

  9. iOS-TextField知多少

    iOS-TextField知多少 //初始化textfield并设置位置及大小 UITextField *text = [[UITextField alloc]initWithFrame:CGRect ...

随机推荐

  1. JSP中RequestDispatcher的用法

    RequestDispatcher是一个Web资源的包装器,可以用来把当前request传递到该资源,或者把新的资源包括到当前响应中.RequestDispatcher接口中定义了两个方法:inclu ...

  2. 【linux命令】grep

    1.作用Linux系统中grep命令是一种强大的文本搜索工具,它能使用正则表达式搜索文本,并把匹 配的行打印出来.grep全称是Global Regular Expression Print,表示全局 ...

  3. C#_加密解密

    一.MD5加密解密 1.加密 public static string ToMd5(string clearString) { Byte[] clearBytes = System.Text.Enco ...

  4. Rocketmq-尝试理解

    普通的信息发送和消费 首先要启动nameserver和broker,nameserver是一个几乎无状态节点.broker分为master和slave,master和slave的对应关系通过指定相同的 ...

  5. Linux技巧学习

    主要是收集一些Linux的技巧: 1.编写可靠shell脚本的八个建议 指定bash,推荐使用 /usr/bin/env bash 和 /bin/bash,不要使用/usr/bin/bash. set ...

  6. 关于json的理解

    一. 获取数组长度 array.length 获取对象长度  Object.keys(objs).length 二. 如何抉择{}和[] 先说两者区别, {}:父类下面直接是子类名称 []:父类下会追 ...

  7. 20145218 《Java程序设计》第04次实验报告

    北京电子科技学院(BESTI)实验报告 课程:Java程序设计 班级:1452 指导教师:娄嘉鹏 实验日期:2016.04.22 实验名称:Android开发基础 一.实验内容 1.基于Android ...

  8. (06)odoo报表

    ----------更新时间:18:06 2016-09-18 星期日18:13 2016-04-05 星期二10:31 2016-03-01 星期二----------* odoo8 采用是Qweb ...

  9. hdu----(3065)病毒侵袭持续中(AC自动机)

    病毒侵袭持续中 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Sub ...

  10. 解析 MACH_O 文件

    现在做iOS开发的挺多,了解一下在苹果平台上程序运行的原理 解析 MACH_O 文件 这篇文章描述了如何解析 Mach-O 文件并稍微解释了一下它的格式.这不是一份权威指南,不过当你不知从何开始时,它 ...