网络拓扑

XRV1

==========================================================

!
hostname XRV1
!
interface Loopback0
ip address 220.198.32.1 255.255.255.255
ip router isis 100
!
interface GigabitEthernet1
ip address 123.103.15.1 255.255.255.252
negotiation auto
bfd interval 250 min_rx 250 multiplier 3
!
interface GigabitEthernet2
ip address 123.103.15.5 255.255.255.252
negotiation auto
bfd interval 250 min_rx 250 multiplier 3
!
interface GigabitEthernet3
ip address 10.10.1.2 255.255.255.252
ip router isis 100
negotiation auto
isis circuit-type level-2-only
!
router isis 100
net 49.0000.2201.9832.1000.00
is-type level-2-only
!
router bgp 4809
bgp router-id 220.198.32.1
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
aggregate-address 43.180.0.0 255.255.0.0 as-set
aggregate-address 36.159.0.0 255.255.0.0 as-set
aggregate-address 27.160.0.0 255.255.0.0 as-set
aggregate-address 14.102.0.0 255.255.0.0 as-set
neighbor 123.103.15.2 remote-as 9308
neighbor 123.103.15.2 password cisco
neighbor 123.103.15.2 fall-over bfd
neighbor 123.103.15.6 remote-as 9808
neighbor 123.103.15.6 password cisco
neighbor 123.103.15.6 fall-over bfd
neighbor 220.198.32.5 remote-as 4809
neighbor 220.198.32.5 password cisco
neighbor 220.198.32.5 update-source Loopback0
neighbor 220.198.32.5 next-hop-self
!

XRV2

==========================================================

!
hostname XRV2
!
interface Loopback0
ip address 220.198.32.2 255.255.255.255
!
interface GigabitEthernet1
ip address 123.103.15.2 255.255.255.252
negotiation auto
bfd interval 250 min_rx 250 multiplier 3
!
interface GigabitEthernet2
ip address 123.103.15.13 255.255.255.252
negotiation auto
bfd interval 250 min_rx 250 multiplier 3
!
interface GigabitEthernet3
ip address 123.103.15.9 255.255.255.252
negotiation auto
bfd interval 250 min_rx 250 multiplier 3
!
router bgp 9308
bgp router-id 220.198.32.2
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
aggregate-address 43.180.0.0 255.255.0.0 summary-only
aggregate-address 36.159.0.0 255.255.0.0 summary-only
aggregate-address 27.160.0.0 255.255.0.0 summary-only
aggregate-address 14.102.0.0 255.255.0.0 summary-only
neighbor 123.103.15.1 remote-as 4809
neighbor 123.103.15.1 password cisco
neighbor 123.103.15.1 fall-over bfd
neighbor 123.103.15.10 remote-as 9808
neighbor 123.103.15.10 password cisco
neighbor 123.103.15.10 fall-over bfd
neighbor 123.103.15.14 remote-as 4807
neighbor 123.103.15.14 password cisco
neighbor 123.103.15.14 fall-over bfd
!

XRV3

==========================================================

!
hostname XRV3
interface Loopback0
ip address 220.198.32.3 255.255.255.255
!
interface GigabitEthernet2
ip address 123.103.15.14 255.255.255.252
negotiation auto
bfd interval 250 min_rx 250 multiplier 3
!
interface GigabitEthernet4
ip address 123.103.15.17 255.255.255.252
negotiation auto
bfd interval 250 min_rx 250 multiplier 3
!
router bgp 4807
bgp router-id 220.198.32.3
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 123.103.15.13 remote-as 9308
neighbor 123.103.15.13 password cisco
neighbor 123.103.15.13 fall-over bfd
neighbor 123.103.15.18 remote-as 9808
neighbor 123.103.15.18 password cisco
neighbor 123.103.15.18 fall-over bfd
!

XRV4

==========================================================

!
hostname XRV4
!
interface Loopback0
ip address 220.198.32.4 255.255.255.255
!
interface GigabitEthernet2
ip address 123.103.15.6 255.255.255.252
negotiation auto
bfd interval 250 min_rx 250 multiplier 3
!
interface GigabitEthernet3
ip address 123.103.15.10 255.255.255.252
negotiation auto
bfd interval 250 min_rx 250 multiplier 3
!
interface GigabitEthernet4
ip address 123.103.15.18 255.255.255.252
negotiation auto
bfd interval 250 min_rx 250 multiplier 3
!
router bgp 9808
bgp router-id 220.198.32.4
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
aggregate-address 43.180.0.0 255.255.0.0 suppress-map external-export
aggregate-address 27.160.0.0 255.255.0.0 suppress-map external-export
aggregate-address 14.102.0.0 255.255.0.0 suppress-map external-export
neighbor 123.103.15.5 remote-as 4809
neighbor 123.103.15.5 password cisco
neighbor 123.103.15.5 fall-over bfd
neighbor 123.103.15.9 remote-as 9308
neighbor 123.103.15.9 password cisco
neighbor 123.103.15.9 fall-over bfd
neighbor 123.103.15.17 remote-as 4807
neighbor 123.103.15.17 password cisco
neighbor 123.103.15.17 fall-over bfd
!
ip prefix-list external-export seq 5 permit 14.102.0.0/16
ip prefix-list external-export seq 10 permit 27.160.0.0/16
ip prefix-list external-export seq 15 permit 43.180.0.0/16
!
route-map external-export permit 10
match ip address prefix-list external-export
!

XRV5

==========================================================

!
hostname XRV5
!
interface Loopback0
ip address 220.198.32.5 255.255.255.255
ip router isis 100
!
interface GigabitEthernet0/0
switchport access vlan 100
switchport mode access
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface GigabitEthernet0/2
media-type rj45
negotiation auto
!
interface GigabitEthernet0/3
media-type rj45
negotiation auto
!
interface Vlan1
ip address 14.102.1.254 255.255.255.0
!
interface Vlan2
ip address 14.102.128.254 255.255.255.0
!
interface Vlan3
ip address 14.102.192.254 255.255.255.0
!
interface Vlan4
ip address 14.102.255.254 255.255.255.0
!
interface Vlan5
ip address 27.160.1.254 255.255.255.0
!
interface Vlan6
ip address 27.160.128.254 255.255.255.0
!
interface Vlan7
ip address 27.160.192.254 255.255.255.0
!
interface Vlan8
ip address 27.160.255.254 255.255.255.0
!
interface Vlan9
ip address 36.159.1.254 255.255.255.0
!
interface Vlan10
ip address 36.159.128.254 255.255.255.0
!
interface Vlan11
ip address 36.159.192.254 255.255.255.0
!
interface Vlan12
ip address 36.159.255.254 255.255.255.0
!
interface Vlan13
ip address 43.180.1.254 255.255.255.0
!
interface Vlan14
ip address 43.180.128.254 255.255.255.0
!
interface Vlan15
ip address 43.180.192.254 255.255.255.0
!
interface Vlan16
ip address 43.180.255.254 255.255.255.0
!
interface Vlan100
ip address 10.10.1.1 255.255.255.252
ip router isis 100
isis circuit-type level-2-only
!
router isis 100
net 49.0000.2201.9832.5000.00
is-type level-2-only
!
router bgp 4809
bgp router-id 220.198.32.5
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
network 14.102.1.0 mask 255.255.255.0
network 14.102.128.0 mask 255.255.255.0
network 14.102.192.0 mask 255.255.255.0
network 14.102.255.0 mask 255.255.255.0
network 27.160.1.0 mask 255.255.255.0
network 27.160.128.0 mask 255.255.255.0
network 27.160.192.0 mask 255.255.255.0
network 27.160.255.0 mask 255.255.255.0
network 36.159.1.0 mask 255.255.255.0
network 36.159.128.0 mask 255.255.255.0
network 36.159.192.0 mask 255.255.255.0
network 36.159.255.0 mask 255.255.255.0
network 43.180.1.0 mask 255.255.255.0
network 43.180.128.0 mask 255.255.255.0
network 43.180.192.0 mask 255.255.255.0
network 43.180.255.0 mask 255.255.255.0
neighbor 220.198.32.1 remote-as 4809
neighbor 220.198.32.1 password cisco
neighbor 220.198.32.1 update-source Loopback0
!

手工汇总的注意事项:

1.as-set 当BGP的路由汇总后,原路由的属性会丢失,比如as-path等,加as-set属性能够重新生成新的as-path

2. advertise-map 只对 advertise-map 匹配的路由条目进行路由聚合

3. attribute-map 聚合后清除原路由的属性

4.suppress-map 设置为bgp路由条目为suppress,即该条目在BGP路由表中带s

BGP路由的手动汇总的更多相关文章

  1. 如何使用 Quagga BGP(边界网关协议)路由器来过滤 BGP 路由

    在之前的文章中,我们介绍了如何使用 Quagga 将 CentOS 服务器变成一个 BGP 路由器,也介绍了 BGP 对等体和前缀交换设置.在本教程中,我们将重点放在如何使用前缀列表prefix-li ...

  2. filter-policy和AS-PATH-FILTER过滤BGP路由条目

    Filter-policy过滤BGP路由条目 一:根据项目需求搭建好拓扑图如下: 二:配置 1:对项目图做理论分析,首先RT1和RT2属于EBGP(不同自治系统之间的直连路由),而RT2和RT3属于I ...

  3. BGP路由属性详解

    Weight属性:cisco私有的BGP属性参数,它只适用于一台路由器中的路由,也就是不会传递给任何其他的路由器.他的取值范围为<0-65535>,这个数越大优先级越高,默认从邻居学到的路 ...

  4. HCNP Routing&Switching之BGP路由宣告

    前文我们了解了BGP报文结构.类型以及邻居状态相关话题,回顾请参考https://www.cnblogs.com/qiuhom-1874/p/15422924.html:今天我们来聊一聊BGP路由宣告 ...

  5. HCNP Routing&Switching之BGP路由属性和优选规则

    前文我们了解了BGP防环机制和路由聚合相关话题,回顾请参考https://www.cnblogs.com/qiuhom-1874/p/15458110.html:今天我们来聊一聊BGP路由属性和选路规 ...

  6. HCNP Routing&Switching之BGP路由控制

    前文我们了解了BGP的路由属性和优选规则相关话题,回顾请参考https://www.cnblogs.com/qiuhom-1874/p/15489497.html:今天我们来聊一聊BGP路由控制相关话 ...

  7. CCIE路由实验(4) -- BGP路由控制

    1.过滤BGP路由的方法2.用AS-path filter控制路由3.用Community Filter控制路由 enableconf tno ip do loenable pass ciscolin ...

  8. BGP路由控制属性

    控制BGP路由概述: BGP与IGP不同,其着跟点主要在于不同的AS之间控制路由的传播和选择最佳路由 通过修改BGP基本属性可以实现基本的BGP路由控制和最佳路由的选择 引入其他路由协议发现的路由时. ...

  9. BGP路由技术

    BGP路由技术 目录 一.BGP概述 1.1.自治系统 1.2.动态路由分类 1.3.BGP概念 1.4.BGP的特征 1.5.BGP工作原理 二.命令配置 2.1.BGP配置思路 2.2.命令 一. ...

随机推荐

  1. SQL Server高速生成SQL增删改查语句

    你还在手写程序生成SQL语句吗?你还在为由于马虎出错的SQL语句而感到无语吗?你还在为不知如何表达复杂的SQL语句而纠结吗?假设你的回答为"是".那你就OUT啦.快来试试应用SQL ...

  2. [Ramda] Refactor to a Point Free Function with Ramda's useWith Function

    Naming things is hard and arguments in generic utility functions are no exception. Making functions ...

  3. [ExtJS5学习笔记]第三十五条 sencha extjs 5 组件查询方法

    一UI前部组件势必更加,我们通常习惯性使用ID获取部件操作的需要.但是,这种方法是extjs推荐么?你有吗extjs利用它来获取组件的推荐方法? 夹 文件夹 extjs的查询组件的API 查询实例 主 ...

  4. Erlang类型及函数声明规格

    http://erlangdisplay.iteye.com/blog/404570 Erlang类型及函数声明规格 Author: Mail: Date: Copyright: litaocheng ...

  5. Quartz 入门详解 专题

    Cron-Expressions are used to configure instances of CronTrigger. Cron-Expressions are strings that a ...

  6. boost::any在降低模块之间耦合性的应用

    作者:朱金灿 来源:http://blog.csdn.net/clever101 在开发大型系统中,遵循这样一个原则:模块之间低耦合,模块内高内聚.比如系统中模块有界面模块和算法模块两种,一般是界面模 ...

  7. 调用cordova相关插件进行消息推送(通知栏提醒、响铃、震动)

    原文:调用cordova相关插件进行消息推送(通知栏提醒.响铃.震动) 版权声明:本文为博主原创文章,转载须注明出处,博客地址:https://blog.csdn.net/wx13227855087 ...

  8. UWP 在 WebView 中执行 JavaScript 代码(用于模拟用户输入等) - walterlv

    原文:UWP 在 WebView 中执行 JavaScript 代码(用于模拟用户输入等) - walterlv UWP 在 WebView 中执行 JavaScript 代码(用于模拟用户输入等) ...

  9. [Example of Sklearn] - 分类对比

    refrence :http://cloga.info/python/2014/02/07/classify_use_Sklearn/ 加载数据集 这里我使用pandas来加载数据集,数据集采用kag ...

  10. JDK源代码学习系列03----StringBuffer+StringBuilder

                         JDK源代码学习系列03----StringBuffer+StringBuilder 因为前面学习了StringBuffer和StringBuilder的父类 ...