隧道6in4 和隧道6to4(GNS3)
隧道6in4实验配置
拓扑图
Device |
Interface |
IP Address(IPv6) |
R1 |
F 0/0 |
10.1.81.1 |
F 0/1 |
2001:db8:cafe:81::10 |
|
R2 |
F 0/0 |
10.81.1.2 |
F 0/1 |
172.81.1.2 |
|
R3 |
F 0/0 |
172.81.1.3 |
F 0/1 |
2001:DB8:ACE:81::20 |
|
R4 |
F 0/0 |
2001:db8:cafe:81::40 |
R5 |
F 0/0 |
2001:DB8:ACE:81::50 |
手工隧道是双向点到点隧道,但两台边界路由器之间的纯IPv4网络不必是点到点网络,且IPv4网络一定要ping通,手工隧道可以用静态路由或者动态路由,我这里使用ospf动态路由配置。
R1与R3同理
R1(config)#int f 0/0
R1(config-if)#ip add 10.81.1.1 255.255.255.0
R1(config-if)#ip ospf 1 area 0
R1(config-if)#no shut
R1(config-if)#int lo0
R1(config-if)#ip add 1.1.1.1 255.255.255.255
R1(config-if)#ip ospf 1 area 0
R1(config-if)#ex
R1(config)#router ospf 1
R1(config-rtr)#router-id 1.1.1.1
R1(config-rtr)#network 1.1.1.1 0.0.0.0 area 0
R1(config-rtr)#network 10.81.1.0 0.0.0.255 area 0
R2(config)#int f 0/0
R2(config-if)#ip add 10.81.1.2 255.255.255.0
R2(config-if)#ip ospf 1 area 0
R2(config-if)#no shut
R2(config-if)#int f 0/1
R2(config-if)#ip add 172.81.1.2 255.255.255.0
R2(config-if)#ip ospf 1 area 0
R2(config-if)#no shut
R2(config-if)#int lo0
R2(config-if)#ip add 2.2.2.2 255.255.255.255
R2(config-if)#ip ospf 1 area 0
R2(config-if)#ex
R2(config)#router ospf 1
R2(config-rtr)#router-id 2.2.2.2
R2(config-rtr)#network 2.2.2.2 0.0.0.0 area 0
R2(config-rtr)#network 10.81.1.0 0.0.0.255 area 0
R2(config-rtr)#network 172.81.1.0 0.0.0.255 area 0
查看R1路由表,验证ospf是否配置成功
Ospf配置完成后去边界路由配置隧道
R1与R3同理
R1(config)#ipv6 unicast-routing
R1(config)#int f 0/1
R1(config-if)#ipv6 enable
R1(config-if)#ipv6 add 2001:db8:café:81::10/64
R1(config-if)#no shut
R1(config-if)#int tunnel 0
R1(config-if)#ipv6 enable
R1(config-if)#tunnel source f 0/0
R1(config-if)#tunnel mode ipv6ip
R1(config-if)#tunnel destination 172.81.1.3
R1(config-if)#exit
R1(config)#ipv6 route 2001:db8:cafe::/48 tunnel 0
配置完R3后试ping R1 f0/1接口
最后配置R4(R5同理)
R4(config)#ipv6 unicast-routing
R4(config)#int f 0/0
R4(config-if)#ipv6 enable
R4(config-if)#ipv6 add 2001:db8:cafe:81::40/64
R4(config-if)#no shut
R4(config-if)#ex
R4(config)#ipv6 route ::0/0 2001:db8:café:81::10
配置完R5后,从R4ping到 R5
从R5 ping 到 R4
隧道配置完成。
6to4隧道配置
拓扑图
Device |
Interface |
IP Address(IPv6) |
R1 |
F 0/0 |
172.10.81.1 |
F 0/1 |
2002:AC0A:5101::1 |
|
R2 |
F 0/0 |
10.81.1.1 |
F 0/1 |
2002:A01:5101::1 |
|
R3 |
F 0/0 |
218.224.81.1 |
F 0/1 |
2002:DAE0:5101::1 |
|
R4 |
F 0/0 |
172.10.81.4 |
F 0/1 |
10.1.81.4 |
|
F 1/0 |
218.224.81.4 |
|
R5 |
F 0/0 |
2002:AC0A:5101::5 |
R6 |
F 0/0 |
2002:A01:5101::6 |
R5 |
F 0/0 |
2002:DAE0:5101::7 |
6to4隧道内部路由只能配置静态路由
R1(config)#int f 0/0
R1(config-if)#ip add 172.10.81.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#ex
R1(config)#ip route 10.1.81.0 255.255.255.0 172.10.81.4
R1(config)#ip route 218.224.81.0 255.255.255.0 172.10.81.4
R2(config)#int f 0/0
R2(config-if)#ip add 10.1.81.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#ex
R2(config)#ip route 172.10.81.0 255.255.255.0 10.1.81.4
R2(config)#ip route 218.224.81.0 255.255.255.0 10.1.81.4
R3(config)#int f 0/0
R3(config-if)#ip add 218.224.81.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#ex
R3(config)#ip route 10.1.81.0 255.255.255.0 218.224.81.4
R3(config)#ip route 172.10.81.0 255.255.255.0 218.224.81.4
R4(config)#int f 0/0
R4(config-if)#ip add 172.10.81.4 255.255.255.0
R4(config-if)#no shut
R4(config-if)#int f 0/1
R4(config-if)#ip add 10.1.81.4 255.255.255.0
R4(config-if)#no shut
R4(config-if)#int f 1/0
R4(config-if)#ip add 218.224.81.4 255.255.255.0
R4(config-if)#no shut
静态路由配置完成,show路由表验证
试从R1ping到R3、R4
继续配置隧道
R2、R3配置与R1同理
R1(config)#ipv6 unicast-routing
R1(config)#int f 0/1
R1(config-if)#ipv6 enable
R1(config-if)#ipv6 add 2002:ac0a:5101::1/48
R1(config-if)#no shut
R1(config-if)#int tunnel 0
R1(config-if)#ipv6 enable
R1(config-if)#tunnel source f 0/0
R1(config-if)#tunnel mode ipv6ip 6to 4
R1(config-if)#exit
R1(config)#ipv6 route 2002::/16 tunnel 0
配置完后从R1ping到R2、R3
最后配置R5(R6、R7同理)
R5(config)#ipv6 unicast-routing
R5(config)#int f 0/0
R5(config-if)#ipv6 enable
R5(config-if)#ipv6 add 2002:ac0a:5101::5/48
R5(config-if)#no shut
R5(config-if)#ex
R5(config)#ipv6 route ::0/0 2002:ac0a:5101::1
配置完成R6、R7后,试从R5ping 通 R6、R7
6to4隧道实验完成
隧道6in4 和隧道6to4(GNS3)的更多相关文章
- labview 移位寄存器、隧道、索引隧道的区别
Lab view区别:移位寄存器.隧道.索引隧道 最近研究Lab view的时候发现移位寄存器和隧道的功能非常相似但是又有区别 外部数据进入循环体是通过隧道进入的,有几种方式: 图1:For 循环结构 ...
- 内网安全---隐藏通信隧道基础&&网络通信隧道之一ICMP隧道
一,隐藏通信隧道基础知识 在完成信息收集之后,我们要判断流量是否出的去.进的来.隐藏通信隧道技术常用于在受限的网络环境中追踪数据流向和在非受信任的网络中实现安全的数据传输. 1.常见的隧道: .网络层 ...
- 绕过边界防火墙之ICMP隧道、HTTP隧道、UDP隧道
一.ICMP隧道 背景:已经通过某种手段拿到了园区网A主机的控制权,但是边界防火墙只放行该主机向外的ICMP流量,此时怎样才能让A主机和公网主机C建立TCP连接呢? 方案:将TCP包内容包裹在ICMP ...
- 在 Windows 7 中禁用IPv6协议/IPv6隧道
How to disable certain Internet Protocol version 6 (IPv6) components in Windows Vista, Windows 7 and ...
- Windows下使用Xshell建立反向隧道
反向隧道是一个进行内网穿透的简单而有用的方法.在Linux下通过OpenSSH和AutoSSH可以很容易地建立稳定的反向隧道.但是在Windows下,还能看到有人特意装个Cygwin来运行这些工具…… ...
- [置顶] lvs-tun隧道模式搭建
一.lvs直接路由原理 由于图片还要一张一张上传,可以到下面网站下载我的word版本: http://download.csdn.net/user/y0908105023 补充基础知识: OSI(Op ...
- 调试利器:SSH隧道
欢迎大家前往腾讯云社区,获取更多腾讯海量技术实践干货哦~ 本文作者:ivweb 吴浩麟 原文出处:IVWEB社区 未经同意,禁止转载 在开发微信公众号或小程序的时候,由于微信平台规则的限制,部分接口需 ...
- Linux ipip隧道及实现
一.IP隧道技术 IP隧道技术:是路由器把一种网络层协议封装到另一个协议中以跨过网络传送到另一个路由器的处理过程.IP 隧道(IP tunneling)是将一个IP报文封装在另一个IP报文的技术,这可 ...
- 内部办公网与IDC机房的GRE隧道配置实践
背景 公司内网与机房服务器为了实现用内网IP通信的功能,故使用了linux的IP gre隧道的方式.使得公司内部可以直接通过路由直连的方式访问机房服务器. 拓扑图如下: 注:拓扑中的外网IP为虚构的I ...
随机推荐
- Redis笔记-单机版安装
1.几个相关概念 概念 现象描述 规避措施 穿透 通过访问一个缓存中不存在的key,导致程序一定要在数据库中执行查询 将访问结果进行处理,如果返回是null,也存储在缓存中,可以将过期时间设置较短 雪 ...
- 获取用户IP
public static string GetIP() { string ip; if (System.Web.HttpContext.Cu ...
- 删除Widows 启动项中的信息
1.打开任务管理器切换到启动Tab,在需要删除的项目上点击右键,点击打开文件所在位置,这样就找到了启动项所在磁盘位置,可以根据需要决定是否删除. 2.从注册表中删除在启动中的注册信息. regedit ...
- samba介绍和安装
samba基本介绍 为什么需要samba 早期网络文件数据在不同主机之间传输大都可以使用Ftp完成,不过ftp使用有个小小的问题,它不能让你之间修改主机上的文件.要想修改必须要通过下载——修改——上传 ...
- kerberos环境下flume写hbase
直接看官网 http://flume.apache.org/releases/content/1.9.0/FlumeUserGuide.html#hbasesinks a1.channels = c1 ...
- windows部署jenkins持续集成maven测试项目不能访问测试报告
买了一台阿里云的服务器用于练习maven test项目,系统版本wiondows server 2012,将jenkins war包部署在Tomcat服务器上,项目构建后,生成的报告在C:\Windo ...
- idea 连接redis 出现 Caused by: java.net.SocketTimeoutException: connect timed out
Exception in thread "main" redis.clients.jedis.exceptions.JedisConnectionException: java.n ...
- Linux几大服务
server0操作: 1.创建/devops目录,并修改其SELINUX安全上下文 # mkdir /devops # vim /devops/1.mp3# chcon -R -t samba_sha ...
- C++开发python windows版本的扩展模块示例
C++开发python windows版本的扩展模块示例 测试环境介绍和准备 测试环境: 操作系统:windows10 Python版本:3.7.0 VS版本:vs2015社区版(免费) 相关工具下载 ...
- Elasticsearch 目录总结
一:Elasticsearch (及工具插件)安装相关: 二:Elasticsearch 数据新增相关: 三:Elasticsearch 数据删除相关: 四:Elasticsearch 数据更新相关: ...