EIGRP综合实验

本实验可能会有一两个出错的地方,希望大家进行实验测试后,可以指正!当然绝大部分都是正确滴!

实验A:基本配置

A.0)实验目的:

熟悉eigrp的基本配置

A.1)实验拓扑:

A.2)实验步骤

步骤一:基本ip地址配置

R1:

R1#conf t

R1(config)#int e0/0

R1(config-if)#ip add 12.12.12.1 255.255.255.0

R1(config-if)#no shut //路由器接口默认关闭

R1(config-if)#int lo0

R1(config-if)#ip

R1(config-if)#ip add 10.1.1.1 255.255.255.0

R1(config-if)#no shut //不需要

R1(config-if)#end

R2:

R2#CONF T

R2(config)#int e0/0

R2(config-if)#ip add 12.12.12.2 255.255.255.0

R2(config-if)#no shut

R2(config-if)#int e0/1

R2(config-if)#ip add 23.23.23.2 255.255.255.0

R2(config-if)#no shut

R2(config-if)#int lo0

R2(config-if)#ip add 20.2.2.2 255.255.255.0

R2(config-if)#no shut

R2(config-if)#end

R3:

R3#conf t

R3(config)#int e0/1

R3(config-if)#ip add 23.23.23.3 255.255.255.0

R3(config-if)#no shut

R3(config-if)#int lo0

R3(config-if)#ip add 30.3.3.3 255.255.255.0

R3(config-if)#no shut

R3(config-if)#end

步骤二:加入eigrp路由协议

R1::

R1#conf t

R1(config)#router eigrp 123

R1(config-router)#eigrp router-id 1.1.1.1

R1(config-router)#no auto-summary
//某网络信息经过自动汇总路由器A到达路由器B,B的路由表显示该网络的汇总信息。

R1(config-router)#net 10.1.1.0 0.0.0.255

R1(config-router)#net 12.12.12.0 0.0.0.255

R1(config-router)#end

R2:

R2#conf t

R2(config)#router eigrp 123

R2(config-router)#eigrp router-id 2.2.2.2

R2(config-router)#no auto-summary

R2(config-router)#net 20.2.2.0 0.0.0.255

R2(config-router)#net 12.12.12.0 0.0.0.255

*Mar 1 00:15:25.031: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 123:
Neighbor 12.12.12.1 (Ethernet0/0) is up: new adjacency //检测到同属eigrp
123的邻居R2

R2(config-router)#net 23.23.23.0 0.0.0.255

R2(config-router)#end

R3:

R3#CONF T

R3(config)#router eigrp 123

R3(config-router)#eigrp router-id 3.3.3.3

R3(config-router)#no auto-summary

R3(config-router)#net 30.3.3.0 0.0.0.255

R3(config-router)#net 23.23.23.0 0.0.0.255

*Mar 1 00:18:57.075: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 123:
Neighbor 23.23.23.2 (Ethernet0/1) is up: new adjacency

R3(config-router)#end

步骤三:测试连通性

第一种方法:show ip eigrp
neighbors

R2#show ip eigrp neighbors

IP-EIGRP neighbors for process 123

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

1 23.23.23.3 Et0/1 12 00:03:20 51 306 0 3

0 12.12.12.1 Et0/0 12 00:08:13 92 552 0 4

第二种方法:ping

R3#ping 10.1.1.1 so 30.3.3.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2
seconds:

Packet sent with a source address of 30.3.3.3

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max =
64/92/108 ms

第三种办法:show ip eigrp
topology

R2#show ip eigrp topology //拓扑表:所有可抵达的网络的路径信息

IP-EIGRP Topology Table for AS(123)/ID(2.2.2.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R -
Reply,

r - reply Status, s - sia Status

P 10.1.1.0/24, 1 successors, FD is 409600 //feasible
distance(度量值)

via 12.12.12.1 (409600/128256), Ethernet0/0 //通过某个路由器

P 12.12.12.0/24, 1 successors, FD is 281600

via Connected, Ethernet0/0

P 20.2.2.0/24, 1 successors, FD is 128256

via Connected, Loopback0

P 23.23.23.0/24, 1 successors, FD is 281600

via Connected, Ethernet0/1

P 30.3.3.0/24, 1 successors, FD is 409600

via 23.23.23.3 (409600/128256), Ethernet0/1

实验B:手动汇总实验

B.0)实验目的:

熟悉手动汇总的现象和了解手动汇总的作用

B.1)拓扑图 (同实验A)

B.2) 实验步骤

步骤一:基本ip地址配置(同实验A)

步骤二:加入eigrp路由协议(同实验A)

步骤三:测试连通性(同实验A)

步骤四:开始手动汇总:

R2:

R2#conf t

R2(config)#int e0/1

R2(config-if)#ip summary-address EIGRP 123 10.0.0.0
255.0.0.0

R2(config-if)#END

手动汇总产生的系统路由à谁做的汇总谁就有系统路由。

系统路由为避免额外查找和黑洞,NULL0就是指这个路由丢弃

步骤五:现象查看

R1手动汇总前:

R1#show ip route eigrp

20.0.0.0/24 is subnetted, 1 subnets

D 20.2.2.0 [90/409600] via 12.12.12.2, 00:16:46, Ethernet0/0

23.0.0.0/24 is subnetted, 1 subnets

D 23.23.23.0 [90/307200] via 12.12.12.2, 00:16:46,
Ethernet0/0

30.0.0.0/24 is subnetted, 1 subnets

D 30.3.3.0 [90/435200] via 12.12.12.2, 00:15:41, Ethernet0/0

R1手动汇总后:

R1#show ip route eigrp

20.0.0.0/24 is subnetted, 1 subnets

D 20.2.2.0 [90/409600] via 12.12.12.2, 01:48:07, Ethernet0/0

23.0.0.0/24 is subnetted, 1 subnets

D 23.23.23.0 [90/307200] via 12.12.12.2, 01:48:07,
Ethernet0/0

30.0.0.0/24 is subnetted, 1 subnets

D 30.3.3.0 [90/435200] via 12.12.12.2, 01:47:02, Ethernet0/0

R2手动汇总前:

R2#show ip route eigrp

10.0.0.0/24 is subnetted, 1 subnets

D 10.1.1.0 [90/409600] via 12.12.12.1, 00:16:04, Ethernet0/0

30.0.0.0/24 is subnetted, 1 subnets

D 30.3.3.0 [90/409600] via 23.23.23.3, 00:15:00, Ethernet0/1

R2手动汇总后:

R2#SHOW IP ROUTE EIGrp

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D 10.1.1.0/24 [90/409600] via 12.12.12.1, 00:00:03,
Ethernet0/0

D 10.0.0.0/8 is a summary, 00:00:03,
Null0

30.0.0.0/24 is subnetted, 1 subnets

D 30.3.3.0 [90/409600] via 23.23.23.3, 00:00:03, Ethernet0/1

R3手动汇总前:

R3#show ip route eigrp

20.0.0.0/24 is subnetted, 1 subnets

D 20.2.2.0 [90/409600] via 23.23.23.2, 00:23:28, Ethernet0/1

10.0.0.0/24 is subnetted, 1 subnets

D 10.1.1.0 [90/435200] via 23.23.23.2, 00:23:28, Ethernet0/1

12.0.0.0/24 is subnetted, 1 subnets

D 12.12.12.0 [90/307200] via 23.23.23.2, 00:23:28,
Ethernet0/1

R3手动汇总后:

R3#show ip route eigrp

20.0.0.0/24 is subnetted, 1 subnets

D 20.2.2.0 [90/409600] via 23.23.23.2, 01:56:30, Ethernet0/1

D 10.0.0.0/8 [90/435200] via 23.23.23.2, 01:30:57,
Ethernet0/1

12.0.0.0/24 is subnetted, 1 subnets

D 12.12.12.0 [90/307200] via 23.23.23.2, 01:56:30,
Ethernet0/1

查看系统路由管理距离

show ip route 10.0.0.0
255.0.0.0

R2

R2#show ip route 10.0.0.0 255.0.0.0

Routing entry for 10.0.0.0/8

Known via "eigrp 123", distance
5, metric 409600, type internal //eigrp汇总路由管理距离5

Redistributing via eigrp 123

Routing Descriptor Blocks:

* directly connected, via Null0

Route metric is 409600, traffic share count is 1

Total delay is 6000 microseconds, minimum bandwidth is 10000
Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 1/255, Hops 1

R3:

R3#show ip route 10.0.0.0 255.0.0.0

Routing entry for 10.0.0.0/8

Known via "eigrp 123", distance 90, metric 435200, type internal
//内部eigrp管理距离90

Redistributing via eigrp 123

Last update from 23.23.23.2 on Ethernet0/1, 01:34:50 ago

Routing Descriptor Blocks:

* 23.23.23.2, from 23.23.23.2, 01:34:50 ago, via Ethernet0/1

Route metric is 435200, traffic share count is 1

Total delay is 7000 microseconds, minimum bandwidth is 10000
Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 1/255, Hops 2

!!!eigrp的边界汇总

!.0)实验目的:

熟悉边界汇总的现象

RIP对接收学习路由都做边界路由汇总判断 R3 收到10.0.0.0
20.0.0.0

EIGRP只针对本地路由被发送的网络做边界判断 R3收到10.1.1.0
20.0.0.0

!.1)拓扑图

!.2) 实验步骤

步骤一:基本ip地址配置(同实验A)

步骤二:加入eigrp路由协议(同实验A 但是 R2,R3不要no
auto-summary)

步骤三:测试连通性(同实验A)

步骤四:观察实验现象

R1:

R1#show ip route eigrp

D 20.0.0.0/8 [90/409600] via 12.12.12.2, 00:10:32,
Ethernet0/0

D 23.0.0.0/8 [90/307200] via 12.12.12.2, 00:10:24,
Ethernet0/0

D 30.0.0.0/8 [90/435200] via 12.12.12.2, 00:07:23,
Ethernet0/0

R2:

R2#show ip route eigrp

20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D 20.0.0.0/8 is a summary, 00:18:11, Null0

23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D 23.0.0.0/8 is a summary, 00:18:01, Null0

10.0.0.0/24 is subnetted, 1 subnets

D 10.1.1.0 [90/409600] via 12.12.12.1, 00:18:09, Ethernet0/0

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D 12.0.0.0/8 is a summary, 00:18:11, Null0

D 30.0.0.0/8 [90/409600] via 23.23.23.3, 00:14:59,
Ethernet0/1

R3:

R3#SHOW IP ROUte EIGRP

D 20.0.0.0/8 [90/409600] via 23.23.23.2, 00:16:39,
Ethernet0/1

23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D 23.0.0.0/8 is a summary, 00:16:41, Null0

10.0.0.0/24 is subnetted, 1 subnets

D 10.1.1.0 [90/435200] via 23.23.23.2, 00:16:39, Ethernet0/1

D 12.0.0.0/8 [90/307200] via 23.23.23.2, 00:16:39,
Ethernet0/1

30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D 30.0.0.0/8 is a summary, 00:16:41, Null0

将R2,R3 取消自动汇总后

R1:

R1#SHOW IP ROUTE EIGRP

20.0.0.0/24 is subnetted, 1 subnets

D 20.2.2.0 [90/409600] via 12.12.12.2, 00:02:17, Ethernet0/0

23.0.0.0/24 is subnetted, 1 subnets

D 23.23.23.0 [90/307200] via 12.12.12.2, 00:02:17,
Ethernet0/0

30.0.0.0/24 is subnetted, 1 subnets

D 30.3.3.0 [90/435200] via 12.12.12.2, 00:01:22, Ethernet0/0

R2:

R2#show ip route eigrp

10.0.0.0/24 is subnetted, 1 subnets

D 10.1.1.0 [90/409600] via 12.12.12.1, 00:24:09, Ethernet0/0

30.0.0.0/24 is subnetted, 1 subnets

D 30.3.3.0 [90/409600] via 23.23.23.3, 00:02:31, Ethernet0/1

R3:

R3#show ip route eigrp

20.0.0.0/24 is subnetted, 1 subnets

D 20.2.2.0 [90/409600] via 23.23.23.2, 00:01:09, Ethernet0/1

10.0.0.0/24 is subnetted, 1 subnets

D 10.1.1.0 [90/435200] via 23.23.23.2, 00:18:42, Ethernet0/1

12.0.0.0/24 is subnetted, 1 subnets

D 12.12.12.0 [90/307200] via 23.23.23.2, 00:01:09,
Ethernet0/1

实验C:密文认证

C.0)实验目的:

熟练运用密文认证命令行和熟悉密文认证的现象(EIGRP只支持密文认证)

C.1)拓扑图 (同实验A)

C.2) 实验步骤

步骤一:基本ip地址配置(同实验A)

步骤二:加入eigrp路由协议(同实验A)

步骤三:测试连通性(同实验A)

步骤四:开始手动汇总:

步骤五:开始密文认证

R1:

R2#conf t

R1(config)#key chain abc

R1(config-keychain)#key 1

R1(config-keychain-key)#key-string justech

R1(config-keychain-key)#int e0/0

R1(config-if)#ip authentication key-chain eigrp 123 abc

R1(config-if)#ip authentication mode eigrp 123 md5

R1(config-if)#end

R2:

R2#conf t

R2(config)#key chain abc

R2(config-keychain)#key 1

R2(config-keychain-key)#key-string justech

R2(config-keychain-key)#int e0/0

R2(config-if)#ip authentication key-chain eigrp 123 abc

R2(config-if)#ip authentication mode eigrp 123 md5

R2(config-if)#end

!!补充实验

1)eigrp hello 发送间隔及保持时间

!.1.0)实验目的:

发送间隔和保持时间对 eigrp 邻接关系的影响(偏学术)

!.1.1)拓扑图 (同实验A)

!.1.2) 实验步骤

步骤一:基本ip地址配置(同实验A)

步骤二:加入eigrp路由协议(同实验A)

步骤三:测试连通性(同实验A)

步骤四:改变hello发送间隔和保持时间

R3#conf t

R3(config)#int e0/1

R3(config-if)#ip hold-time eigrp 123 4 //保持时间

R3(config-if)#ip hello-interval eigrp 123 4 //hello 发送间隔

发送间隔大于保持时间 路由会不停中断连接中断连接

2)理解EIGRP邻接关系建立审查条件(偏考试)

!.1.0)实验目的:

影响邻接关系的因素!

!.1.1)拓扑图

!.1.2) 实验步骤

步骤一:基本ip地址配置

步骤二:加入eigrp路由协议

步骤三:测试连通性

只有直连是可通的,但是加入路由协议,路由协议不通!

EIGRP RID相同不影响邻接关系建立

HOLDTIME

AS号不一致,邻接关系一定不建立

认证不通过,邻接关系一定不建立

邻居5K值必须一致 show ip protocols

K1=带宽 K2=负载 K3=延迟 K4=可靠性 K5=MTU

10100 1参与计算 0不参与

改变方法:

Router eigrp 123

Metric weight 0 1 1 1 1 1

实验D:EIGRP 默认网络设置

//同rip的default-information originate

D.0)实验目的:

学习该技术用于企业边界将去向互联网数据给运营商

D.1)实验拓扑:

D.2)实验步骤:

步骤一:基本ip地址配置

R1:

R1#conf t

R1(config)#int e0/0

R1(config-if)#ip add 12.12.12.1 255.255.255.0

R1(config-if)#no shut

R1(config-if)#int lo0

R1(config-if)#ip add 10.1.1.1 255.255.255.0

R1(config-if)#end

R2:

R2#conf t

R2(config)#int e0/0

R2(config-if)#ip add 12.12.12.2 255.255.255.0

R2(config-if)#no shut

R2(config-if)#int e0/1

R2(config-if)#ip add 202.2.2.2 255.255.255.0

R2(config-if)#no shut

R2(config-if)#end

R3:

R3#conf t

R3(config)#int e0/1

R3(config-if)#ip add 202.2.2.3 255.255.255.0

R3(config-if)#no shut

R3(config-if)#int lo0

R3(config-if)#ip add 3.3.3.3 255.255.255.0

R3(config-if)#no shut

R3(config-if)#end

步骤二:加入eigrp路由协议

R1:

R1#conf t

R1(config)#router eigrp 12

R1(config-router)#eigrp router-id 1.1.1.1

R1(config-router)#no auto

R1(config-router)#net 10.1.1.0 0.0.0.255

R1(config-router)#net 12.12.12.0 0.0.0.255

R1(config-router)#end

R2:

R2#conf t

R2(config)#router eig

R2(config)#router eigrp 12

R2(config-router)#eigrp router-id 2.2.2.2

R2(config-router)#no auto

R2(config-router)#no auto-summary

R2(config-router)#net 12.12.12.0 0.0.0.255

步骤三:配置静态路由

R3:

R3#conf

R3(config)#int e0/1

R3(config-if)#ip route 10.1.1.0 255.255.255.0 e0/1 202.2.2.2

R3(config)#end

R2:

R2#conf t

R2(config)#int e0/1

R2(config-if)#ip route 0.0.0.0 0.0.0.0 e0/0 202.2.2.3

R2(config)#end

步骤四:设置默认网络

R2:

R2#CONF T

R2(config)#ip default-network 202.2.2.0

R2(config)#end

R2:show ip route

R2#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B -
BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter
area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type
2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2

ia - IS-IS inter area, * - candidate default, U - per-user
static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 202.2.2.3 to network 0.0.0.0

C* 202.2.2.0/24 is directly connected,
Ethernet0/1

10.0.0.0/24 is subnetted, 1
subnets

D 10.1.1.0 [90/409600] via 12.12.12.1, 00:36:00, Ethernet0/0

12.0.0.0/24 is subnetted, 1 subnets

C 12.12.12.0 is directly connected, Ethernet0/0

S* 0.0.0.0/0 [1/0] via 202.2.2.3, Ethernet0/0

步骤五:将默认网络宣告进EIGRP

R2#conf t

R2(config)#router eigrp 12

R2(config-router)#network 202.2.2.0 //边界网络做缺省路由

R2(config-router)#end

//之后R1学习到默认路由

步骤六:测试连通性

R1#ping 3.3.3.3 so 10.1.1.1

实验E:不等价负载均衡

E.0)实验目的:

熟悉掌握不等价负载技能

E.1)实验拓扑:

E.2)实验步骤:

步骤一:基本ip配置

步骤二:进行EIGRP配置

步骤三:观察:

R1:

R1#show ip eigrp topology

IP-EIGRP Topology Table for AS(123)/ID(1.1.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R -
Reply,

r - reply Status, s - sia Status

P 12.12.12.0/24, 1 successors, FD is 281600

via Connected, Ethernet1/0

P 13.13.13.0/24, 1 successors, FD is 2169856

via Connected, Serial0/0

P 23.23.23.0/24, 1 successors, FD is 2195456

via 12.12.12.2 (2195456/2169856), Ethernet1/0

via 13.13.13.3 (2681856/2169856), Serial0/0

P 30.3.3.0/24, 1 successors, FD is 435200

via 13.13.13.3 (2297856/128256), Serial0/0

R1#show ip eigrp topology all-link

IP-EIGRP Topology Table for AS(123)/ID(1.1.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R -
Reply,

r - reply Status, s - sia Status

P 12.12.12.0/24, 1 successors, FD is 281600, serno 1

via Connected, Ethernet1/0

P 13.13.13.0/24, 1 successors, FD is 2169856, serno 3

via Connected, Serial0/0

P 23.23.23.0/24, 1 successors, FD is 2195456, serno 18

via 12.12.12.2 (2195456/2169856), Ethernet1/0

via 13.13.13.3 (2681856/2169856), Serial0/0

P 30.3.3.0/24, 1 successors, FD is 435200, serno 7

via 13.13.13.3 (2297856/128256), Serial0/0

via 12.12.12.2 (2323456/2297856), Ethernet1/0

配置:

不等价负载均衡值

所有路径(最大路径/最小路径)取整(向下取)+1

步骤四:设置不等价负载均衡值

R1#conf t

R1(config)#router eigrp 123

R1(config-router)#variance 2

R1(config-router)#end

不等价负载均衡审查条件

1)不等价负载均衡链路总数不能超过默认的4

Router eigrp 123

Maxmum-paths ? <1-16>

2)不等价负载均衡次优路径AD必须小于FDMIN

3)不等价负载均衡值乘以FDMIN要大于所有次优路径FD

步骤五:修改延迟满足不等价均衡的条件

R2#show int s0/1 | in DLY

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

R2#CONF T

R2(config)#int s0/1

R2(config-if)#delay 1999 //数值自动乘10

R2(config-if)#end

检测:show ip route eigrp(30.3.3.0从23.23.23.3走)

实验F:EIGRP末梢设置(EIGRP STUB)

SIA:卡在激活状态

EIGRP Stub 是避免 SIA最佳方案

R1#conf t

R1(config)#router eigrp 123

R1(config-router)#eigrp stub connected summary redistributed

EIGRP Stub 控制路由更新和发送

自制EIGRP配置实验大全的更多相关文章

  1. 自制OSPF配置实验大全

    OSPF综合实验(gns模拟器)   注意点: Ospf实验推荐用gns制作 //图中的交换机可以视觉忽略或缩小成一个点.(^ v^) Ospf 实验拓扑图 ​ 目录 OSPF综合实验... 1 Os ...

  2. 自制STP配置实验

    本图使用Gns模拟器 实验需求: 1.要求利用vtp实现vlan同步设置 2.要求vtp server实现备份冗余 3.创建vlan 1~10要求MLSW1 是奇数vlan主根 MLSW2 是偶数vl ...

  3. HCIA-datacom 4.3 实验三:网络地址转换配置实验

    实验介绍: 网络地址转换NAT(Network Address Translation)是将IP数据报文头中的IP地址转换为另一个IP地址的过程.作为减缓IP地址枯竭的一种过渡方案,NAT通过地址重用 ...

  4. CCNP第三天 EIGRP综合实验

    实验题如图所示:其中R2连R3 R5为快速以太网线,其他均为串线,帧中继默认是富曼斯(全连网状结构),即所有接入的路由之间的PVC都已经打通,所有  要关闭R5和R8的逆向arp功能,来手工配置R5到 ...

  5. 默认路由、RIPv2、OSPF、EIGRP配置(全网全通)

    1:默认路由 遇到问题:给r2配置向右的单项默认路由,通过PC1去ping主机PC2,一直显示Request timed out, 解决方法:r2配置如下: r2(config)#ip route 0 ...

  6. EIGRP 高级实验

    一.环境准备 1. 软件:GNS3 2. 路由:c7200 二.实验操作 实验要求: 1.掌握EIGRP  的不等价均衡的条件. 2.掌握EIGRP  的metric  值修改方法. 3.掌握 EIG ...

  7. EIGRP 基础实验

    一.环境准备 1. 软件:GNS3 2. 路由:c7200 二.实验操作 实验要求: 1.掌握EIGRP 的基本配置 2.掌握EIGRP 的通配符掩配置方法 3.掌握EIGRP 的自动汇总特性,理解E ...

  8. 【网络】默认路由、RIPv2、OSPF、EIGRP配置(全网全通)

    1:默认路由 遇到问题:给r2配置向右的单项默认路由,通过PC1去ping主机PC2,一直显示Request timed out, 解决方法:r2配置如下: r2(config)#ip route 0 ...

  9. VS项目属性配置实验过程

    (原创,转载注明出处:http://www.cnblogs.com/binxindoudou/p/4017975.html ) 一.实验背景 cocos2d-x已经发展的相对完善了,从项目的创建.编译 ...

随机推荐

  1. (5)UIView常见属性

    此时打印的所有子控件会把使用自动布局的控件也打印出来,不准确,所以得去掉这两个选项,再进行打印 使用实例如下: viewWithTag的注意点,当有多个相同的Tag值时,它是先找到第一个Tag值,而不 ...

  2. Unity 发布的 WebGL 使用SendMessage传递多个参数

    如果要实现Unity与浏览器的数据交互一般都会采用两种方式 方法一: Application.ExternalCall("SayHello","helloworld&qu ...

  3. Head First 设计模式 第1章 策略模式

    本章从浅入深的讲解了策略模式的使用,以及策略模式中所涉及到的几个设计原则,在本章的最后给出了策略模式的定义. 1.定义及优点 什么是策略模式呢? 答:定义算法族(对象),分别封装起来,让他们之间可以相 ...

  4. NYOJ 23.取石子(一)

    取石子(一) 时间限制:3000 ms  |  内存限制:65535 KB 难度:2   描述 一天,TT在寝室闲着无聊,和同寝的人玩起了取石子游戏,而由于条件有限,他/她们是用旺仔小馒头当作石子.游 ...

  5. 学习笔记TF035:实现基于LSTM语言模型

    神经结构进步.GPU深度学习训练效率突破.RNN,时间序列数据有效,每个神经元通过内部组件保存输入信息. 卷积神经网络,图像分类,无法对视频每帧图像发生事情关联分析,无法利用前帧图像信息.RNN最大特 ...

  6. Xmemcached学习笔记

    memcached有三种java客户端 第一种:Com.danga 包下面的memcached,需引入jar(本人用的是memcached-2.5.2.jar 文末附上附件需要的可以下载) 第二种:s ...

  7. Ubuntu安装iNOde

    学校使用的是Inode客户端认证上网的.而且还只能使用iNodeSetup3.60-6210版本进行连接,之前使用Ubuntu 32位版本,可以完美地安装并能够连接到网站.由于我的机子是64位的机子, ...

  8. 高级映射,查询缓存和与spring整合

    一.高级映射 -------一对一 这里以订单查询为例,其中有一个外键为user_id,通过这个关联用户表.这里要实现的功能是这个两个表关联查询,得到订单的信息和部分user的信息.order表结构如 ...

  9. Python 对象引用、可变性和垃圾回收

    p.p1 { margin: 0.0px 0.0px 0.0px 0.0px; font: 25.0px Helvetica } 变量不是盒子 在示例所示的交互式控制台中,无法使用"变量是盒 ...

  10. Go语言数组的使用

    Go 语言数组 Go 语言提供了数组类型的数据结构. 数组是具有相同唯一类型的一组已编号且长度固定的数据项序列,这种类型可以是任意的原始类型例如整形.字符串或者自定义类型. 相对于去声明number0 ...