网络拓扑图:

SPINE1配置

======================================================

hostname SPINE-1
nv overlay evpn
feature ospf
feature bgp
feature pim
feature nv overlay

ip pim rp-address 192.168.1.8 group-list 239.0.0.0/24
ip pim log-neighbor-changes
ip pim ssm range 232.0.0.0/8
ip pim anycast-rp 192.168.1.8 192.168.1.1
ip pim anycast-rp 192.168.1.8 192.168.1.2

vrf context management

interface Ethernet1/1
no switchport
ip address 10.10.1.1/30
ip ospf network point-to-point
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
no shutdown

interface Ethernet1/2
no switchport
ip address 10.10.3.1/30
ip ospf network point-to-point
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
no shutdown

interface loopback0
ip address 192.168.1.1/32
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode

interface loopback1
ip address 192.168.1.8/32
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
line console
line vty
boot nxos bootflash:/nxos.7.0.3.I5.2.bin
router ospf 100
router-id 192.168.1.1
log-adjacency-changes
router bgp 65001
router-id 192.168.1.1
log-neighbor-changes
address-family ipv4 unicast
address-family l2vpn evpn
retain route-target all
template peer VTEP
remote-as 65001
update-source loopback0
address-family ipv4 unicast
send-community
send-community extended
route-reflector-client
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
neighbor 192.168.1.3
inherit peer VTEP
remote-as 65001
neighbor 192.168.1.4
inherit peer VTEP
remote-as 65001

SPINE2配置

======================================================

hostname SPINE-2

nv overlay evpn
feature ospf
feature bgp
feature pim
feature nv overlay

ip pim rp-address 192.168.1.8 group-list 239.0.0.0/24
ip pim log-neighbor-changes
ip pim ssm range 232.0.0.0/8
ip pim anycast-rp 192.168.1.8 192.168.1.1
ip pim anycast-rp 192.168.1.8 192.168.1.2

vrf context management

interface Ethernet1/1
no switchport
ip address 10.10.4.1/30
ip ospf network point-to-point
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
no shutdown

interface Ethernet1/2
no switchport
ip address 10.10.2.1/30
ip ospf network point-to-point
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
no shutdown

interface loopback0
ip address 192.168.1.2/32
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode

interface loopback1
ip address 192.168.1.8/32
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
line console
line vty
boot nxos bootflash:/nxos.7.0.3.I5.2.bin
router ospf 100
router-id 192.168.1.2
log-adjacency-changes
router bgp 65001
router-id 192.168.1.2
log-neighbor-changes
address-family ipv4 unicast
address-family l2vpn evpn
retain route-target all
template peer VTEP
remote-as 65001
update-source loopback0
address-family ipv4 unicast
send-community
send-community extended
route-reflector-client
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
neighbor 192.168.1.3
inherit peer VTEP
remote-as 65001
neighbor 192.168.1.4
inherit peer VTEP
remote-as 65001

LEAF101配置

======================================================

hostname LEAF101

nv overlay evpn
feature ospf
feature bgp
feature pim
feature interface-vlan
feature vn-segment-vlan-based
feature nv overlay

vlan 1,11,21,31,41,901-904
fabric forwarding anycast-gateway-mac 0000.1111.2222
ip pim rp-address 192.168.1.8 group-list 239.0.0.0/24
ip pim log-neighbor-changes
ip pim ssm range 232.0.0.0/8
vlan 11
vn-segment 160011
vlan 21
vn-segment 160021
vlan 31
vn-segment 160031
vlan 41
vn-segment 160041
vlan 901
vn-segment 900901
vlan 902
vn-segment 900902
vlan 903
vn-segment 900903
vlan 904
vn-segment 900904

vrf context APP
vni 900901
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context CTRIX
vni 900903
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context DB
vni 900904
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context VM
vni 900902
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context management

interface Vlan1

interface Vlan11
no shutdown
mtu 9216
vrf member APP
ip address 10.133.1.254/24
fabric forwarding mode anycast-gateway

interface Vlan21
no shutdown
mtu 9216
vrf member VM
ip address 10.63.1.254/24
fabric forwarding mode anycast-gateway

interface Vlan31
no shutdown
mtu 9216
vrf member CTRIX
ip address 10.158.1.254/24
fabric forwarding mode anycast-gateway

interface Vlan41
no shutdown
mtu 9216
vrf member DB
ip address 10.79.1.254/24
fabric forwarding mode anycast-gateway

interface Vlan901
no shutdown
mtu 9216
vrf member APP
no ip redirects
ip forward

interface Vlan902
no shutdown
mtu 9216
vrf member VM
no ip redirects
ip forward

interface Vlan903
no shutdown
mtu 9216
vrf member CTRIX
no ip redirects
ip forward

interface Vlan904
no shutdown
mtu 9216
vrf member DB
no ip redirects
ip forward

interface nve1
no shutdown
source-interface loopback0
host-reachability protocol bgp
member vni 160011
mcast-group 239.0.0.1
member vni 160021
mcast-group 239.0.0.2
member vni 160031
mcast-group 239.0.0.3
member vni 160041
mcast-group 239.0.0.4
member vni 900901 associate-vrf
member vni 900902 associate-vrf
member vni 900903 associate-vrf
member vni 900904 associate-vrf

interface Ethernet1/1
no switchport
ip address 10.10.1.2/30
ip ospf network point-to-point
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
no shutdown

interface Ethernet1/2
no switchport
ip address 10.10.2.2/30
ip ospf network point-to-point
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
no shutdown

interface Ethernet1/3
switchport access vlan 11

interface loopback0
ip address 192.168.1.3/32
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
line console
line vty
boot nxos bootflash:/nxos.7.0.3.I5.2.bin
router ospf 100
router-id 192.168.1.3
log-adjacency-changes
router bgp 65001
router-id 192.168.1.3
log-neighbor-changes
address-family ipv4 unicast
address-family l2vpn evpn
neighbor 192.168.1.1
remote-as 65001
update-source loopback0
address-family ipv4 unicast
send-community
send-community extended
address-family l2vpn evpn
send-community
send-community extended
neighbor 192.168.1.2
remote-as 65001
update-source loopback0
address-family ipv4 unicast
send-community
send-community extended
address-family l2vpn evpn
send-community
send-community extended
vrf APP
address-family ipv4 unicast
advertise l2vpn evpn
maximum-paths 2
vrf CTRIX
address-family ipv4 unicast
advertise l2vpn evpn
maximum-paths ibgp 2
vrf DB
address-family ipv4 unicast
advertise l2vpn evpn
maximum-paths ibgp 2
vrf VM
address-family ipv4 unicast
advertise l2vpn evpn
maximum-paths ibgp 2
evpn
vni 160011 l2
rd auto
route-target import auto
route-target export auto
vni 160021 l2
rd auto
route-target import auto
route-target export auto
vni 160031 l2
rd auto
route-target import auto
route-target export auto
vni 160041 l2
rd auto
route-target import auto
route-target export auto
ip tcp path-mtu-discovery

BORDERLEAF配置

======================================================

hostname BORDERLEAF

nv overlay evpn
feature ospf
feature bgp
feature pim
feature interface-vlan
feature vn-segment-vlan-based
feature nv overlay

vlan 1,11,21,31,41,901-904
fabric forwarding anycast-gateway-mac 0000.1111.2222
ip pim rp-address 192.168.1.8 group-list 239.0.0.0/24
ip pim log-neighbor-changes
ip pim ssm range 232.0.0.0/8
vlan 11
vn-segment 160011
vlan 21
vn-segment 160021
vlan 31
vn-segment 160031
vlan 41
vn-segment 160041
vlan 901
vn-segment 900901
vlan 902
vn-segment 900902
vlan 903
vn-segment 900903
vlan 904
vn-segment 900904

ip prefix-list static2bgp seq 5 permit 0.0.0.0/0 le 32
route-map static2bgp permit 10
match ip address prefix-list static2bgp
vrf context APP
vni 900901
ip route 0.0.0.0/0 Ethernet1/3.110 10.20.1.2
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context CTRIX
vni 900903
ip route 0.0.0.0/0 Ethernet1/3.130 10.20.3.2
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context DB
vni 900904
ip route 0.0.0.0/0 Ethernet1/3.140 10.20.4.2
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context VM
vni 900902
ip route 0.0.0.0/0 Ethernet1/3.120 10.20.2.2
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context management

interface Vlan11
no shutdown
mtu 9216
vrf member APP
ip address 10.133.1.254/24
fabric forwarding mode anycast-gateway

interface Vlan21
no shutdown
mtu 9216
vrf member VM
ip address 10.63.1.254/24
fabric forwarding mode anycast-gateway

interface Vlan31
no shutdown
mtu 9216
vrf member CTRIX
ip address 10.158.1.254/24
fabric forwarding mode anycast-gateway

interface Vlan41
no shutdown
mtu 9216
vrf member DB
ip address 10.79.1.254/24
fabric forwarding mode anycast-gateway

interface Vlan901
no shutdown
mtu 9216
vrf member APP
no ip redirects
ip forward

interface Vlan902
no shutdown
mtu 9216
vrf member VM
no ip redirects
ip forward

interface Vlan903
no shutdown
mtu 9216
vrf member CTRIX
no ip redirects
ip forward

interface Vlan904
no shutdown
mtu 9216
vrf member DB
no ip redirects
ip forward

interface nve1
no shutdown
source-interface loopback0
host-reachability protocol bgp
member vni 160011
mcast-group 239.0.0.1
member vni 160021
mcast-group 239.0.0.2
member vni 160031
mcast-group 239.0.0.3
member vni 160041
mcast-group 239.0.0.4
member vni 900901 associate-vrf
member vni 900902 associate-vrf
member vni 900903 associate-vrf
member vni 900904 associate-vrf

interface Ethernet1/1
no switchport
ip address 10.10.4.2/30
ip ospf network point-to-point
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
no shutdown

interface Ethernet1/2
no switchport
ip address 10.10.3.2/30
ip ospf network point-to-point
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
no shutdown

interface Ethernet1/3
no switchport
no shutdown

interface Ethernet1/3.110
encapsulation dot1q 110
vrf member APP
ip address 10.20.1.1/30
no shutdown

interface Ethernet1/3.120
encapsulation dot1q 120
vrf member VM
ip address 10.20.2.1/30
no shutdown

interface Ethernet1/3.130
encapsulation dot1q 130
vrf member CTRIX
ip address 10.20.3.1/30
no shutdown

interface Ethernet1/3.140
encapsulation dot1q 140
vrf member DB
ip address 10.20.4.1/30
no shutdown

interface loopback0
ip address 192.168.1.4/32
ip router ospf 100 area 0.0.0.0
ip pim sparse-mode
line console
line vty
boot nxos bootflash:/nxos.7.0.3.I5.2.bin
router ospf 100
router-id 192.168.1.4
log-adjacency-changes
router bgp 65001
router-id 192.168.1.4
log-neighbor-changes
address-family ipv4 unicast
address-family l2vpn evpn
neighbor 192.168.1.1
remote-as 65001
update-source loopback0
address-family ipv4 unicast
send-community
send-community extended
address-family l2vpn evpn
send-community
send-community extended
neighbor 192.168.1.2
remote-as 65001
update-source loopback0
address-family ipv4 unicast
send-community
send-community extended
address-family l2vpn evpn
send-community
send-community extended
vrf APP
address-family ipv4 unicast
advertise l2vpn evpn
redistribute static route-map static2bgp
maximum-paths 2
default-information originate
vrf CTRIX
address-family ipv4 unicast
advertise l2vpn evpn
redistribute static route-map static2bgp
maximum-paths ibgp 2
default-information originate
vrf DB
address-family ipv4 unicast
advertise l2vpn evpn
redistribute static route-map static2bgp
maximum-paths ibgp 2
default-information originate
vrf VM
address-family ipv4 unicast
advertise l2vpn evpn
redistribute static route-map static2bgp
maximum-paths ibgp 2
default-information originate
evpn
vni 16004 l2
rd auto
vni 160011 l2
rd auto
route-target import auto
route-target export auto
vni 160021 l2
rd auto
route-target import auto
route-target export auto
vni 160031 l2
rd auto
route-target import auto
route-target export auto
vni 160041 l2
rd auto
route-target import auto
route-target export auto
ip tcp path-mtu-discovery

ISP配置

======================================================

!
hostname ISP

!
interface Loopback0
ip address 123.103.15.129 255.255.255.255
!
interface GigabitEthernet1.110
encapsulation dot1Q 110
ip address 10.20.1.2 255.255.255.252
!
interface GigabitEthernet1.120
encapsulation dot1Q 120
ip address 10.20.2.2 255.255.255.252
!
interface GigabitEthernet1.130
encapsulation dot1Q 130
ip address 10.20.3.2 255.255.255.252
!
interface GigabitEthernet1.140
encapsulation dot1Q 140
ip address 10.20.4.2 255.255.255.252
!
interface GigabitEthernet2
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet3
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet4
no ip address
shutdown
negotiation auto
!
!
virtual-service csr_mgmt
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip route 10.63.0.0 255.255.0.0 GigabitEthernet1.120 10.20.2.1
ip route 10.79.0.0 255.255.0.0 GigabitEthernet1.140 10.20.4.1
ip route 10.133.0.0 255.255.0.0 GigabitEthernet1.110 10.20.1.1
ip route 10.158.0.0 255.255.0.0 GigabitEthernet1.130 10.20.3.1
!

在leaf上查看NVE peer

======================================================

在VPC上ping测试external的loopback地址123.103.15.129/32

======================================================

VXLAN IBGP RR 实验的更多相关文章

  1. [原] 利用 OVS 建立 VxLAN 虚拟网络实验

    OVS 配置 VxLAN HOST A ------------------------------------------ | zh-veth0(10.1.1.1) VM A | | ---|--- ...

  2. Open vSwitch系列实验(三):Open vSwitch的VxLAN隧道网络实验

    1 实验目的 该实验通过Open vSwitch构建Overlay的VxLAN网络,更直观的展现VxLAN的优势.在实验过程中,可以了解如何建立VxLAN隧道并进行配置,并实现相同网段和不同网段之间的 ...

  3. 干货分享: 长达150页的openvswitch的ppt,不实验无真相

    下载链接: Openvswitch实验教程 http://files.cnblogs.com/popsuper1982/Openvswtich.pptx 一.概论 Software Defined N ...

  4. GRE and VXLAN with Open vSwitch

    因为在OpenStack的Neutron中比较常用,所以参考别人的博客试了下OVS的一些隧道封装功能(GRE,VXLAN). 实验:实现两个host的Network namespace之间的通信,NS ...

  5. Linux 下实践 VxLAN

    本文首发于我的公众号 Linux云计算网络(id: cloud_dev),专注于干货分享,号内有 10T 书籍和视频资源,后台回复 「1024」 即可领取,欢迎大家关注,二维码文末可以扫. 来源:ht ...

  6. Linux 下实践 VxLAN:虚拟机和 Docker 场景

    本文首发于我的公众号 Linux云计算网络(id: cloud_dev),专注于干货分享,号内有 10T 书籍和视频资源,后台回复 「1024」 即可领取,欢迎大家关注,二维码文末可以扫. 在上篇文章 ...

  7. [转帖]Linux 下实践 VxLAN:虚拟机和 Docker 场景

    Linux 下实践 VxLAN:虚拟机和 Docker 场景 https://www.cnblogs.com/bakari/p/11264520.html 实践了下 没问题 作者写的很perfect ...

  8. Mysql学习笔记-临键锁实验

    前言 昨天同事跟我聊到一个问题:InnoDB里面间隙锁锁住的数据可以update么?我们经常都说间隙锁是InnoDB在RR隔离级别下防止幻读的一种处理手段.它可以防止数据在间隙范围中insert数据, ...

  9. BGP笔记

    BGP:用于AS与AS之间的路由,但现在也越来越多的用在IDC内部了 BGP是应用层协议,应用TCP协议(唯一一个运用TCP的路由协议) IGP和EGP的区别:IGP运行在一个AS之内,EGP运行在A ...

随机推荐

  1. 中国境内PE\VC\投资公司名单

    中国境内PE\VC\投资公司名单 1.青云创投 2.高盛 3.红杉资本 4.鼎晖创投 5.枫丹国际 6.派杰投资银行 7.凯雷投资 8.长安私人资本 9.格林雷斯 10.汉能资本 11.启明创投 12 ...

  2. Same Tree 深度优先

    Given two binary trees, write a function to check if they are equal or not. Two binary trees are con ...

  3. 小爬爬2:fiddler安装和了解fiddler

    1.解压安装就可以了 fiddler优点:抓取移动和PC机器的请求 2.首先进行证书的配置 如果不配置只能抓取http的请求,https不能抓取. 先选择,第一个"清空所有内容" ...

  4. .net 数据表格显示控件

    版权声明:本文为博主原创文章.未经博主同意不得转载. https://blog.csdn.net/chenjinge7/article/details/30470609 1. GridView 控件 ...

  5. MySQL中使用LIMIT进行分页的方法

    一.分页需求: 客户端通过传递start(页码),pageSize(每页显示的条数)两个参数去分页查询数据库表中的数据,那我们知道MySql数据库提供了分页的函数limit m,n,但是该函数的用法和 ...

  6. php 正则学习取反符号~

    php 正则学习取反符号~ ~(<a .*?>.*?</a>|<.*?>)~i 先看正则图形,有点偏差,但可以初步看出结果. 关于 ~ 是取反符号,看下面说明.

  7. oracle表内连接和外连接

    n  概述 表连接分为内连接和外连接 n  内连接 内连接实际上就是利用where子句对两张表形成的笛卡尔集进行筛选,我们前面学习的查询都是内连接,也是在开发过程中用的最多的连接查询. 基本语法: s ...

  8. SpringBoot @Transactional的rollbackFor属性

    1.简单回顾Java Exception 该图摘自:https://blog.csdn.net/zhangerqing/article/details/8248186 一方面,我们可以将异常分为运行时 ...

  9. Datanodes-心跳机制

  10. C++ 输出到文本文件

    输出到文本文件 就像从文件输入数据一样,你也可以将数据输出到文件.假设你有一个矩阵,你想把结果保存到一个文本文件中.你会看到,将矩阵输出到文件的代码和将矩阵输出到终端的代码非常相似. 你需要在本地运行 ...