ospf综合实验(1)

本实验主要考察ospf中的接口上的多种工作方式

实验如图所示:

所用拓扑为CCNP标准版,如图:

-------------------------------------------------------------------------------------------------------------------------------------

1. 全网可达

由于CCNP中帧中继是默认全部开启,而且是全连通的,所以在物理接口和多点子接口上建议关闭逆向arp功能,来手写map,否则会有很多与实验图不符合的map

而对于点对点子接口,由于其只有两端,且不考虑ip地址,所以不需要关闭逆向arp功能

R1(config)#int lo0
R1(config-if)#ip add 1.1.1.1 255.255.255.0

R1(config-if)#int s1/2
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shutdown

R1(config)#int s1/2.1 multipoint
R1(config-subif)#no frame-relay inverse-arp
R1(config-subif)#no arp frame-relay
R1(config-subif)#ip add 145.1.1.1 255.255.255.0
R1(config-subif)#frame-relay map ip 145.1.1.4 104 broadcast
R1(config-subif)#frame-relay map ip 145.1.1.5 105 broadcast

R1(config)#int s1/2.2 point-to-point
R1(config-subif)#ip add 16.1.1.1 255.255.255.0
R1(config-subif)#frame-relay interface-dlci 106

R1(config)#int s1/2.3 point-to-point
R1(config-subif)#ip add 123.1.1.1 255.255.255.0
R1(config-subif)#frame-relay interface-dlci 102

----------------------------------------------------------------------------------------------------------------------------------------

R2(config)#int lo0
R2(config-if)#ip add 2.2.2.2 255.255.255.0
R2(config)#int s1/2
R2(config-if)#encapsulation frame-relay
R2(config-if)#no frame-relay inverse-arp
R2(config-if)#no arp frame-relay
R2(config-if)#ip add 123.1.1.2 255.255.255.0
R2(config-if)#frame-relay map ip 123.1.1.1 201 broadcast
R2(config-if)#frame-relay map ip 123.1.1.3 203 broadcast
R2(config-if)#no shutdown

-----------------------------------------------------------------------------------------------------------------------------------------

R3(config)#int lo0
R3(config-if)#ip add 3.3.3.3 255.255.255.0
R3(config)#int s1/2
R3(config-if)#encapsulation frame-relay
R3(config-if)#no frame-relay inverse-arp
R3(config-if)#no arp frame-relay
R3(config-if)#ip add 123.1.1.3 255.255.255.0
R3(config-if)#frame-relay map ip 123.1.1.2 302 broadcast

----------------------------------------------------------------------------------------------------------------------------------------

R4(config)#int lo0
R4(config-if)#ip add 4.4.4.4 255.255.255.0

R4(config)#int s1/2
R4(config-if)#encapsulation frame-relay
R4(config-if)#no shutdown

R4(config)#int s1/2.1 point-to-point
R4(config-subif)#ip add 145.1.1.4 255.255.255.0
R4(config-subif)#frame-relay interface-dlci 401

R4(config)#int s1/2.2 point-to-point
R4(config-subif)#ip add 45.1.1.4 255.255.255.0
R4(config-subif)#frame-relay interface-dlci 405

-----------------------------------------------------------------------------------------------------------------------------------------

R5(config)#int lo0
R5(config-if)#ip add 5.5.5.5 255.255.255.0

R5(config-if)#int s1/2
R5(config-if)#encapsulation frame-relay
R5(config-if)#no shutdown

R5(config)#int s1/2.1 point-to-point
R5(config-subif)#ip add 45.1.1.5 255.255.255.0
R5(config-subif)#frame-relay interface-dlci 504

R5(config)#int s1/2.2 multipoint
R5(config-subif)#no frame-relay inverse-arp
R5(config-subif)#no arp frame-relay
R5(config-subif)#ip add 145.1.1.5 255.255.255.0
R5(config-subif)#frame-relay map ip 145.1.1.1 501 broadcast

-------------------------------------------------------------------------------------------------------------------------------------------

R6(config)#int lo0
R6(config-if)#ip add 6.6.6.6 255.255.255.0

R6(config)#int s1/2
R6(config-if)#encapsulation frame-relay
R6(config-if)#no frame-relay inverse-arp
R6(config-if)#no arp frame-relay
R6(config-if)#ip add 16.1.1.6 255.255.255.0
R6(config-if)#frame-relay map ip 16.1.1.1 601 broadcast
R6(config-if)#no shutdown

R6(config)#int f0/0
R6(config-if)#ip add 10.1.1.6 255.255.255.0
R6(config-if)#no shutdown

-------------------------------------------------------------------------------------------------------------------------------------------

R7(config-if)#int lo0
R7(config-if)#ip add 7.7.7.7 255.255.255.0

R7(config)#int f0/0
R7(config-if)#ip add 10.1.1.7 255.255.255.0
R7(config-if)#no shutdown

----------------------------------------------------------------------------------------------------------------------------------------------

R8(config)#int lo0
R8(config-if)#ip add 8.8.8.8 255.255.255.0

R8(config)#int f0/0
R8(config-if)#ip add 10.1.1.8 255.255.255.0
R8(config-if)#no shutdown

到目前为止,基本底层全部配置完毕,应该进行连通测试。 接来下,启ospf协议
==========================================================================================

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 145.1.1.1 0.0.0.0 area 0
R1(config-router)#network 123.1.1.1 0.0.0.0 area 0
R1(config-router)#network 16.1.1.1 0.0.0.0 area 0
R1(config-router)#network 1.1.1.1 0.0.0.0 area 0

R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 123.1.1.2 0.0.0.0 area 0
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0

R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 123.1.1.1 0.0.0.0 area 0
R3(config-router)#network 3.3.3.3 0.0.0.0 area 0

R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 145.1.1.4 0.0.0.0 area 0
R4(config-router)#network 45.1.1.4 0.0.0.0 area 0
R4(config-router)#network 4.4.4.4 0.0.0.0 area 0

R5(config)#router ospf 1
R5(config-router)#router-id 5.5.5.5
R5(config-router)#network 45.1.1.5 0.0.0.0 area 0
R5(config-router)#network 145.1.1.5 0.0.0.0 area 0
R5(config-router)#network 5.5.5.5 0.0.0.0 area 0

R6(config)#router ospf 1
R6(config-router)#router-id 6.6.6.6
R6(config-router)#network 16.1.1.6 0.0.0.0 area 0
R6(config-router)#network 6.6.6.6 0.0.0.0 area 0
R6(config-router)#network 10.1.1.6 0.0.0.0 area 1

R7(config)#router ospf 1
R7(config-router)#router-id 7.7.7.7
R7(config-router)#network 7.7.7.7 0.0.0.0 area 1
R7(config-router)#network 10.1.1.7 0.0.0.0 area 1

R8(config)#router ospf 1
R8(config-router)#router-id 8.8.8.8
R8(config-router)#network 8.8.8.8 0.0.0.0 area 1
R8(config-router)#network 10.1.1.8 0.0.0.0 area 1

此时R1到R8的路由协议ospf都已经启起来了,但是路由表中还是不齐全,这是因为ospf在不同的接口上的工作方式不同,所以无法建立邻接关系,即无法交互路由条目 下面修改接口成对应的工作方式。
--------------------------------------------------------------------------------------------------------------------------------------

因为R1 R4 R5构成145.1.1.0/24网段的是MA网络,所以修改这三个接口的工作方式为点到多点型

R1(config)#int s1/2.1
R1(config-subif)#ip ospf network point-to-multipoint

R4(config)#int s1/2.1
R4(config-subif)#ip ospf network point-to-multipoint

R5(config)#int s1/2.2
R5(config-subif)#ip ospf network point-to-multipoint

R1 R6构成的16.1.1.0/24网段中,因为R1接口是点到点工作方式, R6为物理接口,工作方式为非广播,故修改R6接口工作方式为点到点

R6(config)#int s1/2
R6(config-if)#ip ospf network point-to-point

R1 R2 R3构成的网络和145.1.1.0/24网段类似,修改三个接口工作方式为点到多点

R1(config)#int s1/2.3
R1(config-subif)#ip ospf network point-to-multipoint

R2(config)#int s1/2
R2(config-if)#ip ospf network point-to-multipoint

R3(config)#int s1/2
R3(config-if)#ip ospf network point-to-multipoint

剩下的 R4 R5 因为两端子接口都是点到点子接口,工作方式都是点对点,所以不用修改。

此时,稍等ospf收敛完成, R1 - R6的路由条目应该也全部习得,此时全网可达
如图所示:

----------------------------------------------------------------------------------------------------------------------------------------

2. R6-R8之间R6为DR, 无BDR

R6为DR,无BDR,即修改R7和R8的选举优先级为0

R7(config)#int f0/0
R7(config-if)#ip ospf priority 0

R8(config)#int f0/0
R8(config-if)#ip ospf priority 0

修改后如图所示:

R6

R7

R8

-----------------------------------------------------------------------------------------------------------------------------------------

声明:

  本文为 大Yi巴狼 对自己所学的知识整理和实现。

  本文档欢迎自由转载,但请务必保持本文档完整或注明来之本文档。本文档未经 大Yi巴狼 同意,不得用于商业用途。最后,如果您能从这个简单文档里获得些许帮助,大Yi巴狼 将对自己的一点努力感到非常高兴;由于作者本人水平有限,如果本文档中包含的错误给您造成了不便,在此提前说声抱歉。

  祝身体健康,工作顺利。

CCNP第四天 OSPF综合实验(1)的更多相关文章

  1. ACL与OSPF综合实验

    OSPF与ACL 综合实验   拓扑图如下: 分析: 配置基本配置: R1: R2: R3: 2.配置OSPF: R1: R2: R3: IT: 设置IT的ip 并划分到ospf2区域 3.配置ACL ...

  2. OSPF综合实验

    实验要求: 1.R4为ISP,其上只能配置IP地址,R4与其他所有直连设备间使用共有IP 2.R3--R5/6/7为MGRE环境,R3为中心站点 3.整个OSPF环境IP地址为172.16.0.0/1 ...

  3. CCNP第三天 EIGRP综合实验

    实验题如图所示:其中R2连R3 R5为快速以太网线,其他均为串线,帧中继默认是富曼斯(全连网状结构),即所有接入的路由之间的PVC都已经打通,所有  要关闭R5和R8的逆向arp功能,来手工配置R5到 ...

  4. OSPF 综合实验

    实验拓扑 实验需求 1.按照图示配置好 IP 地址,PC1 网关指向为 R8 2.OSPF 划分为 4 个区域,其中 192.168.0.0/24,192.168.1.0/24,192.168.2.0 ...

  5. 自制OSPF配置实验大全

    OSPF综合实验(gns模拟器)   注意点: Ospf实验推荐用gns制作 //图中的交换机可以视觉忽略或缩小成一个点.(^ v^) Ospf 实验拓扑图 ​ 目录 OSPF综合实验... 1 Os ...

  6. OSPF与ACL综合实验

    OSPF与ACL综合实验 1.实验内容 (1)企业内网运行OSPF路由协议,区域规划如拓扑图所示(见3.实验拓扑图): (2)财务和研发所在的区域不受其他区域链路不稳定性影响: (3)R1.R2.R3 ...

  7. 第三组 通信一班 030 OSPFv2、OSPFv3综合实验

      一.        实验目的 掌握 OSPFv2. OSPFv3 的配置方法 掌握在帧中继环境下OSPFv2. OSPFv3 的配置方法 掌握 OSPFv2. OSPFv3 NSSA 的配置方法 ...

  8. 【Linux程序设计】之环境系统函数综合实验

    这个系列的博客贴的都是我大二的时候学习Linux系统高级编程时的一些实验程序,都挺简单的.贴出来纯粹是聊胜于无. 实验题目:Linux环境下系统函数综合实验 实验目的:熟悉并掌握Linux环境下数学函 ...

  9. 华为路由交换综合实验 ---IA阶段

    目录 华为路由交换综合实验 ---IA阶段 实验拓扑 实验需求 华为路由交换综合实验 ---IA阶段 实验拓扑 实验需求 根据拓扑合理规划IP地址以及VLANIf地址(PC1属于运营部,PC2属于市场 ...

随机推荐

  1. XML 之 与Json或String的相互转换

    1.XML与String的相互转换 [1] XML 转为 String //载入Xml文件 XmlDocument xdoc = new XmlDocument(); xdoc.Load(" ...

  2. Objective-C ,ios,iphone开发基础:使用第三方库FMDB连接sqlite3 数据库,实现简单的登录

    第一步:下载第三方库,点击 连接 下载, 第二部:准备数据库:按照连接&中博客的步骤实现数据库, 数据库的设计大致如下表: id        username             pas ...

  3. Java代码操作Redis的sentinel和Redis的集群Cluster操作

    总共四台机器,crxy99,crxy98分别是主节点和从节点.   crxy97和crxy96是两个监控此主从架构的sentinel节点. 看代码: import org.junit.Test; im ...

  4. 转:基于Webrtc的跨平台实时语音通信解决方案(讲座)

    转:http://edu.csdn.net/course/detail/320/

  5. jquery的datepicker汉化

    $("#date").datepicker({ dateFormat: "yy-mm-dd", monthNames:["1月", &quo ...

  6. HDOJ2018母牛的故事

    母牛的故事 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submi ...

  7. boost库区间range基本原理及使用实例

    由 www.169it.com 搜集整理 区间的概念类似于STL中的容器概念.一个区间提供了可以访问半开放区间[first,one_past_last)中元素的迭代器,还提供了区间中的元素数量的信息. ...

  8. Contoso 大学 - 10 - 高级 EF 应用场景

    原文 Contoso 大学 - 10 - 高级 EF 应用场景 By Tom Dykstra, Tom Dykstra is a Senior Programming Writer on Micros ...

  9. mysql补集合计算

    mysql补集计算方法:   两表是1对多关系,user_id是关联字段,两表的数据量都是千万级别的     子查询实现 select count(*),sum(total_money) from A ...

  10. iOS开发——app审核指导方针(官网)

    iOS 开发后上传到App Store审核的指导方针 ——苹果官网介绍地址 https://developer.apple.com/app-store/review/guidelines/