网络拓扑:

XRV1

==============================================================

!
hostname XRV1
!

interface Loopback0
ip address 220.198.32.1 255.255.255.255
ip router isis 100
!
interface Loopback1
ip address 114.114.1.1 255.255.255.255
!
interface GigabitEthernet1
ip address 10.10.1.1 255.255.255.252
ip router isis 100
negotiation auto
isis circuit-type level-2-only
!
interface GigabitEthernet2
ip address 10.10.1.9 255.255.255.252
ip router isis 100
negotiation auto
isis circuit-type level-2-only
!
interface GigabitEthernet3
ip address 10.10.1.17 255.255.255.252
ip router isis 100
negotiation auto
isis circuit-type level-2-only
!
router isis 100
net 49.0000.2201.9832.1000.00
is-type level-2-only
!
router bgp 4809
bgp router-id 220.198.32.1
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
network 114.114.1.1 mask 255.255.255.255
neighbor internal peer-group
neighbor internal password cisco
neighbor internal update-source Loopback0
neighbor 220.198.32.2 remote-as 4809
neighbor 220.198.32.2 peer-group internal
neighbor 220.198.32.3 remote-as 4809
neighbor 220.198.32.3 peer-group internal
neighbor 220.198.32.4 remote-as 4809
neighbor 220.198.32.4 peer-group internal
!

XRV2

==============================================================

hostname XRV2
!

interface Loopback0
ip address 220.198.32.2 255.255.255.255
ip router isis 100
!
interface Loopback1
ip address 114.114.1.2 255.255.255.255
!
interface GigabitEthernet1
ip address 10.10.1.2 255.255.255.252
ip router isis 100
negotiation auto
isis circuit-type level-2-only
!
interface GigabitEthernet2
ip address 10.10.1.13 255.255.255.252
ip router isis 100
negotiation auto
isis circuit-type level-2-only
!
interface GigabitEthernet3
ip address 10.10.1.21 255.255.255.252
ip router isis 100
negotiation auto
isis circuit-type level-2-only
!
router isis 100
net 49.0000.2201.9832.2000.00
is-type level-2-only
!
router bgp 4809
bgp router-id 220.198.32.2
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
network 114.114.1.2 mask 255.255.255.255
neighbor internal peer-group
neighbor internal password cisco
neighbor internal update-source Loopback0
neighbor 220.198.32.1 remote-as 4809
neighbor 220.198.32.1 peer-group internal
neighbor 220.198.32.3 remote-as 4809
neighbor 220.198.32.3 peer-group internal
neighbor 220.198.32.4 remote-as 4809
neighbor 220.198.32.4 peer-group internal
!

XRV3

==============================================================

!
hostname XRV3
!

interface Loopback0
ip address 220.198.32.3 255.255.255.255
ip router isis 100
!
interface Loopback1
ip address 114.114.1.3 255.255.255.255
!
interface GigabitEthernet1
ip address 10.10.1.5 255.255.255.252
ip router isis 100
negotiation auto
isis circuit-type level-2-only
!
interface GigabitEthernet2
ip address 10.10.1.10 255.255.255.252
ip router isis 100
negotiation auto
isis circuit-type level-2-only
!
interface GigabitEthernet3
ip address 10.10.1.22 255.255.255.252
ip router isis 100
negotiation auto
isis circuit-type level-2-only
!
interface GigabitEthernet4
ip address 123.103.15.1 255.255.255.252
negotiation auto
bfd interval 250 min_rx 250 multiplier 3
!
router isis 100
net 49.0000.2201.9832.3000.00
is-type level-2-only
redistribute static ip
!
router isis 1200
!
router bgp 4809
bgp router-id 220.198.32.3
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
network 114.114.1.3 mask 255.255.255.255
neighbor internal peer-group
neighbor internal password cisco
neighbor internal update-source Loopback0
neighbor internal next-hop-self
neighbor internal route-map external-import out
neighbor 123.103.15.2 remote-as 9808
neighbor 123.103.15.2 password cisco
neighbor 123.103.15.2 fall-over bfd
neighbor 220.198.32.1 remote-as 4809
neighbor 220.198.32.1 peer-group internal
neighbor 220.198.32.2 remote-as 4809
neighbor 220.198.32.2 peer-group internal
neighbor 220.198.32.4 remote-as 4809
neighbor 220.198.32.4 peer-group internal
!
!
virtual-service csr_mgmt
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip route 108.108.108.1 255.255.255.255 123.103.15.2
!
!
ip prefix-list external-import seq 5 permit 114.114.1.5/32
ip prefix-list external-import seq 10 permit 114.114.1.6/32
!
route-map external-import permit 10
match ip address prefix-list external-import
set ip next-hop 108.108.108.1
!
route-map external-import permit 20
!

XRV4

==============================================================

!
hostname XRV4
!

interface Loopback0
ip address 220.198.32.4 255.255.255.255
ip router isis 100
!
interface Loopback1
ip address 114.114.1.4 255.255.255.255
!
interface GigabitEthernet1
ip address 10.10.1.6 255.255.255.252
ip router isis 100
negotiation auto
isis circuit-type level-2-only
!
interface GigabitEthernet2
ip address 10.10.1.14 255.255.255.252
ip router isis 100
negotiation auto
isis circuit-type level-2-only
!
interface GigabitEthernet3
ip address 10.10.1.18 255.255.255.252
ip router isis 100
negotiation auto
isis circuit-type level-2-only
!
interface GigabitEthernet4
ip address 61.135.142.1 255.255.255.252
negotiation auto
bfd interval 250 min_rx 250 multiplier 3
!
router isis 100
net 49.0000.2201.9832.4000.00
is-type level-2-only
redistribute static ip
!
router bgp 4809
bgp router-id 220.198.32.4
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
network 114.114.1.4 mask 255.255.255.255
neighbor internal peer-group
neighbor internal password cisco
neighbor internal update-source Loopback0
neighbor internal next-hop-self
neighbor internal route-map external-import out
neighbor 61.135.142.2 remote-as 9808
neighbor 61.135.142.2 password cisco
neighbor 61.135.142.2 fall-over bfd
neighbor 220.198.32.1 remote-as 4809
neighbor 220.198.32.1 peer-group internal
neighbor 220.198.32.2 remote-as 4809
neighbor 220.198.32.2 peer-group internal
neighbor 220.198.32.3 remote-as 4809
neighbor 220.198.32.3 peer-group internal
!
!
virtual-service csr_mgmt
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip route 108.108.108.1 255.255.255.255 61.135.142.2
!
!
ip prefix-list external-import seq 5 permit 114.114.1.5/32
ip prefix-list external-import seq 10 permit 114.114.1.6/32
!
route-map external-import permit 10
match ip address prefix-list external-import
set ip next-hop 108.108.108.1
!
route-map external-import permit 20
!

XRV5

==============================================================

!
hostname XRV5

!
interface Loopback0
ip address 220.198.32.5 255.255.255.255
ip router isis 100
!
interface Loopback1
ip address 114.114.1.5 255.255.255.255
!
interface GigabitEthernet1
ip address 10.10.2.1 255.255.255.252
ip router isis 100
negotiation auto
isis circuit-type level-2-only
!
interface GigabitEthernet4
ip address 123.103.15.2 255.255.255.252
negotiation auto
bfd interval 250 min_rx 250 multiplier 3
!
router isis 100
net 49.0000.2201.9832.5000.00
is-type level-2-only
!
router bgp 9808
bgp router-id 220.198.32.5
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
network 114.114.1.5 mask 255.255.255.255
neighbor 123.103.15.1 remote-as 4809
neighbor 123.103.15.1 password cisco
neighbor 123.103.15.1 fall-over bfd
neighbor 220.198.32.6 remote-as 9808
neighbor 220.198.32.6 password cisco
neighbor 220.198.32.6 update-source Loopback0
neighbor 220.198.32.6 next-hop-self
!

XRV6

==============================================================

!
hostname XRV6

interface Loopback0
ip address 220.198.32.6 255.255.255.255
ip router isis 100
!
interface Loopback1
ip address 114.114.1.6 255.255.255.255
!
interface GigabitEthernet1
ip address 10.10.2.2 255.255.255.252
ip router isis 100
negotiation auto
isis circuit-type level-2-only
!
interface GigabitEthernet4
ip address 61.135.142.2 255.255.255.252
negotiation auto
bfd interval 250 min_rx 250 multiplier 3
!
router isis 100
net 49.0000.2201.9832.6000.00
is-type level-2-only
!
router bgp 9808
bgp router-id 220.198.32.6
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
network 114.114.1.6 mask 255.255.255.255
neighbor 61.135.142.1 remote-as 4809
neighbor 61.135.142.1 password cisco
neighbor 61.135.142.1 fall-over bfd
neighbor 220.198.32.5 remote-as 9808
neighbor 220.198.32.5 password cisco
neighbor 220.198.32.5 update-source Loopback0
neighbor 220.198.32.5 next-hop-self
!

在XRV1上使用show ip bgp 查看BGP路由表

==============================================================

在XRV1上使用tracert跟踪路由,源为XRV1的l1地址,目标为XRV5的l1地址

==============================================================

配置要点:

1.在两个ISP的边界上写一条下一跳并非真实存在的路由,下一跳指向友商的真实的EBGP的接口地址

2.将上述静态路由重分布进ISIS路由

3.在边界上通过前缀列表匹配需要进行IBGP负载的友商的路由

4.通过route-map进行修改需要进行IBGP负载的友商的路由的下一跳为1的静态的目标路由

5.在边界上通过neighbor调用route-map修改下一跳后发布给IBGP

6.IBGP邻居受到从EBGP学习到的路由后即可实现负载

使用BGP的虚拟下一跳实现IGP的路由负载的更多相关文章

  1. 利用BGP虚拟下一跳实现链路负载均衡

    最近针对BGP链路负载均衡方案“虚拟下一跳”进行了总结,现将总结的PPT贴上来.

  2. Linux3.5内核以后的路由下一跳缓存

    在Linux3.5版本号(包括)之前.存在一个路由cache.这个路由cache的初衷是美好的,可是现实往往是令人遗憾的.下面是陈列得出的两个问题:1.面临针对hash算法的ddos问题(描写叙述该问 ...

  3. linux 接口地址全部清除才清理从此接口发出的下一跳路由

    接口地址全部清除才清理从此接口发出的下一跳路由 如: eth7配置两个地址 eth7: 192.168.1.1 10.1.1.1 添加一条路由: route add -net 2.2.2.0/24 g ...

  4. 等价路由在路由器和CE交换机上默认的行为是不同的,路由器总是走第一个下一跳,CE交换机是逐包。

    结论: 1.在eNSP中实验,路由器和CE交换机对于等价路由的默认转发行为是不同的, 路由器:默认是基于流的转发形态,更准确的来讲,ping两个不同的下一跳,都是走等价路由的第一个路由,不走第二条路由 ...

  5. 配置多个相同网段的ECMP下一跳,配合NQA健康检查实现高可靠性

    1.一般情况下,ECMP常用的常见是,针对很远的目的地址,下一跳分别是路由器的不同出端口,而路由器的不同端口是不同网段的,也就是说,下一跳是不同的网段地址. 但是,在连接到终端服务器时,常常会采用多个 ...

  6. route -A inet6 增加下一跳 提示错误 SIOCADDRT: No route to host

    1.增加前路由表: 2. route -A inet6 增加下一跳 提示错误 SIOCADDRT: No route to host 3.删除已有的下一条路由表项: 4.再次尝试 route -A i ...

  7. IBGP的自己下一跳,指定源命令。

    neighbor router-id update-source loopback int 当两者并不是以物理接口为搭建邻居的时候,就得使用指定源,充当TCP接口. neighbor router-i ...

  8. ensp的基础路由命令,接口,下一跳的配置,入门必备

    关于ensp入门事情,第一件事当是安装必备三件套:而后,应该是接触路由和PC机了,最烦人满屏代码,眼花缭乱: 今天写一篇零基础接触ensp的首次操作,PC-路由-路由-PC的互通实验: 实验要拉出两台 ...

  9. 【Azure API 管理】APIM集成内网虚拟网络后,启用自定义路由管理外出流量经过防火墙(Firewall),遇见APIs加载不出来问题

    问题描述 使用 Azure 虚拟网络,Azure APIM 可以管理无法通过 Internet 访问的 API,达到以保护企业内部的后端API的目的.在虚拟网络中,启用网络安全组(NSG:Networ ...

随机推荐

  1. OpenGL核心之视差映射

    笔者介绍:姜雪伟,IT公司技术合伙人.IT高级讲师,CSDN社区专家,特邀编辑.畅销书作者;已出版书籍:<手把手教你¯的纹理坐标偏移T3来对fragment的纹理坐标进行位移.你能够看到随着深度 ...

  2. Java 类锁、对象锁、私有锁

    3.6 Java类锁.对象锁.私有锁.隐式锁 类锁和对象锁是否会冲突?对象锁和私有锁是否会冲突?通过实例来进行说明. 一.相关约定 为了明确后文的描述,先对本文涉及到的锁的相关定义作如下约定: 1. ...

  3. [SVG] Add an SVG as a Background Image

    Learn how to set an SVG as the background image of an element. Background images can be resized by c ...

  4. Opencv 使用Stitcher类图像拼接生成全景图像

    Opencv中自带的Stitcher类可以实现全景图像,效果不错.下边的例子是Opencv Samples中的stitching.cpp的简化,源文件可以在这个路径里找到: \opencv\sourc ...

  5. BZOJ 1855 股票交易 - 单调队列优化dp

    传送门 题目分析: \(f[i][j]\)表示第i天,手中拥有j份股票的最优利润. 如果不买也不卖,那么\[f[i][j] = f[i-1][j]\] 如果买入,那么\[f[i][j] = max\{ ...

  6. ServletContextListener接口用法

    ServletContextListener接口用于tomcat启动时自动加载函数,方法如下: 一.需加载的类必须实现ServletContextListener接口. 二.该接口中有两个方法必须实现 ...

  7. React中的state与props的再理解

    props可以看做是 property 的缩写的复数,可以翻译为属性,类似于HTML 标签的自定义属性.在大多数React教程里讲 state 和 props 主要的区别在于 props 是不可变的, ...

  8. 简单的记录一下JavaScript 高级应用

    我是一名.net 程序员但是由于公司需求,开发离线app,但是在工作的过程中我发现,周围人在写JavaScript的时候都是面向过程的编码,对于我这.net程序员,遇到这种情况真是六神无主,但是工作中 ...

  9. 使用ant对项目进行多渠道打包时遇到问题记录

    1.打包成功后,打开apk时,会出现闪退的现象解决方法:1.配置好ant后,先把项目正常运行后,再打包,如有问题见第2步        2.找到项目中build.xml,然后右键,选择Run As - ...

  10. override 与overload 的差别

    方法的重写(Overriding)和重载(Overloading)是Java多态性的不同表现.   重写(Overriding)是父类与子类之间多态性的一种表现,而重载(Overloading)是一个 ...