作者:邓聪聪

  智能以太保护SEP(Smart Ethernet Protection)是一种专用于以太网链路层的环网协议。SEP是一种以太环路保护机制,它通过有选择性地阻塞网络环路冗余链路,来达到消除网络二层环路的目的,避免报文在环路网络中增生和无限循环,有效防止形成网络风暴。本人刚接手了一套网络,布局也不是太复杂,基本全是2层网络,所以就利用了sep这个小技术。

  实例1:

sysname sw1
#
vlan batch to
#
stp disable
#
sep segment
control-vlan
block port optimal
preempt delay
protected-instance to
sep segment
control-vlan
block port optimal
preempt delay
tc-notify segment
protected-instance to
#
interface Vlanif12
ip address 10.1.1.1 255.255.255.224
#
interface GigabitEthernet0//
port link-type trunk
port trunk allow-pass vlan
stp disable
sep segment
#
interface GigabitEthernet0//
port link-type access
port default vlan
#
interface GigabitEthernet0//
shutdown
port link-type trunk
undo port trunk allow-pass vlan
port trunk allow-pass vlan to
stp disable
sep segment edge primary
#
interface GigabitEthernet0//
shutdown
port link-type trunk
port trunk allow-pass vlan
stp disable
sep segment 10 edge primary
#
sysname sw2
#
stp disable
#
sep segment
control-vlan
protected-instance to
#

  sep segment 11
  control-vlan 100
  block port optimal
  preempt delay 30
  tc-notify segment 5
  protected-instance 0 to 48

interface GigabitEthernet0//
port link-type trunk
undo port trunk allow-pass vlan
port trunk allow-pass vlan
stp disable
sep segment
#
interface GigabitEthernet0//
port link-type trunk
undo port trunk allow-pass vlan
port trunk allow-pass vlan
stp disable
sep segment 5

  interface GigabitEthernet0/0/4
  port link-type trunk
  port trunk allow-pass vlan 11 100
  stp disable
  sep segment 11 edge primary

sysname sw3
#
stp disable
#
sep segment
control-vlan
protected-instance to
sep segment
control-vlan
tc-notify segment
protected-instance to
#
interface Vlanif11
ip address 1.1.1.30 255.255.255.224
#
interface Vlanif12
ip address 10.1.1.2 255.255.255.224
#
interface MEth0//
#
interface GigabitEthernet0//
port link-type access
port default vlan
#
interface GigabitEthernet0//
port link-type trunk
undo port trunk allow-pass vlan
port trunk allow-pass vlan
stp disable
sep segment
#
interface GigabitEthernet0//
port link-type trunk
undo port trunk allow-pass vlan
port trunk allow-pass vlan to
stp disable
sep segment
sep segment priority
#
interface GigabitEthernet0//
port link-type trunk
undo port trunk allow-pass vlan
port trunk allow-pass vlan
stp disable
sep segment
sep segment priority
#
sysname sw4
#
vlan batch
#
stp disable
#
sep segment
control-vlan
protected-instance to
#

  sep segment 11
  control-vlan 100
  tc-notify segment 10
  protected-instance 0 to 48

interface Vlanif11
ip address 1.1.1.4 255.255.255.224
#

interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 11 100
 stp disable
 sep segment 11
 sep segment 11 priority 128

interface GigabitEthernet0//
port link-type trunk
undo port trunk allow-pass vlan
port trunk allow-pass vlan
stp disable
sep segment
#
interface GigabitEthernet0//
port link-type trunk
port trunk allow-pass vlan
stp disable
sep segment
sysname sw5
#
sep segment
control-vlan
protected-instance to
#
interface GigabitEthernet0//
port link-type trunk
port trunk allow-pass vlan
stp disable
sep segment
#
interface GigabitEthernet0//
port link-type trunk
port trunk allow-pass vlan
stp disable
sep segment
#

  实例2:

9306配置:

sep segment 1
control-vlan 4094
block port optimal
preempt delay 30
tc-notify segment 2
protected-instance 0 to 48
sep segment 2
control-vlan 4094
block port optimal
preempt delay 15
tc-notify segment 1
protected-instance 0 to 48
sep segment 3
control-vlan 4090
block port optimal
preempt delay 15
protected-instance 0 to 48
#
interface Vlanif1
ip address 1.1.1.1 255.255.255.0
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
shutdown
port hybrid tagged vlan 4094
stp disable
sep segment 1 edge secondary
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 4094
stp disable
sep segment 2 edge primary
#
interface GigabitEthernet0/0/3
port hybrid tagged vlan 4094
stp disable
sep segment 1 edge primary
#
interface GigabitEthernet0/0/4
port hybrid tagged vlan 4090
stp disable
sep segment 3 edge primary
#
interface GigabitEthernet0/0/5
port hybrid tagged vlan 4090
stp disable
sep segment 3 edge secondary
#

 

分支1-5700配置:

sep segment
control-vlan
block port optimal
protected-instance to #
interface Vlanif1
ip address 1.1.1.254 255.255.255.0
#
interface MEth0//
#
interface GigabitEthernet0//
port hybrid tagged vlan
stp disable
sep segment
#
interface GigabitEthernet0//
port hybrid tagged vlan
stp disable
sep segment
#

分支3-5700配置:

sep segment 1
control-vlan 4094
tc-notify segment 2
protected-instance 0 to 48
sep segment 2
control-vlan 4094
tc-notify segment 1
protected-instance 0 to 48
#
interface Vlanif1
ip address 1.1.1.2 255.255.255.0
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 4094
stp disable
sep segment 2 edge secondary
#
interface GigabitEthernet0/0/2
port hybrid tagged vlan 4094
stp disable
sep segment 1
sep segment 1 priority 128
#
interface GigabitEthernet0/0/3
port hybrid tagged vlan 4094
stp disable
sep segment 1
#

分支2-5700配置:

sep segment 2
control-vlan 4094
protected-instance 0 to 48
#
interface Vlanif1
ip address 1.1.1.3 255.255.255.0
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
port hybrid tagged vlan 4094
stp disable
sep segment 2
sep segment 2 priority 128
#
interface GigabitEthernet0/0/2
shutdown
port hybrid tagged vlan 4094
stp disable
sep segment 2

分支1配置:

sep segment
control-vlan
protected-instance to
#
interface Vlanif1
#
interface MEth0//
#
interface GigabitEthernet0//
port hybrid tagged vlan
stp disable
sep segment
#
interface GigabitEthernet0//
port hybrid tagged vlan
stp disable
sep segment
#

分支2配置:

sep segment
control-vlan
protected-instance to
#
interface Vlanif1
ip address 1.1.1.6 255.255.255.0
#
interface MEth0//
#
interface GigabitEthernet0//
port hybrid tagged vlan
stp disable
sep segment
sep segment priority
#
interface GigabitEthernet0//
port hybrid tagged vlan
stp disable
sep segment

二层环路保护,SEP多实例的配置的更多相关文章

  1. 二层环路保护,RRPP多环的配置

    作者:邓聪聪 组网需求: 局域网中,由A/B/C/D构成RRPP域1换网络结构,要求环网机构中的任意两条线路中断都不能影响业务. 配置思路: 环路由两部分组成,ring1.ring2,B为环1的主节点 ...

  2. MSTP多实例的配置

    MSTP多实例的配置 这次实验主要是为了加强对stp生成树协议中,RP(根端口),DP(指定端口),AP(阻塞端口)的判断方法:虽然很多时候不需要我们人工判断,因为当我们吧所有的配置好之后,然后开启生 ...

  3. 《连载 | 物联网框架ServerSuperIO教程》2.服务实例的配置参数说明

    1.C#跨平台物联网通讯框架ServerSuperIO(SSIO)介绍  <连载 | 物联网框架ServerSuperIO教程>1.4种通讯模式机制 一.综述 SuperIO(SIO)定位 ...

  4. mysql多实例的配置和管理

    原文地址:mysql多实例的配置和管理 作者:飞鸿无痕 多实例mysql的安装和管理 mysql的多实例有两种方式可以实现,两种方式各有利弊.第一种是使用多个配置文件启动不同的进程来实现多实例,这种方 ...

  5. 第十七章——配置SQLServer(4)——优化SQLServer实例的配置

    原文:第十七章--配置SQLServer(4)--优化SQLServer实例的配置 前言: Sp_configure 可以用于管理和优化SQLServer资源,而且绝大部分配置都可以使用SQLServ ...

  6. SuperSocket入门(三)-Telnet多服务实例和服务实例交互配置详解

        在SuperSocket入门(二)中我们已经简单了解了通过配置App.config文件使用BootStrap启动SuperSocket服务.我们先来看一下上个案例中的基本配置文件示例: < ...

  7. oracle 单实例DG(配置篇二)

    一,DG搭建实例--主库配置 one : 归档配置 01,查看归档  1 select log_mode,force_logging from v$database; 02,开启归档 关闭数据库重新启 ...

  8. Amazon EC2安装mysql多实例并配置主从复制

    1.MySQL安装: EC2直接使用yum安装mysql很方便: yum install mysql mysql-server mysql-libs 此处安装了三个包 完事之后可以直接使用 servi ...

  9. 基于mysqld_multi实现MySQL 5.7.24多实例多进程配置

    学习环境: 操作系统 IP地址 主机名 软件包 备注 CentOS7.5 192.168.200.111 localhost       实验初始配置:所有主机关闭防火墙与selinux [root@ ...

随机推荐

  1. MySQL_参数设置

    1.max_allowed_packet 描述:有时备份数据库时,将本地psc文件备份到数据库时,会遇见备份不成功的情况 分析:这时要考虑,是否由于max_allowed_packet这个参数过小,导 ...

  2. zookeeper 介绍与集群安装

    zookeeper 介绍 ZooKeeper是一个分布式开源框架,提供了协调分布式应用的基本服务,它向外部应用暴露一组通用服务——分布式同步(Distributed Synchronization). ...

  3. 网络编程基础【day09】:堡垒机前戏(十一)

    本节内容 1.堡垒机前戏 2.SSHClient 3.SFTPClient 一.堡垒机前戏 开发堡垒机之前,先来学习Python的paramiko模块,该模块机遇SSH用于连接远程服务器并执行相关操作 ...

  4. 当php邂逅windows通用上传缺陷

    早上逛乌云发现了PKAV大牛的一篇文章,针对php和windows文件上传的分析,思路很YD,果断转之与大家分享. 虽然此文可能有许多的限制条件,但是如果你认真阅读会发现,其实还是比较实用的. 另外一 ...

  5. 学习总结:CSS(二)块级与行级元素特性、盒模型、层模型、BUG与BFC、浮动模型

    一.元素的块级与行级特性 在CSS属性display控制元素是否及如何显示的特性,常用的值有none.inline.block.inline-block,在CSS3中还有一些新的特性状态,在这里不做讨 ...

  6. zookeeper的Java端API应用

    1. 基本使用 org.apache.zookeeper.Zookeeper是客户端入口主类,负责建立与server的会话.它提供了表1所示几类主要方法: 功能 描述 create 在本地目录树中创建 ...

  7. 【四】Ribbon负载均衡

    1.概述1.1.是什么 Spring Cloud Ribbon 是基于Netflix Ribbon实现的一套客户端负载均衡的工具. 简单的说, Ribbon是Netflix发布的开源项目,主要功能是提 ...

  8. luogu 2014 选课 树上背包

    树上背包 #include<bits/stdc++.h> using namespace std; ; const int inf=0x3f3f3f3f; vector<int> ...

  9. 【U3d】Tiled2Unity 使用Tips

    Tiled编辑完地图后借Tiled2Unity导入Unity. 使用T2U时遇到点麻烦,打开T2U界面显示如下,注意上方黄底文字,需要在Tiled中添加命令行才能使用T2U. 在Tiled工具栏点击( ...

  10. l类与对象课后作业

    java 的初始化规律 执行类成员定义时指定的默认值或类的初始化块,到底执行哪一个要看哪一个“排在前面”. 执行类的构造函数. 类的初始化块不接收任何的参数,而且只要一创建类的对象,它们就会被执行.因 ...