Port-Channel 的在实际工作中的主要作用是将两个或多个端口捆绑成为一个虚拟通道。

interface Port-channel1
 description port(1/0/5-6)
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10
 switchport mode trunk
!
interface Port-channel2
 description port(1/0/7-8)
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10
 switchport mode trunk
!
interface Port-channel3
 description port(1/0/9-10)
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10
 switchport mode trunk
!
interface Port-channel4
 description port(1/0/11-12)
 shutdown

以上是我在Cisco 3750上做的配置,其中:

description port(1/0/5-6) 是对这个虚拟通道的描述,告知这个虚拟通道使用了端口1/0/ 的5和6端口

switchport trunk encapsulation dot1q 是强制虚拟通道使用dot 1q 来封装数据包

switchport trunk allowed vlan 10  是强制虚拟通道能够通过的VLAN,此例只有vlan10能通过此通道

switchport mode trunk 是强制为 triuk 模式

具体的命令如下:

3750-route#configure terminal

3750-route(config)#interface port-channel 1
3750-route(config-if)#switchport mode trunk
3750-route(config-if)#switchport trunk encapsulation dot1q
3750-route(config-if)#switchport trunk allowed vlan 10
3750-route(config-if)#description xxxxxx

创建 port-channel 1 后,还需要在相应的端口上进行配置

interface GigabitEthernet1/0/5
 description Port-channel-1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode on
!
interface GigabitEthernet1/0/6
 description Port-channel-1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode on

此处特别要提示的是最后的一条命令

channel-group 1 mode on 是 port-channel 1 可以调用此端口,换句话说:这个端口隶属于 port-channel 1

具体命令如下:

3750-route#configure terminal

3750-route(config)#interface range gigabitEthernet 1/0/5-6
3750-route(config-if)#switchport mode trunk
3750-route(config-if)#switchport trunk encapsulation dot1q
3750-route(config-if)#description xxxxxx
3750-route(config-if)#channel-group 1 mode on

端口聚合查看命令(排错常用命令)

#查看端口聚合信息,正常情况Port-channel显示是SU,如果显示SD就不正常

Switch#show etherchannel summary

更具体的命令:

Switch#sh etherchannel 3 summary   查PO3 汇总信息,即绑定哪些接口 做聚合

1 Po1(SU) PAgP Fa0/23(P) Fa0/24(P)

2 Po2(SU) PAgP Fa0/21(P) Fa0/22(P)

#查看通道接口状况

Switch#show etherchannel load-balance

Switch#sh int trunk     查所有允许trunk 通道的VLAN

更具体的命令:

Switch#sh int port-channel 1 trunk    查po1 允许通过的vlan  ,trunk 通道

sh int etherchannel

Cisco Port-Channel 设置(链路聚合--重点)的更多相关文章

  1. Cisco Port-Channel 设置(链路聚合)

    Port-Channel 的在实际工作中的主要作用是将两个或多个端口捆绑成为一个虚拟通道. interface Port-channel1 description port(1/0/5-6) swit ...

  2. 关于在链路聚合下做smart,monitor link的转发测试

    关于在链路聚合下做smart,monitor link的转发测试 这次又要开始瞎折腾了.没事找事了.毕竟我还是很无聊的: 这个实验主要要涉及到以下几个方面: 1.gvrp的应用: 2.Smart Li ...

  3. Cisco交换机基础命令 + Win Server08 R2 多网卡配置链路聚合

    最近捣鼓服务器链路集合需要配置交换机… 以前没弄过交换机,现学现卖… 一般交换机是支持telnet的,配置好ip可以直接telnet,当然如果没配的话就要用串口了,串口要选择Serial… 还好我们万 ...

  4. [CISCO] 交换机间链路聚合端口聚合

    [CISCO] 交换机间链路聚合端口聚合 一.Introduction 端口通道( port channel ) 是一种聚合多个物理接口 ( that ) 创建一个逻辑接口.你可以捆扎( bundle ...

  5. centos 网卡聚合及Cisco交换机链路聚合

    一.配置环境 centos 系统.网卡1口和2口做链路聚合.    交换机网口 6口和7口. 二.服务器操作步骤 centos 6 1.创建一个channel bonding interface #v ...

  6. LACP链路聚合控制协议

    LACP链路聚合控制协议 来源: https://www.cnblogs.com/taosim/articles/4378691.html http://storage.chinabyte.com/6 ...

  7. Port Channel and VPC

    1.Port Channel 介绍 Port Channel  简介 绑定多个物理链路(最多8条),到一个单一的逻辑链路,在两个物理设备之间 每个物理端口只能被放入一个port-channel中. 在 ...

  8. H3C交换机端口链路聚合

    H3C交换机端口链路聚合 以太网链路聚合 -- 以太网链路聚合配置命令 -- lacp system-prioritylacp system-priority命令用来配置系统的LACP优先级.undo ...

  9. 华为5700s配置链路聚合

    /创建聚合链路,数值可以随意. port link-type trunk /设置成trunk模式.(如果是接入vlan的话,link-type acess) port trunk allow-pass ...

随机推荐

  1. mysql查询某一列的数据最大字节

    语法:select 列名, length(列名) from 表名where length(列名) = ( select max(length(列名)) from 表名); 实例:select proj ...

  2. 关于TCP/IP协议的记录

    本博客是个人随笔,只是记录自己的学习过程.

  3. 03 Spring对Bean的管理

    Spring创建bean的三种方式 1.第一种方式:使用默认构造函数创建 bean.xml <?xml version="1.0" encoding="UTF-8& ...

  4. THINKPHP SQL注入处理方式

    //注入的产生一般都是对用户输入的参数未做任何处理直接对条件和语句进行拼装. //不安全的写法举例1 $_GET['id']=8;//希望得到的是正整数 $data=M('Member')->w ...

  5. DOM(innerHTML和className)

    <!DOCTYPE html> <html lang="en"> <head> <meta charset="UTF-8&quo ...

  6. 通过n+1个控制点求出n段分段函数的解析式

    最近刚好学了解析几何,在学完二元一次方程组与一次函数的关系后,我突然有了一个大胆的想法! 可不可以用程序自动求出一次函数的解析式呢? 这个想法源自于最近一段时间数学练习册上百考不厌的同类型题:给定在一 ...

  7. 012——C#打开ecxel修改数据(附教程)

    (一)参考文献:[C#]将数据写入已存在的excel文件 C# 导入excel数据,解决关闭excel后不能释放资源的问题 (二)视频教程:https://v.qq.com/x/page/p30063 ...

  8. icpc 银川 H. Delivery Route SPFA优化

    Problem Description Pony is the boss of a courier company. The company needs to deliver packages to ...

  9. 【csp模拟赛九】--dfs2

    dfs 代码: #include<algorithm> #include<iostream> #include<cstdio> using namespace st ...

  10. 【概率论】5-1:分布介绍(Special Distribution Introduction)

    title: [概率论]5-1:分布介绍(Special Distribution Introduction) categories: - Mathematic - Probability keywo ...