一、实验目的

1.  掌握 OSPFv3(v2) 的配置方法

2.  掌握在帧中继环境下 OSPFv3 (v2)的配置方法

3.  掌握 OSPFv3(v2) NSSA 的配置方法

4.  掌握外部路由汇总的配置

5.  掌握区域间路由的汇总配置

二、OSPFv2实验拓扑图

三、OSPFv2网络地址规划

IPv4地址表

Device

Interface

IP Address

R1

F0/0

10.1.19.1

S1/0

192.168.19.1

R3

S1/0

192.168.19.3

R4

S1/0

192.168.19.4

R5

F0/0

10.1.19.5

S1/0

12.1.19.5

R6

F0/0

10.1.19.6

F0/1

11.1.19.6

R7

F0/1

11.1.19.7

S1/0

12.1.19.7

R8

四、OSPFv2配置步骤

步骤1:开启R2帧中继交换功能

R2(config)#frame-relay switching

步骤2:配置各接口封装

R2(config)#interface Serial 1/2

R2(config-if)#no shutdown

R2(config-if)#clock rate 128000

R2(config-if)#encapsulation frame-relay

R2(config)#interface Serial 1/0

R2(config-if)#no shutdown

R2(config-if)#clock rate 128000

R2(config-if)#encapsulation frame-relay

R2(config)#interface Serial 1/1

R2(config-if)#no shutdown

R2(config-if)#clock rate 128000

R2(config-if)#encapsulation frame-relay

步骤3:配置LMI类型

R2(config)#interface Serial 1/2

R2(config-if)#frame-relay lmi-type cisco

R2(config-if)#frame-relay intf-type dce

R2(config)#interface Serial 1/0

R2(config-if)#frame-relay lmi-type cisco

R2(config-if)#frame-relay intf-type dce

R2(config)#interface Serial 1/1

R2(config-if)#frame-relay lmi-type cisco

R2(config-if)#frame-relay intf-type dce

步骤4:配置帧中继交换表

R2(config)#interface Serial 1/2

R2(config-if)#frame-relay route 103 interface Serial 1/0 301

R2(config-if)#frame-relay route 104 interface Serial 1/1 401

R2(config)#interface Serial 1/0

R2(config-if)#frame-relay route 301 interface Serial 1/2 103

R2(config)#interface Serial 1/1

R2(config-if)#frame-relay route 401 interface Serial 1/2 104

此时执行命令“show frame-relay route”来检查帧中继交换机是否正常:

步骤5:配置R1、R3、R4,使得它们能够互相通信

R1(config)#interface Serial 1/0

R1(config-if)#ip address 192.168.19.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#encapsulation frame-relay

R1(config-if)#frame-relay lmi-type cisco

R1(config-if)#no frame-relay inverse-arp     //关闭自动映射

R1(config-if)#frame-relay map ip 192.168.19.3 103 broadcast

R1(config-if)#frame-relay map ip 192.168.19.4 104 broadcast

R3(config)#interface Serial 1/0

R3(config-if)#ip address 192.168.19.3 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#encapsulation frame-relay

R3(config-if)#no frame-relay inverse-arp

R3(config-if)#frame-relay map ip 192.168.19.1 301 broadcast

R4(config)#interface Serial 1/0

R4(config-if)#ip address 192.168.19.4 255.255.255.0

R4(config-if)#no shutdown

R4(config-if)#encapsulation frame-relay

R4(config-if)#no frame-relay inverse-arp

R4(config-if)#frame-relay map ip 192.168.19.1 401 broadcast

执行ping命令测试:

R1 ping R3与R4

在R1执行命令“show frame-relay PVC”

显示存在两条本地连接。

步骤6:开始配置OSPF

先配置外部路由器OSPF(配置以R6、R1为例,R5、R7同理)

R6(config)#router ospf 1

R6(config-router)#router-id 6.6.6.6

R6(config-router)#area 1 nssa               //配置区域 1为 NSSA 区域

R6(config)#interface loopback 0

R6(config-if)#ip address 6.6.6.6 255.255.255.255

R6(config)#interface FastEthernet 0/0

R6(config-if)#ip address 10.1.19.6 255.255.255.0

R6(config-if)#no shutdown

R6(config-if)#ip ospf 1 area 0

R6(config-if)#interface FastEthernet 0/1

R6(config-if)#ip address 11.1.19.6 255.255.255.0

R6(config-if)#no shutdown

R6(config-if)#ip ospf 1 area 1

R6(config-if)#exit

R6(config)#router ospf 1

R6(config-router)#network 6.6.6.6 0.0.0.0 area 0

R6(config-router)#network 10.1.19.0 0.0.0.255 area 0

R6(config-router)#network 11.1.19.0 0.0.0.255 area 1

R1(config)#router ospf 1

R1(config-router)#router-id 1.1.1.1

R1(config)#interface loopback 0

R1(config-if)#ip address 1.1.1.1 255.255.255.255

R1(config)#interface FastEthernet 0/0

R1(config-if)#ip add 10.1.19.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#ip ospf 1 area 0

R1(config-if)#interface Serial 1/0

R1(config-if)#ip ospf 1 area 0

R1(config-if)#exit

R1(config)#router ospf 1

R1(config-router)#network 1.1.1.1 0.0.0.0 area 0

R1(config-router)#network 10.1.19.0 0.0.0.255 area 0

R1(config-router)#network 192.168.19.0 0.0.0.255 area 2

R1(config-router)#neighbor 192.168.19.3

R1(config-router)#neighbor 192.168.19.4

步骤7:配置帧中继中路由器的OSPF(以R3为例,R4同理)

R3(config)#router ospf 1

R3(config-router)#router-id 3.3.3.3

R3(config-router)#exit

R3(config)#interface loopback 0

R3(config-if)#ip address 3.3.3.3 255.255.255.255

R3(config-if)#ip ospf 1 area 2

R3(config-if)# interface Serial 1/0

R3(config-if)# ip ospf 1 area 2

R3(config-if)# ip ospf priority 0

R3(config)#router ospf 1

R3(config-router)#network 3.3.3.3 0.0.0.0 area 2

R3(config-router)#network 192.168.19.0 0.0.0.255 area 2

此时已完成OSPFv2配置,在R1上查OSPF邻居关系:

R1#show ipv6 ospf neighbor

接着测试路由通断情况,在R5上测试得出结果如下:

从内部到外部皆ping通,实验完成。

五、OSPFv3实验拓扑图

六、OSPFv3网络地址规划

IPv6地址表

Device

Interface

IPv6 Address

R1

F0/0

2123::19:1/64

S1/0.1

2356::19:1/64

Loopback 0

2011:19::1/128

R3

S1/0.1

2356::19:3/64

Loopback 0

2033:19::1/128

R4

S1/0.1

2356::19:4/64

Loopback 0

2044:19::1/128

R5

F0/0

2123::19:5/64

S1/0

2027::19:5/64

Loopback 0

2055:19::1/128

R6

F0/0

2123::19:6/64

Loopback 0

2066:19::1/128

Loopback 1

2166:19::1/128

R7

S1/0

2027::19:7/64

Loopback 0

2077:19::1/128

七、OSPFv3配置步骤

帧中继R2配置与第二部分OSPFv2相同。

步骤1:完成接口 IPv6地址的配置,并且在路由上配置 loopback0

R1(config)#ipv6 unicast-routing              //全局打开 IPv6路由功能

R1config)#interface loopback 0

R1(config-if)#ipv6 enable

R1(config-if)#ipv6 address 2011:19::1/128    //配置 loopback0接口地址

R1(config-if)#interface FastEthernet 0/0

R1(config-if)#ipv6 enable

R1(config-if)#ipv6 address 2123::19:1/64

R1(config-if)#no shutdown

R1(config-if)#interface Serial 1/0

R1(config-if)#ipv6 enable

R1(config-if)# encapsulation frame-relay

R1(config-if)#no shutdown

R1(config)#interface serial 1/0.1 multipoint

R1(config-subif)#ipv6 address 2356::19:1/64

R1(config-subif)#frame-relay map ipv6 2356::19:3 103 broadcast

R1(config-subif)#frame-relay map ipv6 2356::19:4 104 broadcast

R1(config-subif)#frame-relay map ipv6 2356::19:1 104 broadcast

R1(config-subif)#frame-relay map ipv6 FE80::C804:1CFF:FE48:8 104 broadcast

R1(config-subif)#frame-relay map ipv6 FE80::C803:1CFF:FE48:8 103 broadcast

R3(config)#ipv6 unicast-routing

R3(config)#interface loopback 0

R3(config-if)#ipv6 address 2033:19::1/128

R3(config-if)# interface Serial 1/0

R3(config-if)#ipv6 enable

R3(config-if)# encapsulation frame-relay

R3(config-if)#no shutdown

R3(config)#interface serial 1/0.1 multipoint

R3(config-subif)#ipv6 address 2356::19:3/64

R3(config-subif)#frame-relay map ipv6 2356::19:1 301 broadcast

R3(config-subif)#frame-relay map ipv6 2356::19:4 301 broadcast

R3(config-subif)#frame-relay map ipv6 2356::19:3 301 broadcast

R3(config-subif)#frame-relay map ipv6 FE80::C804:1CFF:FE48:8 304 broadcast

R3(config-subif)#frame-relay map ipv6 FE80::C801:1CFF:FE48:8 301 broadcast

R4(config)#ipv6 unicast-routing

R4(config)#interface loopback 0

R4(config-if)#ipv6 address 2044:19::1/128

R4(config-if)# interface Serial 1/0

R4(config-if)#ipv6 enable

R4(config-if)# encapsulation frame-relay

R4(config-if)#no shutdown

R4(config)#interface serial 1/0.1 multipoint

R4(config-subif)#ipv6 address 2356::19:4/64

R4(config-subif)#frame-relay map ipv6 2356::19:1 401 broadcast

R4(config-subif)#frame-relay map ipv6 2356::19:4 401 broadcast

R4(config-subif)#frame-relay map ipv6 2356::19:3 401 broadcast

R4(config-subif)#frame-relay map ipv6 FE80::C803:1CFF:FE48:8 403 broadcast

R4(config-subif)#frame-relay map ipv6 FE80::C801:1CFF:FE48:8 401 broadcast

执行ping命令测试:

尝试R1上ping通 R3和R4

用“show frame-relay pvc”命令查看:

帧中继配置完成。

步骤2:按实验拓扑图标识的区域,完成 OSPFv3的基本配置。其中区域 1NSSA 区域。

R6(config)#ipv6 unicast-routing

R6(config)#ipv6 router ospf 1            //启动 OSPFv3进程

R6(config-rtr)#router-id 6.6.6.6

R6(config-rtr)#area 1 nssa              //配置区域 1为 NSSA 区域

R6(config-rtr)#interface FastEthernet 0/0

R6(config-if)#ipv6 enable

R6(config-if)# ipv6 ospf 1 area 0

R6(config-if)#no shutdown

R6(config-if)#int loopback 0

R6(config-if)#ipv6 enable

R6(config-if)#ipv6 address 2066:19::1/128

R6(config-if)# ipv6 ospf 1 area 0

R6(config-if)#interface FastEthernet 0/1

R6(config-if)#ipv6 enable

R6(config-if)# ipv6 ospf 1 area 1

R6(config-if)#no shutdown

R5(config)#ipv6 unicast-routing

R5(config)#ipv6 router ospf 1          //启动 OSPFv3进程

R5(config-rtr)#router-id 5.5.5.5

R5(config-rtr)#area 1 nssa            //配置区域 1 为 NSSA 区域

R5(config-rtr)#interface FastEthernet 0/0

R5(config-if)#ipv6 enable

R5(config-if)# ipv6 ospf 1 area 0

R5(config-if)#no shutdown

R5(config-if)#int loopback 0

R5(config-if)#ipv6 enable

R5(config-if)#ipv6 address 2055:19::1/128

R5(config-if)# ipv6 ospf 1 area 0

R5(config-if)#interface Serial 1/0

R5(config-if)#ipv6 enable

R5(config-if)# ipv6 ospf 1 area 1

R5(config-if)#no shutdown

R1(config)#ipv6 unicast-routing

R1(config)#ipv6 router ospf 1         //启动 OSPFv3 进程

R1(config-rtr)#router-id 1.1.1.1

R1(config-rtr)#interface FastEthernet 0/0

R1(config-if)#ipv6 enable

R1(config-if)# ipv6 ospf 1 area 0

R1(config-if)#no shutdown

R1(config-if)#int loopback 0

R1(config-if)#ipv6 enable

R1(config-if)#ipv6 address 2011:19::1/128

R1(config-if)# ipv6 ospf 1 area 0

R1(config-if)#interface Serial 1/0.1

R1(config-subif)#ipv6 enable

R1(config-subif)# ipv6 ospf 1 area 2

R1(config-subif)#ipv6 ospf neighbor FE80::C803:1CFF:FE48:8

R1(config-subif)#ipv6 ospf neighbor FE80::C804:1CFF:FE48:8

R1(config-subif)# ipv6 address FE80::C801:1CFF:FE48:8 link-local

R3(config)#ipv6 router ospf 1

R3(config-rtr)#router-id 3.3.3.3

R3(config-rtr)#interface loopback 0

R3(config-if)#ipv6 enable

R3(config-if)#ipv6 address 2033:19::1/128

R3(config-if)# ipv6 ospf 1 area 2

R3(config-if)#interface Serial 1/0.1

R3(config-subif)#ipv6 enable

R3(config-subif)# ipv6 ospf 1 area 2

R3(config-subif)# ipv6 ospf priority 0

R3(config-subif)# ipv6 address FE80::C803:1CFF:FE48:8 link-local

R4config)#ipv6 router ospf 1

R4config-rtr)#router-id 4.4.4.4

R4config-rtr)#interface loopback 0

R4config-if)#ipv6 enable

R4(config-if)#ipv6 address 2044:19::1/128

R4(config-if)# ipv6 ospf 1 area 2

R4(config-if)#interface Serial 1/0.1

R4(config-subif)#ipv6 enable

R4(config-subif)# ipv6 ospf 1 area 2

R4(config-subif)# ipv6 ospf priority 0

R4(config-subif)# ipv6 address FE80::C804:1CFF:FE48:8 link-local

R7(config)#ipv6 unicast-routing

R7(config)#ipv6 router ospf 1            //启动 OSPFv3进程

R7(config-rtr)#router-id 7.7.7.7

R7(config-rtr)#area 1 nssa              //配置区域 1为 NSSA 区域

R7(config-rtr)#int s 1/0

R7(config-if)#ipv6 enable

R7(config-if)# ipv6 ospf 1 area 1

R7(config-if)#no shutdown

R7(config-if)#int loopback 0

R7(config-if)#ipv6 enable

R7(config-if)#ipv6 address 2077:19::1/128

R7(config-if)# ipv6 ospf 1 area 1

R7(config-if)#interface FastEthernet 0/1

R7(config-if)#ipv6 enable

R7(config-if)# ipv6 ospf 1 area 1

R7(config-if)#no shutdown

步骤3:检查 OSPFv3的邻居关系

R3上检查,可以看到邻居的 Router-ID都是用 IPv4的地址格式标识

R1#show ipv6 ospf neighbor

步骤4:测试路由通断情况在R4测试,OSPFv3配置成功

在本实验步骤基础上引入外部路由类型 5和外部路由类型 7

(1) 在 R6上新增加一个loopback1接口,地址为2166::1/128,然后重分布进入OSPFv3:

R6(config)#interface loopback 1

R6(config-if)#ipv6 address 2166:19::1/128

R6(config-if)#exit

R6(config)#ipv6 router ospf 1

R6(config-rtr)#redistribute connected

(2)配置R7和R8的RIPng,然后重分布RIPng 到OSPFv3:

R8(config)#ipv6 router rip yeslab

R8(config-rtr)#exit

R8(config)#interface FastEthernet 0/0

R8(config-if)#ipv6 rip yeslab enable

R8(config-if)#exit

R7(config)#ipv6 router rip yeslab

R7(config-rtr)#exit

R7(config)#interface FastEthernet 0/0

R7(config-if)#ipv6 rip yeslab enable

R7(config-if)#exit

R7(config)#ipv6 router ospf 1

R7(config-rtr)#redistribute rip yeslab         //重分布RIPng到OSPFv3

R7(config-rtr)#redistribute connected

//由于重分布RIPng,不能把连接R7的接口网段重分布进入OSPFv3,因此重分布直连,把连接R7的网段重分布到OSPFv3

八、心得体会

本次实验在IPv4的OSPFv2实验配置基础上进行IPv6的OSPFv3实验配置,在配置中遇到了许多问题,包括IPv6地址的路由分配以及在OSPFv3的步骤基础上引入RIPng重分布,在与小组成员的讨论中合理进行了组网规划并确定好OSPF区域,在这一环节上加深了对OSPF的理解。通过OSPFv2以及OSPFv3对比实验,也让我明白了IPv4和IPv6的异同,为之后的IP课程学习打下了良好的基础。

OSPFv3综合实验(GNS3)的更多相关文章

  1. 第三组 通信一班 030 OSPFv2、OSPFv3综合实验

      一.        实验目的 掌握 OSPFv2. OSPFv3 的配置方法 掌握在帧中继环境下OSPFv2. OSPFv3 的配置方法 掌握 OSPFv2. OSPFv3 NSSA 的配置方法 ...

  2. OSPFV3综合实验 (第三组)

    拓扑图 本次试验规划:拓扑分4个区域,其中区域2采用帧中继实现区域内互通的前提下配置OSPF.ospfv3.R7与R8之间配置rip实现互通,区域1作为nssa区域,实现路由注入.最终实现全局互通. ...

  3. 第九组 通信3班 063 OSPFv2与OSPFv3综合实验

    实验目的 1. 掌握 OSPFv3(v2) 的配置方法 2. 掌握在帧中继环境下 OSPFv3 (v2)的配置方法 3. 掌握 OSPFv3(v2) NSSA 的配置方法 4. 掌握外部路由汇总的配置 ...

  4. 【Linux程序设计】之环境系统函数综合实验

    这个系列的博客贴的都是我大二的时候学习Linux系统高级编程时的一些实验程序,都挺简单的.贴出来纯粹是聊胜于无. 实验题目:Linux环境下系统函数综合实验 实验目的:熟悉并掌握Linux环境下数学函 ...

  5. CCNP第四天 OSPF综合实验(1)

    ospf综合实验(1) 本实验主要考察ospf中的接口上的多种工作方式 实验如图所示: 所用拓扑为CCNP标准版,如图: --------------------------------------- ...

  6. (6综合实验)从零开始的嵌入式图像图像处理(PI+QT+OpenCV)实战演练

    从零开始的嵌入式图像图像处理(PI+QT+OpenCV)实战演练 1综述http://www.cnblogs.com/jsxyhelu/p/7907241.html2环境架设http://www.cn ...

  7. 华为路由交换综合实验 ---IA阶段

    目录 华为路由交换综合实验 ---IA阶段 实验拓扑 实验需求 华为路由交换综合实验 ---IA阶段 实验拓扑 实验需求 根据拓扑合理规划IP地址以及VLANIf地址(PC1属于运营部,PC2属于市场 ...

  8. CCNA 之 综合实验

    CCNA 综合实验 需要:根据下列图中的网路拓扑,搭建环境; PC1属于VLAN10:PC2属于VLAN20:网关均在OR_C2811: VLAN10.20对应的网段分别为192.168.10.0.2 ...

  9. OSPF与ACL综合实验

    OSPF与ACL综合实验 1.实验内容 (1)企业内网运行OSPF路由协议,区域规划如拓扑图所示(见3.实验拓扑图): (2)财务和研发所在的区域不受其他区域链路不稳定性影响: (3)R1.R2.R3 ...

随机推荐

  1. Listen and Write 18th Feb 2019

    Weighted blanket has becomes very popular in many homes. they claim it can provide better sleep and ...

  2. C语言数据结构基础学习笔记——树

    树是一种一对多的逻辑结构,树的子树之间没有关系. 度:结点拥有的子树数量. 树的度:树中所有结点的度的最大值. 结点的深度:从根开始,自顶向下计数. 结点的高度:从叶结点开始,自底向上计数. 树的性质 ...

  3. 问题-python3.6找不到tkinter

    问题:import tkinter失败 然后直接pip安装也不ok python3.6安装过程中会提示是否选择安装tkinter,如此只有打开原来的安装程序 勾选箭头所示

  4. [python,2018-06-29] 37%法则及其拓展解决恋爱问题

    37%法则 苏格拉底的问题: 在一片麦田里摘出一颗最大最好的麦穗.但只能摘一次,而且不能回头. 传说这是苏格拉底给他的弟子柏拉图提出的问题,又传说柏拉图进行了2次选择: 1.柏拉图第一次走进麦田,他发 ...

  5. 数据分析与科学计算可视化-----用于科学计算的numpy库与可视化工具matplotlib

    一.numpy库与matplotlib库的基本介绍 1.安装 (1)通过pip安装: >> pip install matplotlib 安装完成 安装matplotlib的方式和nump ...

  6. Django自定义模板标签和过滤器

    1.创建模板库 在某个APP所在目录下新建包templatetags,然后在其中创建存储标签或者过滤器的的模块,名称随意,例如myfilters.py. 在这个模块中编写相关代码. 注意:templa ...

  7. python--面向过程编程与面向对象编程

    面向过程 面向过程: 核心就是过程二字,过程指的是解决问题的步骤,设计一条流水线,机械式的思维方式. 优点: 复杂的问题流程化,进而简单化. 缺点: 可扩展性差. 面向对象 面向对象: 核心就是对象二 ...

  8. V-REP Remote API(C++)实现简单的关节转动

    基础内容参考:https://www.cnblogs.com/eternalmoonbeam/p/10753149.html V-REP客户端设置: 在V-REP场景文件中需要添加三个实体,包括两个形 ...

  9. Redis系列十:缓存雪崩、缓存穿透、缓存预热、缓存更新、缓存降级

    一.缓存雪崩 缓存雪崩我们可以简单的理解为:由于原有缓存失效,新缓存未到期间(例如:我们设置缓存时采用了相同的过期时间,在同一时刻出现大面积的缓存过期),所有原本应该访问缓存的请求都去查询数据库了,而 ...

  10. MySQL自增列锁模式 innodb_autoinc_lock_mode不同参数下性能测试

    对于innodb_autoinc_lock_mode 各种参数的值的含义,网上也有各种详解,看完觉得意犹未尽,这里不做阐述,只动手测试,看看性能上,到底有没有理论上所说的差别.对于自增列的锁定,据说是 ...