RIP协议分为版本1和版本2,均具备以下特征:
1.是距离向量路由协议
2.使用跳数(Hop Count)作为度量值
3.默认路由更新周期为30秒
4.管理距离(AD)为120
5.支持触发更新
6.最大跳数为15跳
7.支持等价路径,默认4跳,最大6条
8.使用UDP520端口进行路由更新

RIPv1:
1.在路由更新过程中不携带子网信息
2.不提供认证
3.不支持VLSM和CIDR
4.采用广播更新
5.有类(Classful)路由协议

RIPv2:
1.在路由更新过程中携带子网信息
2.提供明文和MD5认证
3.支持VLSM和CIDR
4.采用组播(224.0.0.9)更新
5.无类(Classless)路由协议

1.RIPv1
2.RIPv2
3.RIPv1与RIPv2兼容
4.在接口上禁止运行RIP
5.RIPv2单播更新
6.RIPv2自动汇总
7.RIPv2手动汇总
8.RIPv2产生默认路由
9.RIPv2明文认证
10.RIPv2 MD5认证
11.RIP过滤路由

enable
conf t
no ip do lo
enable pass cisco
line con 0
logg sync
exec-t 0 0
line vty 0 4
pass cisco
logg sync
exit
host
1.RIP版本1
-------------------------------------------------------------
R1:
int f0/0
ip add 12.1.1.1 255.255.255.0
no shut
exit
int l0
ip add 11.1.1.1 255.255.255.0
no shut
exit

router rip
version 1
network 11.0.0.0
network 12.0.0.0

R2:
int f0/0
ip add 12.1.1.2 255.255.255.0
no shut
exit
int f1/0
ip add 23.1.1.2 255.255.255.0
no shut
exit
int l0
ip add 22.1.1.1 255.255.255.0
no shut
exit

router rip
version 1
network 12.0.0.0
network 23.0.0.0
network 22.0.0.0

R3:
int f0/0
ip add 23.1.1.3 255.255.255.0
no shut
exit
int l0
ip add 33.1.1.1 255.255.255.0
no shut
exit

router rip
version 1
network 33.0.0.0
network 23.0.0.0

R1:
show ip route

2.RIP版本2
----------------------------------------------
R1:
router rip
version 2
no auto-summary

R2:
router rip
version 2
no auto-summary

R3:
router rip
version 2
no auto-summary

R1:
clear ip route *
show ip route

3.RIP版本1与版本2兼容
-------------------------------------------------
R3:
router rip
version 1

show ip route

R2:
show ip route

int f1/0
ip rip send version 1
ip rip receive version 1

4.在接口禁止运行RIP
-----------------------------------------------
R2:
int f1/0
no ip rip send version 1
no ip rip receive version 1

R3:
router rip
version 2
exit

R1:
router rip
passive-interface f0/0

R2/R1:
clear ip route *
show ip route

5.RIPv2单播更新
-------------------------------------------------------
R2:
router rip
passive-interface f0/0
exit

R1:
router rip
neighbor 12.1.1.2
exit

R2:
router rip
neighbor 12.1.1.1
exit

R1:
show ip route

6.RIPv2自动汇总
-----------------------------------------------------------
R1:
router rip
no passive-interface f0/0
no neighbor 12.1.1.2
auto-summary
exit

R2:
router rip
no passive-interface f0/0
no neighbor 12.1.1.1
auto-summary
exit

R3:
router rip
auto-summary
exit

7.RIPv2手动汇总
-----------------------------------------------------
R1:
router rip
no auto-summary
exit

R2:
router rip
no auto-summary
exit

R3:
router rip
no auto-summary
exit

R2:
int f0/0
ip summary-add rip 1.1.0.0 255.255.0.0
exit

8.RIPv2产生默认路由
-----------------------------------------------------
R3:
router rip
default-information originate
exit

router rip
no default-information originate
exit

int l1
ip add 10.1.1.1 255.0.0.0
exit
ip default-network 10.0.0.0

no ip default-network 10.0.0.0
int l1
shutdown
exit

ip route 0.0.0.0 0.0.0.0 null 0
router rip
network 0.0.0.0
exit

router rip
no network 0.0.0.0
exit

router rip
redistribute static
exit

R1:
clear ip route *
show ip route rip

9.RIPv2明文认证
----------------------------------------------------------
R1:
key chain yeslab
key 1
key-string cisco
exit
exit

int f0/0
ip rip authentication mode text
ip rip authentication key-chain yeslab
exit

R2:
key chain yeslab
key 1
key-string cisco
exit
exit

int f0/0
ip rip authentication mode text
ip rip authentication key-chain yeslab
exit

10.RIPv2 MD5认证
-----------------------------------------------------------
R2:
key chain yeslab2
key 1
key-string yeslab
exit
exit

int f1/0
ip rip authentication mode md5
ip rip authentication key-chain yeslab2
exit

R3:
key chain yeslab3
key 1
key-string yeslab
exit
exit

int f0/0
ip rip authentication mode md5
ip rip authentication key-chain yeslab3
exit

11.RIP过滤路由
R3:
access-list 10 deny 11.1.1.0
access-list 10 permit any

rotuer rip
distribute-list 10 in
exit

CCNA实验(3) -- RIP的更多相关文章

  1. Packet Tracer 5.0 构建CCNA实验(2)—— 配置VLAN

    Packet Tracer 5.0 构建CCNA实验(2)—— 配置VLAN Vlan(Virtual Local Area Network) 即虚拟局域网.VLAN可以把同一个物理网络划分为多个逻辑 ...

  2. 实验10: RIP

    实验7-1 :  RIPV1 实验目的通过本实验可以掌握:1. 在路由器上启动RIPv1 路由进程2. 启用参与路由协议的接口,并且通告网络3. 理解路由表的含义4. 查看和调试RIPv1 路由协议相 ...

  3. CCNA实验4:HDLC和PPP

    一.HDLC封装 router9和11上分别配置s0/0如下 conf t int s0/0 encapsulation hdlc do show int s0/0 ip address x.x.x. ...

  4. CCNA实验(9) -- Frame Relay

    帧中继的一些特点:1.中小企业常用的广域网线路2.通信费用较低3.配置较为复杂 1.将Cisco路由器配置为帧中继交换机2.帧中继基本配置.帧中继映射3.在帧中继的链路上运行RIPv24.帧中继的多点 ...

  5. CCNA实验2.VLAN

    一. 二.配置主VTP上的信息 sw2上配置为domain server,sw1上配置为domain client,sw2上增加vlan并命名和添加描述 conf t vtp domain corp ...

  6. CCNA实验1.port-security

    一, 二,MAC地址绑定 3550-1#conf t3550-1(config)#int f0/13550-1(config-if)#switchport mode access /指定端口模式.35 ...

  7. CCNA实验(1) -- 基本配置

    Ctrl+A: 到行首(Ahead)Ctrl+E: 到行尾(End)Esc+B: 回退一个单词(Back)Esc+F: 前进一个单词(Forward) 1.三种配置模式2.时间时区配置3.设置超时时间 ...

  8. CCNA实验(2) -- Static Route

    1.静态路由R1:ip route 22.1.1.0 255.255.255.0 12.1.1.2 2.静态汇总路由R1:ip route 22.1.0.0 255.255.0.0 12.1.1.2 ...

  9. CCNA实验(5) -- OSPF

    enableconf tno ip do loenable pass ciscoline con 0logg syncexec-t 0 0line vty 0 4pass ciscologg sync ...

随机推荐

  1. 关于Condition Variable的一些思考

    可能大家都使用过condition variable(之后称cv),一些博客也对cv做了介绍,但是有的说的不完全正确,甚至有误导使用者的倾向,其实最合理的使用方式是查阅文档, 如果你英语还ok的话,h ...

  2. background-size使用

    background-size: left center | 0% 50% | cover | contain backgound-size: left center | 0% 50%; 这个指的是背 ...

  3. s3c6410学习笔记-烧写uboot+构建文件系统

    一.进入目录 #cd u-boot-1.1.6_sndk6410 二.SD卡 make clean make distclean vim Makefile                       ...

  4. MySQLdb autocommit

    MySQLdb 中 autocommit 默认是关闭的,下面是例子. import MySQLdb conn = MySQLdb.connect(host='127.0.0.1',user='root ...

  5. Oracle EBS-SQL (GL-4):从接收追溯到接收事务

    SELECT row_id, creation_date, created_by, last_update_date, last_updated_by,last_update_login, note_ ...

  6. MBG 相关资源链接

    MyBatis Generator(MBG)相关资源链接 http://mbg.cndocs.tk/quickstart.html http://www.mybatis.tk/ http://git. ...

  7. C语言入门(14)——结构体

    整数.字符.布尔值.浮点数这些数据类型都具有单一的值,这些可称为基本数据类型.但字符串是一个例外,它由很多字符组成,像这种由基本类型组成的数据类型称为复合数据类型,正如表达式和语句有组合规则一样,由基 ...

  8. c语言libcurl 使用实例get/post方法+c语言字符串处理

    #include <stdio.h> #include <curl/curl.h> #include <string.h> #include <ctype.h ...

  9. COCOS2d-x简易安装步骤

    准备工作:1.    下载 cocos2d-x  下载地址:http://cdn.cocos2d-x.org/cocos2d-x-2.2.zip2.    下载 python 2.7.3 下载地址:h ...

  10. POJ1008

    2014-08-22 题意: (有中文版题目..)  就是两种历法的转换 思路: 把两种历法的细节了解了就很简单了 Haab历法一年365,Tzolkin一年260天 先求出总天数sumDay,然后s ...