IP SLA(Internet Protocol Service-Level Agreement)互联网服务等级协议,本实验里通过发送测试报文,测试下一跳是否可达,结合Track实现冗余静态路由的切换。

实验环境:

模拟器:GNS3-1.5.2

路由器IOS 版本:C2691-ADVENTERPRISEK9-M)

交换机IOS版本:(C3640-IK9S-M), Version 12.4(10)

终端:VPCS

 

 

------------------------------网络接口配置---------------------------------------------

 

R1:

R1#sho ip interface brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/1 172.16.20.1 YES NVRAM up up

FastEthernet1/0 192.168.1.2 YES NVRAM up up

Tunnel0 172.18.1.2 YES NVRAM up up

R1(config)#interface Tunnel0

ip address 172.18.1.2 255.255.255.0

keepalive 10 3

tunnel source FastEthernet0/1

tunnel destination 10.1.1.4

 

R2:

R2#sho ip inter bri

Interface IP-Address OK? Method Status Protocol

FastEthernet0/1 192.168.1.3 YES NVRAM up up

FastEthernet1/0 172.16.50.1 YES NVRAM up up

Tunnel0 172.18.2.2 YES NVRAM up up

 

R2(config)#interface Tunnel0

ip address 172.18.2.2 255.255.255.0

tunnel source FastEthernet1/0

tunnel destination 10.1.1.4

 

R3:

R3#sh ip int bri

Interface IP-Address OK? Method Status Protocol

FastEthernet0/1 172.16.20.2 YES NVRAM up up

FastEthernet1/0 10.1.1.2 YES NVRAM up up

 

R4:

R4#show ip int br

Interface IP-Address OK? Method Status Protocol

FastEthernet1/0 172.16.50.2 YES NVRAM up up

FastEthernet1/1 10.1.1.3 YES NVRAM up up

 

R5:

 

R5#sh ip int br

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 unassigned YES unset up up

FastEthernet0/1 unassigned YES unset up up

FastEthernet0/10 10.248.0.1 YES NVRAM up up

Vlan10 10.1.1.4 YES NVRAM up up

Tunnel0 172.18.1.1 YES NVRAM up up

Tunnel1 172.18.2.1 YES NVRAM up up

R5(config)#interface Tunnel0

ip address 172.18.1.1 255.255.255.0

tunnel source Vlan10

tunnel destination 172.16.20.1

exit

interface Tunnel1

ip address 172.18.2.1 255.255.255.0

tunnel source Vlan10

tunnel destination 172.16.50.1

 

Sw1:

 

sw1#sh ip int br

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 unassigned YES unset up up

FastEthernet0/1 unassigned YES unset up up

FastEthernet0/10 20.1.1.1 YES NVRAM up up

Vlan10 192.168.1.4 YES NVRAM up up

 

VPCS:

PC1> ip 20.1.1.2/24 20.1.1.1
PC2> ip 10.248.0.2/24 10.248.0.1

 

--------------------------------------------------IP SLA与静态路由配置命令---------------------------------------------------------------

R1:


R1(config-sla-monitor)#type echo protocol ipIcmpEcho 10.1.1.4

life forever start-time now
R1(config)#track 10
rtr 10
reachability
R1(config-track)#exit

R1(config)#ip route 10.1.1.0 255.255.255.0 172.16.20.2

R1(config)#ip route 10.248.0.0 255.255.255.0 Tunnel0

R1(config)#ip route 20.1.1.0 255.255.255.0 192.168.1.4

 

R2:


R2(config-sla-monitor)#type echo protocol ipIcmpEcho 10.1.1.4

life forever start-time now
R2(config)#track 10

reachability

R2(config-track)#exit

R2(config)#ip route 10.1.1.0 255.255.255.0 172.16.50.2

R2(config)#ip route 10.248.0.0 255.255.255.0 Tunnel0

R2(config)#ip route 20.1.1.0 255.255.255.0 192.168.1.4

 

R3:

R3(config)#ip route 10.248.0.0 255.255.255.0 10.1.1.4

R3(config)#ip route 20.1.1.0 255.255.255.0 172.16.20.1

R3(config)#ip route 172.17.1.0 255.255.255.0 172.16.20.1

R3(config)#ip route 192.168.1.0 255.255.255.0 172.16.20.1

 

R4:

R4(config)#ip route 10.248.0.0 255.255.255.0 10.1.1.4

R4(config)#ip route 20.1.1.0 255.255.255.0 172.16.50.1

R4(config)#ip route 172.17.2.0 255.255.255.0 172.16.50.1

R4(config)#ip route 192.168.1.0 255.255.255.0 172.16.50.1

 

R5:

R5(config(config-sla-monitor)#type echo protocol ipIcmpEcho 172.16.20.1 source-interface Vlan10 //从vlan10 去ping 172.16.20.1

R5
(config-sla-monitor-echo)#timeout 5000 //5秒没有响应,认为掉线

R5
(config-sla-monitor-echo)#frequency 3 //每3秒PING 一次

life forever start-time now

reachability

R5(config-track)#exit

R5(config)#ip route 20.1.1.0 255.255.255.0 Tunnel1 10

R5(config)#ip route 172.16.20.0 255.255.255.0 Vlan10

R5(config)#ip route 172.16.50.0 255.255.255.0 Vlan10

 

-----------------------------------------------------VRRP配置---------------------------------------------------------------------

R1:

R1(config)#interface FastEthernet1/0

ip address 192.168.1.2 255.255.255.0

vrrp 10 ip 192.168.1.1

vrrp 10 priority 250

standby 1 preempt

vrrp 10 track 10 decrement 100 //当出现SLA出现中断时,把自己的优先级降低100.

 

R1:

R2(config)#interface FastEthernet0/1

ip address 192.168.1.3 255.255.255.0

vrrp 10 ip 192.168.1.1

vrrp 10 priority 200

 

-----------------------------------------------------测试---------------------------------------------------------------------

 

中断master任意节点,切线路自动切换.

 

 

在双方设备条件允许情况下,可以使用 BFD检测机制,提供毫秒级检测。大多数情况下,由于网络设备厂商不同、设备新旧程度不同,可能不支持BFD协议,所以IP SLA作为备选方案提供秒级的检测。华为的NQA技术和cisco IP SLA类似。

VRRP+tunnel+IP SLA+Track实现冗余切换的更多相关文章

  1. Cisco IOS IP Service Level Agreementv (IP SLA)

    Responder and Control Protocol 1.Responder内嵌在思科目标路由器中的一个组件,用来对IP SLA请求包做应答,通过对应达包添加时间戳属性,以提高测量计算的准确性 ...

  2. VRRP虚IP漂移

    简介 VRRP 是 Virtual Router Redundancy Protocol 的简称,即 虚拟路由冗余协议 . 原文地址:https://linux-network-programming ...

  3. openstack私有云布署实践【3 keepalive配置(VRRP虚IP)】

    这里只用到keepalived 或者pacemaker两种方法,可二选一来配置,官方提供的是pacemaker,但我们实际测试环境和生产环境上使的是keepalive     首先在4台control ...

  4. [转]openstack-kilo--issue(十四)Tunnel IP %(ip)s in use with host %(host)s'

    bug: http://lists.openstack.org/pipermail/openstack-operators/2015-August/007924.html https://bugs.l ...

  5. 理解 OpenStack 高可用(HA)(2):Neutron L3 Agent HA 之 虚拟路由冗余协议(VRRP)

    本系列会分析OpenStack 的高可用性(HA)概念和解决方案: (1)OpenStack 高可用方案概述 (2)Neutron L3 Agent HA - VRRP (虚拟路由冗余协议) (3)N ...

  6. 架构-虚拟路由器冗余协议【原理篇】VRRP详解

    转自:http://zhaoyuqiang.blog.51cto.com/6328846/1166840/ 为什么要使用VRRP技术 我们知道,为了实现不同子网之间的设备通信,需要配置路由.目前常用的 ...

  7. (转)虚拟路由器冗余协议【原理篇】VRRP详解

    原文:http://blog.51cto.com/zhaoyuqiang/1166840 为什么要使用VRRP技术 我们知道,为了实现不同子网之间的设备通信,需要配置路由.目前常用的指定路由方法有两种 ...

  8. VRRP(Virtual Router Redundancy Protocol) 虚拟路由器冗余协议简介

    因工作中使用Keepalived配置Nginx代理和MySQL代理的高可用,而Keepalived是VRRP协议在linux上的软件实现.因此了解了下VRRP的基础. 1. VRRP技术的引入 随着I ...

  9. 冗余网络构建方案对比:VRRP协议、多网卡绑定及WN202冗余链路网卡

    在组建网络时为网络设计冗余方案已经成为提高网络可用性必不可少的一环,伴随着网络技术的发展实现网络冗余的技术方案也是层出不穷,例如应用于服务器端的HA.LB,应用于存储的SAN.DAS.NAS等.本文重 ...

随机推荐

  1. November 8th 2016 Week 46th Tuesday

    When he can't, he tries a new way to share a new pair. 当他做不到时,他尝试一种新的方式:分享. To share, your failing e ...

  2. 我的Java之旅——之后的学习计划

      在写完第一个Java程序之后,对于一些最最基本的东西有了大致的了解,对于之后的学习,我做了简单的计划. 7月17号:补充一些基本内容. 7月18.19号: 1. Java的一些常用类,包括 :Nu ...

  3. springmvc细节篇

    前面讲了入门篇,现在来了解下springmvc的细节.mvc框架都有请求映射.数据绑定.请求处理.视图解析这几个过程,现在我们来了解springmvc中的这些细节. 1.使用@RequestMappi ...

  4. Cent OS home下中文目录改成英文目录

    如果安装了中文版的Cent OS之后,root目录和home目录下会出现中文的路径名,如“桌面”.“文档”.“图片”.“公共的”.“下载”.“音乐”.“视频”等目录,这样在命令行上操作十分的不方便,需 ...

  5. java.lang.NoClassDefFoundError: org/apache/ibatis/mapping/DatabaseIdProvider

    我用的方案是:maven+struts2+spring+mybatis 出现上述错误的原因是: <dependency>            <groupId>org.myb ...

  6. Uva442

    https://vjudge.net/problem/UVA-442 思路: 1)当遇到左括号将字母进栈,遇到右括号将字母出栈. 2) isalpha() 判断一个字符是否是字母 int isalph ...

  7. L1-046. 整除光棍(模拟竖式计算除法)

    L1-046. 整除光棍 时间限制 400 ms 内存限制 65536 kB 代码长度限制 8000 B 判题程序 Standard 作者 翁恺 这里所谓的“光棍”,并不是指单身汪啦~ 说的是全部由1 ...

  8. java spring boot项目部署-上

    1.编写sh脚本,便于服务器上管理工程: #!/bin/bash source /etc/profile PROG_NAME=$ ACTION=$ usage() { echo "Usage ...

  9. CanOpen协议【CanFestival】移植方法 支持VC、QT、STM32

    前段时间学习了CanOpen协议,到网上下载的CanFestival3-10源码,移植到VC.QT.STM32等平台,由于网上的资源较少,走了不少弯路,移植好使用过程中才逐渐暴露出各种问题,比如OD字 ...

  10. 02_Docker在CentOS 6和CentOS 7下的安装

    CentOS 7 环境下安装docker 安装Docker 检查系统内核是否高于Linux3.10版本 uname -r 使用root权限操作,确保yum包是最新版本 sudo yum update ...